summaryrefslogtreecommitdiffstats
path: root/third_party/rust/winreg/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/winreg/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/winreg/Cargo.toml')
-rw-r--r--third_party/rust/winreg/Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/third_party/rust/winreg/Cargo.toml b/third_party/rust/winreg/Cargo.toml
new file mode 100644
index 0000000000..adb2e88655
--- /dev/null
+++ b/third_party/rust/winreg/Cargo.toml
@@ -0,0 +1,75 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "winreg"
+version = "0.10.1"
+authors = ["Igor Shaula <gentoo90@gmail.com>"]
+description = "Rust bindings to MS Windows Registry API"
+documentation = "https://docs.rs/winreg"
+readme = "README.md"
+keywords = ["Windows", "WinSDK", "Registry"]
+categories = ["api-bindings", "os::windows-apis"]
+license = "MIT"
+repository = "https://github.com/gentoo90/winreg-rs"
+[package.metadata.docs.rs]
+all-features = true
+targets = ["x86_64-pc-windows-msvc", "i686-pc-windows-msvc"]
+
+[[example]]
+name = "basic_usage"
+required-features = ["chrono"]
+
+[[example]]
+name = "enum"
+
+[[example]]
+name = "load_app_key"
+
+[[example]]
+name = "transactions"
+required-features = ["transactions"]
+
+[[example]]
+name = "serialization"
+required-features = ["serialization-serde"]
+
+[[example]]
+name = "map_key_serialization"
+required-features = ["serialization-serde"]
+
+[[example]]
+name = "installed_apps"
+required-features = ["serialization-serde"]
+[dependencies.chrono]
+version = "0.4.6"
+optional = true
+
+[dependencies.serde]
+version = "1"
+optional = true
+
+[dependencies.winapi]
+version = "0.3.9"
+features = ["impl-default", "impl-debug", "minwindef", "minwinbase", "timezoneapi", "winerror", "winnt", "winreg", "handleapi"]
+[dev-dependencies.rand]
+version = "0.3"
+
+[dev-dependencies.serde_derive]
+version = "1"
+
+[dev-dependencies.tempfile]
+version = "~3.0"
+
+[features]
+serialization-serde = ["transactions", "serde"]
+transactions = ["winapi/ktmw32"]