summaryrefslogtreecommitdiffstats
path: root/third_party/rust/extend/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/extend/Cargo.toml')
-rw-r--r--third_party/rust/extend/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/third_party/rust/extend/Cargo.toml b/third_party/rust/extend/Cargo.toml
new file mode 100644
index 0000000000..dcc2ebae15
--- /dev/null
+++ b/third_party/rust/extend/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "extend"
+version = "1.1.2"
+authors = ["David Pedersen <david.pdrsn@gmail.com>"]
+description = "Create extensions for types you don't own with extension traits but without the boilerplate."
+homepage = "https://github.com/davidpdrsn/extend"
+documentation = "https://docs.rs/extend"
+readme = "README.md"
+keywords = ["extension", "trait"]
+categories = ["rust-patterns"]
+license = "MIT"
+repository = "https://github.com/davidpdrsn/extend.git"
+
+[lib]
+path = "src/lib.rs"
+proc-macro = true
+[dependencies.proc-macro-error]
+version = "1"
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1"
+features = ["full", "extra-traits", "visit"]
+[dev-dependencies.async-trait]
+version = "0.1.40"
+
+[dev-dependencies.trybuild]
+version = "1.0.17"
+[badges.maintenance]
+status = "passively-maintained"