summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/Correct-timezone-symlinks-when-using-BACKWARD-backward-PA.patch15
-rwxr-xr-xdebian/rules6
3 files changed, 23 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index ec85854..ac7ebd6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+tzdata (2024a-4) unstable; urgency=medium
+
+ * d/rules: Support creating symlinks pointing to symlinks
+ * Fixup for avoid timezones being symlinks to symlinks (LP: #2062522)
+
+ -- Benjamin Drung <bdrung@debian.org> Thu, 02 May 2024 17:51:44 +0200
+
tzdata (2024a-3) unstable; urgency=medium
* Avoid timezones being symlinks to symlinks to avoid breaking C++20 standard
diff --git a/debian/patches/Correct-timezone-symlinks-when-using-BACKWARD-backward-PA.patch b/debian/patches/Correct-timezone-symlinks-when-using-BACKWARD-backward-PA.patch
index b8e9fa5..293b45e 100644
--- a/debian/patches/Correct-timezone-symlinks-when-using-BACKWARD-backward-PA.patch
+++ b/debian/patches/Correct-timezone-symlinks-when-using-BACKWARD-backward-PA.patch
@@ -15,12 +15,12 @@ See https://bugs.launchpad.net/ubuntu/+source/tzdata/+bug/2062522
Forwarded: https://mm.icann.org/pipermail/tz/2024-April/058853.html
---
- backward | 6 +++---
+ backward | 8 ++++----
ziguard.awk | 4 ++--
- 2 files changed, 5 insertions(+), 5 deletions(-)
+ 2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/backward b/backward
-index 65c711b..08c95b1 100644
+index 65c711b..16a01e5 100644
--- a/backward
+++ b/backward
@@ -30,7 +30,7 @@
@@ -50,6 +50,15 @@ index 65c711b..08c95b1 100644
Link Asia/Shanghai PRC
Link Europe/Warsaw Poland
Link Europe/Lisbon Portugal
+@@ -298,7 +298,7 @@ Link Africa/Nairobi Africa/Asmera #= Africa/Asmara
+ Link America/Nuuk America/Godthab
+ Link Asia/Ashgabat Asia/Ashkhabad
+ Link Asia/Kolkata Asia/Calcutta
+-Link Asia/Shanghai Asia/Chungking #= Asia/Chongqing
++Link Asia/Shanghai Asia/Chungking
+ Link Asia/Dhaka Asia/Dacca
+ # Istanbul is in both continents.
+ Link Europe/Istanbul Asia/Istanbul
diff --git a/ziguard.awk b/ziguard.awk
index 7a3404f..f6b8d24 100644
--- a/ziguard.awk
diff --git a/debian/rules b/debian/rules
index 06ceafc..50fe8c3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,8 +17,10 @@ override_dh_auto_build-indep:
# Replace hardlinks by symlinks
grep '^L ' $(CURDIR)/tzdata.zi | while read L target name ; do \
- ln -srf $(TZGEN)/$$target $(TZGEN)/$$name ; \
- ln -srf $(TZGEN)/right/$$target $(TZGEN)/right/$$name ; \
+ absolute_name="$(TZGEN)/$$name"; \
+ relative_target=$$(realpath -m -s --relative-to="$${absolute_name%/*}" "$(TZGEN)/$$target"); \
+ ln -sf "$$relative_target" "$(TZGEN)/$$name" ; \
+ ln -sf "$$relative_target" "$(TZGEN)/right/$$name" ; \
done
# Generate a posixrules file