summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 06ceafc..50fe8c3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,8 +17,10 @@ override_dh_auto_build-indep:
# Replace hardlinks by symlinks
grep '^L ' $(CURDIR)/tzdata.zi | while read L target name ; do \
- ln -srf $(TZGEN)/$$target $(TZGEN)/$$name ; \
- ln -srf $(TZGEN)/right/$$target $(TZGEN)/right/$$name ; \
+ absolute_name="$(TZGEN)/$$name"; \
+ relative_target=$$(realpath -m -s --relative-to="$${absolute_name%/*}" "$(TZGEN)/$$target"); \
+ ln -sf "$$relative_target" "$(TZGEN)/$$name" ; \
+ ln -sf "$$relative_target" "$(TZGEN)/right/$$name" ; \
done
# Generate a posixrules file