summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:30:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:30:09 +0000
commitfae53e60f8c1278c4fb7ac9f3899a899ae3aeae3 (patch)
tree1cf7ffc74d998b4d14372ba6867e34c6f940a126
parentAdding debian version 2.39.3-7. (diff)
downloadutil-linux-fae53e60f8c1278c4fb7ac9f3899a899ae3aeae3.tar.xz
util-linux-fae53e60f8c1278c4fb7ac9f3899a899ae3aeae3.zip
Adding debian version 2.39.3-8.debian/2.39.3-8
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog13
-rw-r--r--debian/control6
-rw-r--r--debian/gbp.conf2
-rwxr-xr-xdebian/rules10
-rw-r--r--debian/util-linux.postinst10
-rw-r--r--debian/util-linux.postinst.linux8
6 files changed, 37 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index cf24ebc..0bd6124 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+util-linux (2.39.3-8) unstable; urgency=medium
+
+ [ Chris Hofstaedtler ]
+ * Break/Replace libuuid1t64 and provide it versioned (Closes: #1065242)
+ * Update architecture list for Provides: libuuid1t64
+ * d/gbp.conf: update debian-branch
+
+ [ Johannes Schauer Marin Rodrigues ]
+ * util-linux.postinst: avoid running uname in maintainer script for
+ chrootless hurd support (Closes: #1063638)
+
+ -- Chris Hofstaedtler <zeha@debian.org> Sat, 02 Mar 2024 13:45:06 +0100
+
util-linux (2.39.3-7) unstable; urgency=medium
* Run wrap-and-sort -kas
diff --git a/debian/control b/debian/control
index 73a74d7..3e66b47 100644
--- a/debian/control
+++ b/debian/control
@@ -415,8 +415,12 @@ Pre-Depends:
Depends:
${misc:Depends},
${shlibs:Depends}
+Breaks:
+ libuuid1t64 (<< ${source:Version})
+Replaces:
+ libuuid1t64
Provides:
- libuuid1t64 [!armel !armhf !hppa !m68k !mips !mipsel !powerpc !sh4]
+ libuuid1t64 (= ${binary:Version}) [!arm !armeb !armel !armhf !hppa !i386 !hurd-i386 !kfreebsd-i386 !m68k !mips !mipsel !mipsn32 !mipsn32el !mipsn32r6 !mipsn32r6el !mipsr6 !mipsr6el !nios2 !powerpc !powerpcel !powerpcspe !s390 !sh3 !sh3eb !sh4 !sh4eb !sparc]
Recommends:
uuid-runtime
Multi-Arch: same
diff --git a/debian/gbp.conf b/debian/gbp.conf
index 1756df7..b58e1d3 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -1,5 +1,5 @@
[DEFAULT]
-debian-branch = master
+debian-branch = debian/unstable
upstream-branch = upstream
pristine-tar = True
compression = xz
diff --git a/debian/rules b/debian/rules
index b951bd9..7d29059 100755
--- a/debian/rules
+++ b/debian/rules
@@ -85,6 +85,8 @@ override_dh_auto_clean:
# drop arch-overrides, generated in dh_install by dh-exec usage.
rm -f debian/uuid-runtime.install.$(DEB_HOST_ARCH) \
debian/util-linux.install.$(DEB_HOST_ARCH)
+ # remove postinst generated in dh_installdeb
+ rm -f debian/util-linux.postinst
override_dh_install:
ifeq ($(filter stage1,$(DEB_BUILD_PROFILES)),)
@@ -174,3 +176,11 @@ else
@echo "WARNING: non-linux detected, making tests non-fatal."
dh_auto_test --max-parallel=1 || true
endif
+
+execute_before_dh_installdeb:
+ifeq ($(DEB_HOST_ARCH_OS), linux)
+ # due to UL_REQUIRES_LINUX([more]), only set up pager alternative
+ # on linux -- this avoids running uname in the maintainer script
+ # as doing so would be unreliable for chrootless installations
+ cp debian/util-linux.postinst.linux debian/util-linux.postinst
+endif
diff --git a/debian/util-linux.postinst b/debian/util-linux.postinst
deleted file mode 100644
index c9a446e..0000000
--- a/debian/util-linux.postinst
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-set -e
-
-if [ "$(uname -s)" = "Linux" ]; then
- update-alternatives --install /usr/bin/pager pager /bin/more 50 \
- --slave /usr/share/man/man1/pager.1.gz pager.1.gz \
- /usr/share/man/man1/more.1.gz
-fi
-
-#DEBHELPER#
diff --git a/debian/util-linux.postinst.linux b/debian/util-linux.postinst.linux
new file mode 100644
index 0000000..9df1520
--- /dev/null
+++ b/debian/util-linux.postinst.linux
@@ -0,0 +1,8 @@
+#!/bin/sh
+set -e
+
+update-alternatives --install /usr/bin/pager pager /bin/more 50 \
+ --slave /usr/share/man/man1/pager.1.gz pager.1.gz \
+ /usr/share/man/man1/more.1.gz
+
+#DEBHELPER#