summaryrefslogtreecommitdiffstats
path: root/libmount/python
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:57 +0000
commitce95875445c67808caa5d4fb0e6f80dbdaef0cb7 (patch)
tree6da8cbc66ef15086c9d295e4abe733b24818551e /libmount/python
parentAdding upstream version 2.40. (diff)
downloadutil-linux-ce95875445c67808caa5d4fb0e6f80dbdaef0cb7.tar.xz
util-linux-ce95875445c67808caa5d4fb0e6f80dbdaef0cb7.zip
Adding upstream version 2.40.1.upstream/2.40.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--libmount/python/meson.build11
1 files changed, 2 insertions, 9 deletions
diff --git a/libmount/python/meson.build b/libmount/python/meson.build
index e1a79d1..0957bca 100644
--- a/libmount/python/meson.build
+++ b/libmount/python/meson.build
@@ -1,9 +1,3 @@
-python_module = import('python')
-
-python = python_module.find_installation(
- get_option('python'),
- required : get_option('build-python'),
- disabler : true)
build_python = python.found()
pylibmount_sources = '''
@@ -21,10 +15,9 @@ if build_python
python.extension_module(
'pylibmount',
pylibmount_sources,
- include_directories : [dir_include, dir_libmount],
+ include_directories : [dir_include],
subdir : 'libmount',
- link_with : lib_mount,
- dependencies : python.dependency(),
+ dependencies : [mount_dep, python.dependency()],
c_args : [
'-Wno-cast-function-type',