summaryrefslogtreecommitdiffstats
path: root/libmount/python
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:58 +0000
commit764402d8b945f7abbfa5f68a6d16c94c635f7ffe (patch)
treef04a9feedef2357ee3aa9b9eef439447f76f14c3 /libmount/python
parentAdding debian version 2.40-8. (diff)
downloadutil-linux-764402d8b945f7abbfa5f68a6d16c94c635f7ffe.tar.xz
util-linux-764402d8b945f7abbfa5f68a6d16c94c635f7ffe.zip
Merging upstream version 2.40.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libmount/python')
-rw-r--r--libmount/python/meson.build11
1 files changed, 2 insertions, 9 deletions
diff --git a/libmount/python/meson.build b/libmount/python/meson.build
index e1a79d1..0957bca 100644
--- a/libmount/python/meson.build
+++ b/libmount/python/meson.build
@@ -1,9 +1,3 @@
-python_module = import('python')
-
-python = python_module.find_installation(
- get_option('python'),
- required : get_option('build-python'),
- disabler : true)
build_python = python.found()
pylibmount_sources = '''
@@ -21,10 +15,9 @@ if build_python
python.extension_module(
'pylibmount',
pylibmount_sources,
- include_directories : [dir_include, dir_libmount],
+ include_directories : [dir_include],
subdir : 'libmount',
- link_with : lib_mount,
- dependencies : python.dependency(),
+ dependencies : [mount_dep, python.dependency()],
c_args : [
'-Wno-cast-function-type',