summaryrefslogtreecommitdiffstats
path: root/sys-utils/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:33:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:33:34 +0000
commit1272be04be0cb803eec87f602edb2e3e6f111aea (patch)
treebce17f6478cdd9f3c4ec3d751135dc42786d6a56 /sys-utils/meson.build
parentReleasing progress-linux version 2.39.3-11~progress7.99u1. (diff)
downloadutil-linux-1272be04be0cb803eec87f602edb2e3e6f111aea.tar.xz
util-linux-1272be04be0cb803eec87f602edb2e3e6f111aea.zip
Merging upstream version 2.40.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sys-utils/meson.build')
-rw-r--r--sys-utils/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-utils/meson.build b/sys-utils/meson.build
index ee00d1d..e683253 100644
--- a/sys-utils/meson.build
+++ b/sys-utils/meson.build
@@ -36,6 +36,10 @@ renice_sources = files(
'renice.c',
)
+setpgid_sources = files(
+ 'setpgid.c',
+)
+
setsid_sources = files(
'setsid.c',
)
@@ -181,6 +185,9 @@ nsenter_sources = files(
setpriv_sources = files(
'setpriv.c',
)
+if LINUX and conf.get('HAVE_LINUX_LANDLOCK_H').to_string() == '1'
+ setpriv_sources += files('setpriv-landlock.c')
+endif
flock_sources = files(
'flock.c',