summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:18:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:18:20 +0000
commita8ba8857ff04550e070f23480c1c8635e619feee (patch)
tree1132b381f5afa79e3ce8cd28d81ffc9cf8bbcbf4 /debian
parentBuilding vim with python3. (diff)
downloadvim-a8ba8857ff04550e070f23480c1c8635e619feee.tar.xz
vim-a8ba8857ff04550e070f23480c1c8635e619feee.zip
Building vim-gtk3 without ruby.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules13
1 files changed, 2 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index b00accf..bf1fc99 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,17 +19,8 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
MAKEFLAGS += -j$(NUMJOBS)
endif
-ifneq (,$(filter pkg.vim.noruby,$(DEB_BUILD_PROFILES)))
- RUBY_SUBSTVARS = -Vvim:Ruby-Provides= -Vvim:Ruby-Desc=
- RUBY_CFGFLAGS = --disable-ruby
-else ifneq (,$(filter alpha ia64,$(DEB_HOST_ARCH)))
- # Disable ruby on these architectures at the request of porters (c.f., #983308)
- RUBY_SUBSTVARS = -Vvim:Ruby-Provides= -Vvim:Ruby-Desc=
- RUBY_CFGFLAGS = --disable-rubyinterp
-else
- RUBY_SUBSTVARS = -Vvim:Ruby-Provides='vim-ruby (= $${binary:Version})' -Vvim:Ruby-Desc=' Ruby,'
- RUBY_CFGFLAGS = --enable-rubyinterp
-endif
+RUBY_SUBSTVARS = -Vvim:Ruby-Provides= -Vvim:Ruby-Desc=
+RUBY_CFGFLAGS = --disable-ruby
# Set to TEST_SKIP_PAT=<vim pattern> to exclude running tests matching the pattern
EXCLUDE_PAT = TEST_SKIP_PAT=Test_crash1