summaryrefslogtreecommitdiffstats
path: root/runtime/doc/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 02:10:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 02:10:58 +0000
commitbee19c22d569e54513a9c591441c7f411811dc81 (patch)
treeb990d2df9fddb8194bfe49e9205005a0d952bc1f /runtime/doc/Makefile
parentAdding upstream version 2:9.1.0199. (diff)
downloadvim-bee19c22d569e54513a9c591441c7f411811dc81.tar.xz
vim-bee19c22d569e54513a9c591441c7f411811dc81.zip
Adding upstream version 2:9.1.0374.upstream/2%9.1.0374
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'runtime/doc/Makefile')
-rw-r--r--runtime/doc/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/runtime/doc/Makefile b/runtime/doc/Makefile
index eecce55..30a4f08 100644
--- a/runtime/doc/Makefile
+++ b/runtime/doc/Makefile
@@ -50,9 +50,15 @@ vimtutor.man: vimtutor.1
xxd.man: xxd.1
nroff -man $< | sed -e s/.//g > $@
-uganda.nsis.txt: uganda.txt
- sed -e 's/[ ]*\*[-a-zA-Z0-9.]*\*//g' -e 's/vim:tw=78:.*//' \
- uganda.txt | uniq >uganda.nsis.txt
+uganda.nsis.txt : uganda.???
+ for dpn in $?; do \
+ trg=$@; \
+ sed -e 's/[ ]*\*.*\*//g' -e 's/vim:tw=[[:digit:]][[:digit:]]:.*//' \
+ $${dpn} | uniq > $${trg%txt}$${dpn##*.}; \
+ done
+# This files needs to be in dos fileformat for NSIS.
+ $(VIMEXE) -e -X -u NONE --cmd "set notitle noicon nocp noml viminfo=" \
+ -c "argdo write ++ff=dos" -c "qa" uganda.nsis.???
# Awk version of .txt to .html conversion.
html: noerrors tags $(HTMLS)