summaryrefslogtreecommitdiffstats
path: root/runtime/lang
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:05:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:05:15 +0000
commit6e9cd6b491267e6dff3e3f3f37d8af5f28e40672 (patch)
tree35661af16c4a0ef2a9a8e225d2d5cc82605ea289 /runtime/lang
parentAdding upstream version 2:9.1.0496. (diff)
downloadvim-6e9cd6b491267e6dff3e3f3f37d8af5f28e40672.tar.xz
vim-6e9cd6b491267e6dff3e3f3f37d8af5f28e40672.zip
Adding upstream version 2:9.1.0698.upstream/2%9.1.0698
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'runtime/lang')
-rw-r--r--runtime/lang/Makefile92
-rw-r--r--runtime/lang/menu_pt_br.vim304
-rw-r--r--runtime/lang/menu_pt_pt.vim38
3 files changed, 352 insertions, 82 deletions
diff --git a/runtime/lang/Makefile b/runtime/lang/Makefile
index d5f2ed6..211d492 100644
--- a/runtime/lang/Makefile
+++ b/runtime/lang/Makefile
@@ -13,34 +13,34 @@ all: $(CONVERTED)
# Convert menu_zh_cn.utf-8.vim to create menu_chinese_gb.936.vim.
menu_chinese_gb.936.vim: menu_zh_cn.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP936 $< | \
+ iconv -f UTF-8 -t CP936 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp936/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_zh_tw.utf-8.vim to create menu_chinese_taiwan.950.vim.
menu_chinese_taiwan.950.vim: menu_zh_tw.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP950 $< | \
+ iconv -f UTF-8 -t CP950 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp950/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_cs_cz.utf-8.vim to create menu_cs_cz.iso_8859-2.vim.
menu_cs_cz.iso_8859-2.vim: menu_cs_cz.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t ISO-8859-2 $< | \
+ iconv -f UTF-8 -t ISO-8859-2 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding iso-8859-2/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
-e 's/\(" Menu Translations:.*\)(.*)/\1(ISO-8859-2)/' \
> $@
# Convert menu_cs_cz.utf-8.vim to create menu_czech_czech_republic.1250.vim.
menu_czech_czech_republic.1250.vim: menu_cs_cz.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP1250 $< | \
+ iconv -f UTF-8 -t CP1250 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp1250/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
-e 's/\(" Menu Translations:.*\)(.*)/\1(CP1250)/' \
> $@
@@ -54,107 +54,107 @@ menu_czech_czech_republic.ascii.vim: menu_cs_cz.utf-8.vim
-e 's/Ť/T/g' -e 's/ť/t/g' -e 's/Ú/U/g' -e 's/ú/u/g' -e 's/Ů/U/g' \
-e 's/ů/u/g' -e 's/Ý/Y/g' -e 's/ý/y/g' -e 's/Ž/Z/g' -e 's/ž/z/g' \
-e 's/scriptencoding utf-8/scriptencoding latin1/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
-e 's/\(" Menu Translations:.*\)(.*)/\1(ASCII - without diacritics)/' \
- $< > $@
+ $? > $@
# Convert menu_ja_jp.utf-8.vim to create menu_ja_jp.euc-jp.vim.
menu_ja_jp.euc-jp.vim: menu_ja_jp.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t EUC-JP $< | \
+ iconv -f UTF-8 -t EUC-JP $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding euc-jp/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
-e 's/\(" Menu Translations:.*\)(.*)/\1(EUC-JP)/' \
> $@
# Convert menu_ja_jp.utf-8.vim to create menu_japanese_japan.932.vim.
menu_japanese_japan.932.vim: menu_ja_jp.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP932 $< | \
+ iconv -f UTF-8 -t CP932 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp932/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
-e 's/\(" Menu Translations:.*\)(.*)/\1(CP932)/' \
> $@
# Convert menu_ko_kr.utf-8.vim to create menu_ko_kr.euckr.vim.
menu_ko_kr.euckr.vim: menu_ko_kr.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t EUC-KR $< | \
+ iconv -f UTF-8 -t EUC-KR $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding euc-kr/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_pl_pl.utf-8.vim to create menu_pl_pl.iso_8859-2.vim.
menu_pl_pl.iso_8859-2.vim: menu_pl_pl.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t ISO-8859-2 $< | \
+ iconv -f UTF-8 -t ISO-8859-2 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding iso-8859-2/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_pl_pl.utf-8.vim to create menu_polish_poland.1250.vim.
menu_polish_poland.1250.vim: menu_pl_pl.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP1250 $< | \
+ iconv -f UTF-8 -t CP1250 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp1250/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_ru_ru.utf-8.vim to create menu_ru_ru.koi8-r.vim.
menu_ru_ru.koi8-r.vim: menu_ru_ru.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t KOI8-R $< | \
+ iconv -f UTF-8 -t KOI8-R $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding koi8-r/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_ru_ru.utf-8.vim to create menu_ru_ru.cp1251.vim.
menu_ru_ru.cp1251.vim: menu_ru_ru.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP1251 $< | \
+ iconv -f UTF-8 -t CP1251 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp1251/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_sl_si.utf-8.vim to create menu_sl_si.cp1250.vim.
menu_sl_si.cp1250.vim: menu_sl_si.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP1250 $< | \
+ iconv -f UTF-8 -t CP1250 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp1250/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# for naming encodings, see `:h encoding-names`
# Convert menu_sl_si.utf-8.vim to create menu_sl_si.latin2.vim.
menu_sl_si.latin2.vim: menu_sl_si.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t ISO-8859-2 $< | \
+ iconv -f UTF-8 -t ISO-8859-2 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding iso-8859-2/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_tr_tr.utf-8.vim to create menu_tr_tr.cp1254.vim.
menu_tr_tr.cp1254.vim: menu_tr_tr.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP1254 $< | \
+ iconv -f UTF-8 -t CP1254 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp1254/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_tr_tr.utf-8.vim to create menu_tr_tr.iso_8859-9.vim.
menu_tr_tr.iso_8859-9.vim: menu_tr_tr.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t ISO-8859-9 $< | \
+ iconv -f UTF-8 -t ISO-8859-9 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding iso-8859-9/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_sr_rs.utf-8.vim to create menu_sr_rs.iso_8859-5.vim.
menu_sr_rs.iso_8859-5.vim: menu_sr_rs.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t ISO-8859-5 $< | \
+ iconv -f UTF-8 -t ISO-8859-5 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding iso-8859-5/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# for naming encodings, see `:h encoding-names`
@@ -174,8 +174,8 @@ menu_sr_rs.iso_8859-2.vim: menu_sr_rs.utf-8.vim
-e 's/С/S/g' -e 's/Т/T/g' -e 's/Ћ/Ć/g' -e 's/У/U/g' -e 's/Ф/F/g' \
-e 's/Х/H/g' -e 's/Ц/C/g' -e 's/Ч/Č/g' -e 's/Џ/Dž/g' -e 's/Ш/Š/g' \
-e 's/scriptencoding utf-8/scriptencoding iso-8859-2/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
- $< | iconv -f UTF-8 -t ISO-8859-2 \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
+ $? | iconv -f UTF-8 -t ISO-8859-2 \
> $@
# Convert menu_sr_rs.utf-8.vim to create menu_sr_rs.ascii.vim.
@@ -194,39 +194,39 @@ menu_sr_rs.ascii.vim: menu_sr_rs.utf-8.vim
-e 's/С/S/g' -e 's/Т/T/g' -e 's/Ћ/C/g' -e 's/У/U/g' -e 's/Ф/F/g' \
-e 's/Х/H/g' -e 's/Ц/C/g' -e 's/Ч/C/g' -e 's/Џ/Dz/g' -e 's/Ш/S/g' \
-e 's/scriptencoding utf-8/scriptencoding latin1/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
- $< > $@
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
+ $? > $@
# Convert menu_uk_ua.utf-8.vim to create menu_uk_ua.cp1251.vim.
menu_uk_ua.cp1251.vim: menu_uk_ua.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t CP1251 $< | \
+ iconv -f UTF-8 -t CP1251 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding cp1251/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_uk_ua.utf-8.vim to create menu_uk_ua.koi8-u.vim.
menu_uk_ua.koi8-u.vim: menu_uk_ua.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t KOI8-U $< | \
+ iconv -f UTF-8 -t KOI8-U $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding koi8-u/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_hu_hu.utf-8.vim to create menu_hu_hu.iso_8859-2.vim.
menu_hu_hu.iso_8859-2.vim: menu_hu_hu.utf-8.vim
rm -f $@
- iconv -f UTF-8 -t ISO-8859-2 $< | \
+ iconv -f UTF-8 -t ISO-8859-2 $? | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding iso-8859-2/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
# Convert menu_slovak_slovak_republic.1250.vim to create menu_sk_sk.iso_8859-2.vim.
menu_sk_sk.iso_8859-2.vim: menu_slovak_slovak_republic.1250.vim
rm -f $@
- iconv -f CP1250 -t ISO-8859-2 $< | \
+ iconv -f CP1250 -t ISO-8859-2 $? | \
$(SED) -e 's/scriptencoding cp1250/scriptencoding iso-8859-2/' \
- -e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
+ -e 's/" Original translations/" Generated from $?, DO NOT EDIT/' \
> $@
clean:
diff --git a/runtime/lang/menu_pt_br.vim b/runtime/lang/menu_pt_br.vim
index 06dea92..6f5b043 100644
--- a/runtime/lang/menu_pt_br.vim
+++ b/runtime/lang/menu_pt_br.vim
@@ -1 +1,303 @@
-source <sfile>:p:h/menu_pt_pt.vim
+" Menu Translations: Portugus do Brasil
+" Maintainer: Jos de Paula <jose@infoviaweb.com>
+" Contributor: JNylson <nylsinho_ba@hotmail.com>
+" Last Change: 2024 Ago 23
+" Original translations
+
+" Quit when menu translations have already been done.
+if exists("did_menu_trans")
+ finish
+endif
+let did_menu_trans = 1
+let s:keepcpo= &cpo
+set cpo&vim
+
+" Translations in latin1 (ISO-8859-1), and should work in
+" latin9 (ISO-8859-15)
+
+if &enc != "cp1252" && &enc != "iso-8859-15"
+ scriptencoding latin1
+endif
+
+" Help menu
+menutrans &Help A&juda
+menutrans &Overview<Tab><F1> &Contedo
+menutrans &User\ Manual &Manual\ do\ Usurio
+menutrans &How-to\ links &Como\ fazer?
+menutrans &Find\.\.\. &Procurar\.\.\.
+menutrans &Credits &Crditos
+menutrans O&rphans &rfos
+menutrans Co&pying &Licena
+menutrans &Sponsor/Register &Doar/Registrar
+menutrans &Version &Verso
+menutrans &About &Sobre
+
+" File menu
+menutrans &File &Arquivo
+menutrans &Open\.\.\.<Tab>:e A&brir\.\.\.<Tab>:e
+menutrans Sp&lit-Open\.\.\.<Tab>:sp Ab&rir\ em\ outra\ janela\.\.\.<Tab>:sp
+menutrans Open\ &Tab\.\.\.<Tab>:tabnew A&brir\ em\ outra\ aba\.\.\.<Tab>:tabnew
+menutrans &New<Tab>:enew &Novo<Tab>:enew
+menutrans &Close<Tab>:close &Fechar<Tab>:close
+menutrans &Save<Tab>:w &Salvar<Tab>:w
+menutrans Save\ &As\.\.\.<Tab>:sav Sa&lvar\ como\.\.\.<Tab>:sav
+menutrans Split\ &Diff\ with\.\.\. &Exibir\ diferenas\ com\.\.\.
+menutrans Split\ Patched\ &By\.\.\. Ex&ibir\ patcheado\ por\.\.\.
+menutrans &Print I&mprimir
+menutrans Sa&ve-Exit<Tab>:wqa Sal&var\ e\ sair<Tab>:wqa
+menutrans E&xit<Tab>:qa Sai&r<Tab>:qa
+
+" Edit menu
+menutrans &Edit &Editar
+menutrans &Undo<Tab>u &Desfazer<Tab>u
+menutrans &Redo<Tab>^R &Refazer<Tab>^R
+menutrans Rep&eat<Tab>\. Repe&tir<Tab>\.
+menutrans Cu&t<Tab>"+x Re&cortar<Tab>"+x
+menutrans &Copy<Tab>"+y Cop&iar<Tab>"+y
+menutrans &Paste<Tab>"+gP C&olar<Tab>"+gP
+menutrans Put\ &Before<Tab>[p Colocar\ &antes<Tab>[p
+menutrans Put\ &After<Tab>]p Colocar\ &depois<Tab>]p
+menutrans &Delete<Tab>x Apa&gar<Tab>x
+menutrans &Select\ all<Tab>ggVG &Selecionar\ tudo<Tab>ggVG
+menutrans &Find\.\.\. &Procurar\.\.\.
+menutrans Find\ and\ Rep&lace\.\.\. Procurar\ e\ substit&uir\.\.\.
+menutrans Find\ and\ Rep&lace<Tab>:%s Procurar\ e\ substit&uir<Tab>:%s
+menutrans Find\ and\ Rep&lace Procurar\ e\ substit&uir
+menutrans Find\ and\ Rep&lace<Tab>:s Procurar\ e\ substituir<Tab>:s
+menutrans Settings\ &Window &Opes
+menutrans Startup\ &Settings &Inicializao
+
+" Edit/Global Settings
+menutrans &Global\ Settings Opes\ &Globais
+
+menutrans Toggle\ Pattern\ &Highlight<Tab>:set\ hls! Ativar/Desativar\ &Realce\ de\ Padres<Tab>:set\ hls!
+menutrans Toggle\ &Ignoring\ Case<Tab>:set\ ic! Ativar/Desativar\ &Ignorar\ maisculas<Tab>:set\ ic!
+menutrans Toggle\ &Showing\ Matched\ Pairs<Tab>:set\ sm! Ativar/Desativar\ &coincidncias<Tab>:set\ sm!
+
+menutrans &Context\ lines Linhas\ de\ C&ontexto
+
+menutrans &Virtual\ Edit Edio\ &Virtual
+menutrans Never Nunca
+menutrans Block\ Selection Seleo\ de\ Bloco
+menutrans Insert\ mode Modo\ de\ insero
+menutrans Block\ and\ Insert Bloco\ e\ insero
+menutrans Always Sempre
+
+menutrans Toggle\ Insert\ &Mode<Tab>:set\ im! Ativar/Desativar\ Modo\ de\ In&sero<Tab>:set\ im!
+menutrans Toggle\ Vi\ C&ompatibility<Tab>:set\ cp! Ativar/Desativar\ Co&mpatibilidade\ com\ Vi<Tab>:set\ cp!
+menutrans Search\ &Path\.\.\. Camin&ho\ de\ Busca\.\.\.
+menutrans Ta&g\ Files\.\.\. Arquivos\ de\ Tags\.\.\.
+
+" GUI options
+menutrans Toggle\ &Toolbar Ocultar/Exibir\ Barra\ de\ &Ferramentas
+menutrans Toggle\ &Bottom\ Scrollbar Ocultar/Exibir\ Barra\ de\ &Rolagem\ Inferior
+menutrans Toggle\ &Left\ Scrollbar Ocultar/Exibir\ Barra\ de\ R&olagem\ Esquerda
+menutrans Toggle\ &Right\ Scrollbar Ocultar/Exibir\ Barra\ de\ Ro&lagem\ Direita
+let g:menutrans_path_dialog = "Indique um caminho de procura para os arquivos.\nSepare os nomes dos diretrios com uma vrgula."
+let g:menutrans_tags_dialog = "Indique os nomes dos arquivos de tags.\nSepare os nomes com uma vrgula."
+
+" Edit/File Settings
+menutrans F&ile\ Settings Opes\ do\ &Arquivo
+
+" Boolean options
+menutrans Toggle\ Line\ &Numbering<Tab>:set\ nu! Ativar/Desativar\ &numerao\ de\ linhas<Tab>:set\ nu!
+menutrans Toggle\ Relati&ve\ Line\ Numbering<Tab>:set\ rnu! Ativar/Desativar\ numerao\ relati&va\ de\ linha<Tab>:set\ rnu!
+menutrans Toggle\ &List\ Mode<Tab>:set\ list! Ativar/Desativar\ modo\ &lista<Tab>:set\ list!
+menutrans Toggle\ Line\ &Wrapping<Tab>:set\ wrap! Ativar/Desativar\ &quebra\ de\ linhas<Tab>:set\ wrap!
+menutrans Toggle\ W&rapping\ at\ Word<Tab>:set\ lbr! Ativar/Desativar\ quebra\ na\ &palavra<Tab>:set\ lbr!
+menutrans Toggle\ Tab\ &Expanding<Tab>:set\ et! Ativar/Desativar\ expanso\ de\ tabs<Tab>:set\ et!
+menutrans Toggle\ &Auto\ Indenting<Tab>:set\ ai! Ativar/Desativar\ &auto-indentao<Tab>:set\ ai!
+menutrans Toggle\ &C-Style\ Indenting<Tab>:set\ cin! Ativar/Desativar\ indentao\ estilo\ &C<Tab>:set\ cin!
+
+" other options
+menutrans &Shiftwidth Largura\ da\ &indentao
+
+menutrans Soft\ &Tabstop &Tabulao\ com\ espaos
+
+menutrans Te&xt\ Width\.\.\. Largura\ do\ te&xto\.\.\.
+let g:menutrans_textwidth_dialog = "Digite a nova largura do texto (0 para desativar a formatao): "
+
+menutrans &File\ Format\.\.\. &Formato\ do\ arquivo\.\.\.
+let g:menutrans_fileformat_dialog = "Selecione o formato para gravar o arquivo"
+let g:menutrans_fileformat_choices = " &Unix \n &Dos \n &Mac \n &Cancelar "
+
+menutrans C&olor\ Scheme Esquema\ de\ c&ores
+menutrans default padro
+menutrans Show\ C&olor\ Schemes\ in\ Menu Mostrar\ &esquema\ de\ cores\ no\ menu
+menutrans Select\ Fo&nt\.\.\. Selecionar\ fo&nte\.\.\.
+
+menutrans &Keymap &Mapa\ de\ teclado
+menutrans Show\ &Keymaps\ in\ Menu Mostrar\ &mapa\ de\ teclado\ no\ menu
+menutrans None Nenhum
+
+" Programming menu
+menutrans &Tools &Ferramentas
+menutrans &Jump\ to\ this\ tag<Tab>g^] &Pular\ para\ este\ tag<Tab>g^]
+menutrans Jump\ &back<Tab>^T &Voltar<Tab>^T
+menutrans Build\ &Tags\ File &Construir\ Arquivo\ de\ tags
+menutrans &Spelling &Ortografia
+menutrans &Folding &Dobra
+menutrans &Make<Tab>:make &Make<Tab>:make
+menutrans &List\ Errors<Tab>:cl &Lista\ de\ erros<Tab>:cl
+menutrans L&ist\ Messages<Tab>:cl! Li&sta\ de\ mensagens<Tab>:cl!
+menutrans &Next\ Error<Tab>:cn P&rximo\ erro<Tab>:cn
+menutrans &Previous\ Error<Tab>:cp &Erro\ anterior<Tab>:cp
+menutrans &Older\ List<Tab>:cold Listar\ erros\ &antigos<Tab>:cold
+menutrans N&ewer\ List<Tab>:cnew Listar\ erros\ &novos<Tab>:cnew
+menutrans Error\ &Window &Janela\ de\ erros
+menutrans Se&t\ Compiler Def&inir\ Compilador
+menutrans &Convert\ to\ HEX<Tab>:%!xxd Converter\ para\ hexadecimal<Tab>:%!xxd
+menutrans Conve&rt\ back<Tab>:%!xxd\ -r Conver&ter\ de\ volta<Tab>:%!xxd\ -r
+
+" Tools.Spelling menu
+menutrans &Spell\ Check\ On &Ativar\ Correo\ Ortogrfica
+menutrans Spell\ Check\ &Off &Desativar\ Correo\ Ortogrfica
+menutrans To\ &Next\ error<Tab>]s &Prximo\ Erro<Tab>]s
+menutrans To\ &Previous\ Error<Tab>[s Erro\ A&nterior<Tab>[s
+menutrans Suggest\ &Corrections<Tab>z= &Sugerir\ Correes<Tab>z=
+menutrans &Repeat\ correction<Tab>:spellrepall &Repetir\ Correo<Tab>:spellrepall
+
+menutrans Set\ language\ to\ "en" Ingls
+menutrans Set\ language\ to\ "en_au" Ingls\ (en_au)
+menutrans Set\ language\ to\ "en_ca" Ingls\ (en_ca)
+menutrans Set\ language\ to\ "en_gb" Ingls\ (en_gb)
+menutrans Set\ language\ to\ "en_nz" Ingls\ (en_nz)
+menutrans Set\ language\ to\ "en_us" Ingls\ (en_us)
+
+menutrans &Find\ More\ Languages &Buscar\ mais\ idiomas
+
+" Tools.Fold Menu
+menutrans &Enable/Disable\ folds<Tab>zi &Ativar/Desativar\ dobras<Tab>zi
+menutrans &View\ Cursor\ Line<Tab>zv &Ver\ linha\ do\ cursor<Tab>zv
+menutrans Vie&w\ Cursor\ Line\ only<Tab>zMzx Ve&r\ somente\ linha\ do\ cursor<Tab>zMzx
+menutrans C&lose\ more\ folds<Tab>zm &Fechar\ mais\ dobras<Tab>zm
+menutrans &Close\ all\ folds<Tab>zM F&echar\ todas\ as\ dobras<Tab>zM
+menutrans O&pen\ more\ folds<Tab>zr A&brir\ mais\ dobras<Tab>zr
+menutrans &Open\ all\ folds<Tab>zR Abr&ir\ todas\ as\ dobras<Tab>zR
+" fold method
+menutrans Fold\ Met&hod &Modo\ de\ dobras
+menutrans Create\ &Fold<Tab>zf Criar\ &dobras<Tab>zf
+menutrans &Delete\ Fold<Tab>zd Remover\ d&obras<Tab>zd
+menutrans Delete\ &All\ Folds<Tab>zD Remover\ &todas\ as\ dobras<Tab>zD
+" moving around in folds
+menutrans Fold\ col&umn\ width &Largura\ da\ coluna\ da\ dobra
+
+" Tools.Diff Menu
+menutrans &Update &Atualizar
+menutrans &Get\ Block &Obter\ Bloco
+menutrans &Put\ Block &Pr\ Bloco
+
+" Tools.Error Menu
+menutrans &Update<Tab>:cwin &Atualizar<Tab>:cwin
+menutrans &Open<Tab>:copen A&brir<Tab>:copen
+menutrans &Close<Tab>:cclose &Fechar<Tab>:cclose
+
+" Setup the Tools.Compiler submenu
+menutrans Se&t\ Compiler Def&inir\ compilador
+menutrans Show\ Compiler\ Se&ttings\ in\ Menu Mos&trar\ configuraes\ do\ compilador\ no\ menu
+" Names for buffer menu.
+menutrans &Buffers &Buffers
+menutrans &Refresh\ menu A&tualizar\ menu
+menutrans &Delete &Apagar
+menutrans &Alternate A&lternar
+menutrans &Next P&rximo
+menutrans &Previous A&nterior
+let g:menutrans_no_file = "[Sem arquivos]"
+
+" Window menu
+menutrans &Window &Janela
+menutrans &New<Tab>^Wn N&ova<Tab>^Wn
+menutrans S&plit<Tab>^Ws &Dividir<Tab>^Ws
+menutrans Sp&lit\ To\ #<Tab>^W^^ D&ividir\ para\ #<Tab>^W^^
+menutrans Split\ &Vertically<Tab>^Wv Dividir\ &verticalmente<Tab>^Wv
+menutrans Split\ File\ E&xplorer &Abrir\ Gerenciador\ de\ arquivos
+menutrans &Close<Tab>^Wc &Fechar<Tab>^Wc
+menutrans Close\ &Other(s)<Tab>^Wo Fechar\ &outra(s)<Tab>^Wo
+menutrans Move\ &To Mover\ &para
+menutrans &Top<Tab>^WK A&cima<Tab>^WK
+menutrans &Bottom<Tab>^WJ A&baixo<Tab>^WJ
+menutrans &Left\ side<Tab>^WH Lado\ &esquerdo<Tab>^WH
+menutrans &Right\ side<Tab>^WL Lado\ di&reito<Tab>^WL
+menutrans Rotate\ &Up<Tab>^WR &Girar\ para\ cima<Tab>^WR
+menutrans Rotate\ &Down<Tab>^Wr Girar\ para\ bai&xo<Tab>^Wr
+menutrans &Equal\ Size<Tab>^W= Mesmo\ &Tamanho<Tab>^W=
+menutrans &Max\ Height<Tab>^W_ Altura\ &Mxima<Tab>^W_
+menutrans M&in\ Height<Tab>^W1_ A&ltura\ Mnima<Tab>^W1_
+menutrans Max\ &Width<Tab>^W\| Larg&ura\ Mxima<Tab>^W\|
+menutrans Min\ Widt&h<Tab>^W1\| Largura\ M&nima<Tab>^W1\|
+
+" The popup menu
+menutrans &Undo &Desfazer
+menutrans Cu&t Recor&tar
+menutrans &Copy &Copiar
+menutrans &Paste Co&lar
+menutrans &Delete &Apagar
+menutrans Select\ Blockwise Seleo\ de\ bloco
+menutrans Select\ &Word Selecionar\ &Palavra
+menutrans Select\ &Sentence Selecionar\ &frase
+menutrans Select\ Pa&ragraph Selecionar\ pa&rgrafo
+menutrans Select\ &Line Selecionar\ L&inha
+menutrans Select\ &Block Selecionar\ &bloco
+menutrans Select\ &All Selecionar\ T&udo
+
+" The GUI toolbar
+if has("toolbar")
+ if exists("*Do_toolbar_tmenu")
+ delfun Do_toolbar_tmenu
+ endif
+ fun Do_toolbar_tmenu()
+ tmenu ToolBar.Open Abrir Arquivo
+ tmenu ToolBar.Save Salvar Arquivo
+ tmenu ToolBar.SaveAll Salvar Todos os arquivos
+ tmenu ToolBar.Print Imprimir
+ tmenu ToolBar.Undo Desfazer
+ tmenu ToolBar.Redo Refazer
+ tmenu ToolBar.Cut Recortar
+ tmenu ToolBar.Copy Copiar
+ tmenu ToolBar.Paste Colar
+ tmenu ToolBar.Find Procurar...
+ tmenu ToolBar.FindNext Procurar Prximo
+ tmenu ToolBar.FindPrev Procurar Anterior
+ tmenu ToolBar.Replace Procurar e Substituir
+ if 0 " disable; these are in the Windoze menu
+ tmenu ToolBar.New Nova Janela
+ tmenu ToolBar.WinSplit Dividir Janela
+ tmenu ToolBar.WinMax Janela Mxima
+ tmenu ToolBar.WinMin Janela Mnima
+ tmenu ToolBar.WinVSplit Dividir Verticalmente
+ tmenu ToolBar.WinMaxWidth Largura Mxima
+ tmenu ToolBar.WinMinWidth Largura Mnima
+ tmenu ToolBar.WinClose Fechar Janela
+ endif
+ tmenu ToolBar.LoadSesn Carregar Sesso
+ tmenu ToolBar.SaveSesn Salvar Sesso
+ tmenu ToolBar.RunScript Executar script
+ tmenu ToolBar.Make Make
+ tmenu ToolBar.Shell Abrir um shell
+ tmenu ToolBar.RunCtags Gerar um arquivo de tags
+ tmenu ToolBar.TagJump Saltar para um tag
+ tmenu ToolBar.Help Ajuda
+ tmenu ToolBar.FindHelp Procurar na Ajuda
+ endfun
+endif
+
+" Syntax menu
+menutrans &Syntax &Sintaxe
+"menutrans &Show\ individual\ choices E&xibir\ escolhas\ individuais
+menutrans &Show\ filetypes\ in\ menu E&xibir\ tipos\ de\ arquivos\ no\ menu
+menutrans Set\ '&syntax'\ only Ativar\ somente\ s&intaxe
+menutrans Set\ '&filetype'\ too Ativar\ tambm\ &tipo\ de\ arquivo
+menutrans &Off &Desativar
+menutrans &Manual &Manual
+menutrans A&utomatic A&utomtica
+menutrans on/off\ for\ &This\ file Ativar/Desativar\ neste\ &arquivo
+menutrans &Show\ File\ Types\ in\ Menu Mos&trar\ tipos\ de\ arquivos\ no\ menu
+menutrans Co&lor\ test T&este\ de\ cores
+menutrans &Highlight\ test Teste\ de\ &realce
+menutrans &Convert\ to\ HTML &Converter\ para\ HTML
+
+" Find Help dialog text
+let g:menutrans_help_dialog = "Digite um comando ou palavra para obter ajuda;\n\nAnteponha i_ para comandos de entrada (ex.: i_CTRL-X)\nAnteponha c_ para comandos da linha de comandos (ex.: c_<Del>)\nAnteponha ` para um nome de opo (ex.: `shiftwidth`)"
+
+let &cpo = s:keepcpo
+unlet s:keepcpo
diff --git a/runtime/lang/menu_pt_pt.vim b/runtime/lang/menu_pt_pt.vim
index ddc35b8..7d3c104 100644
--- a/runtime/lang/menu_pt_pt.vim
+++ b/runtime/lang/menu_pt_pt.vim
@@ -1,7 +1,7 @@
" Menu Translations: Portugus
" adaptado de pt_br.
" Maintainer: Duarte Henriques <duarte_henriques@myrealbox.com>
-" Last Change: 2024 May 2
+" Last Change: 2024 Aug 22
" Original translations
" Quit when menu translations have already been done.
@@ -129,7 +129,7 @@ menutrans &Jump\ to\ this\ tag<Tab>g^] Saltar\ para\ esta\ &tag<Tab>g^]
menutrans Jump\ &back<Tab>^T &Voltar<Tab>^T
menutrans Build\ &Tags\ File &Construir\ Arquivo\ de\ tags
menutrans &Folding &Dobra
-menutrans &Make<Tab>:make Fazer<Tab>:make
+menutrans &Make<Tab>:make &Make<Tab>:make
menutrans &List\ Errors<Tab>:cl &Lista\ de\ erros<Tab>:cl
menutrans L&ist\ Messages<Tab>:cl! Li&sta\ de\ mensagens<Tab>:cl!
menutrans &Next\ Error<Tab>:cn P&rximo\ erro<Tab>:cn
@@ -137,7 +137,7 @@ menutrans &Previous\ Error<Tab>:cp &Erro\ anterior<Tab>:cp
menutrans &Older\ List<Tab>:cold Listar\ erros\ &antigos<Tab>:cold
menutrans N&ewer\ List<Tab>:cnew Listar\ erros\ &novos<Tab>:cnew
menutrans Error\ &Window &Janela\ de\ erros
-menutrans Se&T\ Compiler Def&inir\ Compilador
+menutrans Se&t\ Compiler Def&inir\ Compilador
menutrans &Convert\ to\ HEX<Tab>:%!xxd Converter\ para\ hexadecimal<Tab>:%!xxd
menutrans Conve&rt\ back<Tab>:%!xxd\ -r Conver&ter\ de\ volta<Tab>:%!xxd\ -r
@@ -266,38 +266,6 @@ menutrans &Convert\ to\ HTML &Converter\ para\ HTML
" Find Help dialog text
let g:menutrans_help_dialog = "Digite um comando ou palavra para obter ajuda;\n\nAnteponha i_ para comandos de entrada (ex.: i_CTRL-X)\nAnteponha c_ para comandos da linha de comandos (ex.: c_<Del>)\nAnteponha ` para um nome de opo (ex.: `shiftwidth`)"
-menutrans Open\ &Tab\.\.\.<Tab>:tabnew Aba\ aberta\.\.\.<Tab>:tabnew
-menutrans Startup\ &Settings Configuraes\ de\ inicializao
-menutrans Toggle\ relati&ve\ Line\ Numbering<Tab>:set\ rnu! Numerao\ relativa\ de\ linha<Tab>:set\ nru!
-menutrans Toggle\ Line\ &Wrapping<Tab>:set\ wrap! Quebra\ de\ linha<Tab>:set\ wrap!
-menutrans Toggle\ W&rapping\ at\ word<Tab>:set\ lbr! Envolvendo\ a\ palavra<Tab>:set\ lbr!
-menutrans Toggle\ Tab\ &Expanding<Tab>:set\ et! Gastos\ de\ tabulao<Tab>:set\ et!
-menutrans Toggle\ &Auto\ Indenting<Tab>:set\ ai! Recuo\ automtico<Tab>:set\ ai!
-menutrans Toggle\ &C-Style\ Indenting<Tab>:set\ cin! Recuo\ estilo\ C<Tab>:set\ cin!
-menutrans &Spelling Ortografia
-menutrans &Spell\ Check\ On Correo\ ortogrfica\ ativada
-menutrans Spell\ Check\ &Off Correo\ ortogrfica\ desativada
-menutrans To\ &Next\ error<Tab>]s Prximo\ erro<Tab>]s
-menutrans To\ &Previous\ error<Tab>[s erro\ anterior<Tab>[s
-menutrans Suggest\ &Corrections<Tab>z= Sugerir\ correes<Tab>z=
-menutrans &Repeat\ correction<Tab>:spellrepall repetir\ correo<Tab>:spellrepall
-"-------------------
-menutrans Set\ language\ to\ "en" Definir\ idioma\ para\ "en"
-menutrans Set\ language\ to\ "en_au" Definir\ idioma\ para\ "en_au"
-menutrans Set\ language\ to\ "en_ca" Definir\ idioma\ para\ "en_ca"
-menutrans Set\ language\ to\ "en_gb" Definir\ idioma\ para\ "en_gb"
-menutrans Set\ language\ to\ "en_nz" Definir\ idioma\ para\ "en_nz"
-menutrans Set\ language\ to\ "en_us" Definir\ idioma\ para\ "en_us"
-menutrans &Find\ More\ Languages Encontre\ mais\ idiomas
-let g:menutrans_set_lang_to = 'Definir idioma para'
-menutrans M&anual Manual
-menutrans I&ndent Recuar
-menutrans E&xpression Expresso
-menutrans S&yntax Sintaxe
-menutrans &Diff Diferena
-menutrans Ma&rker Marcador
-menutrans &Show\ File\ Types\ in\ menu Mostrar\ tipos\ de\ arquivo\ no\ menu
-menutrans &Sponsor/Register Patrocinador/Registro
let &cpo = s:keepcpo
unlet s:keepcpo