summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog19
-rw-r--r--debian/copyright45
-rw-r--r--debian/patches/debian/Add-recognition-of-more-LaTeX-commands-for-tex-filetype-d.patch4
-rw-r--r--debian/patches/debian/Document-Debian-s-decision-to-disable-modelines-by-defaul.patch4
-rw-r--r--debian/patches/debian/Support-sourcing-a-vimrc.tiny-when-Vim-is-invoked-as-vi.patch4
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/runtime/vimrc4
7 files changed, 75 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 47a53df..1f41259 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,22 @@
+vim (2:9.1.0698-1) unstable; urgency=medium
+
+ * Merge upstream tag v9.1.0698
+ + Security fixes:
+ - 9.1.0647: Fix use-after-free in tagstack_clear_entry(), CVE-2024-41957
+ - 9.1.0648: Fix double free in dialog_changed(), CVE-2024-41965
+ - 9.1.0678: Fix use-after-free in alist_add(), CVE-2024-43374
+ - 9.1.0689: Fix buffer-overflow in do_search() when 'rightleft' is set,
+ CVE-2024-43790
+ - 9.1.0697: Fix heap-buffer-overflow in ins_typebuf(), CVE-2024-43802
+ + 9.1.0568: Add support for completing paths from 'cdpath' in :cd (Closes:
+ #509940)
+ * Clarify defaults.vim instructions in system vimrc when wanting to source
+ defaults.vim to build on top of its settings.
+ * Adjust make parameter used to specify vim binary, since upstream changed
+ the expected variable name in multiple makefiles
+
+ -- James McCoy <jamessan@debian.org> Wed, 28 Aug 2024 06:41:08 -0400
+
vim (2:9.1.0496-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/copyright b/debian/copyright
index b72e1fe..4b50cb5 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -54,18 +54,24 @@ Copyright: Andy Cedilnik <andy.cedilnik@kitware.com>
License: BSD-3-clause
Files:
+ runtime/autoload/typst.vim
runtime/compiler/pip_compile.vim
+ runtime/compiler/typst.vim
runtime/ftplugin/jsonc.vim
runtime/ftplugin/jq.vim
runtime/ftplugin/julia.vim
runtime/ftplugin/requirements.vim
+ runtime/ftplugin/typst.vim
runtime/ftplugin/wat.vim
runtime/indent/asm.vim
runtime/indent/astro.vim
+ runtime/indent/glsl.vim
runtime/indent/julia.vim
+ runtime/indent/typst.vim
runtime/indent/wat.vim
runtime/syntax/astro.vim
runtime/syntax/bitbake.vim
+ runtime/syntax/glsl.vim
runtime/syntax/jq.vim
runtime/syntax/json.vim
runtime/syntax/jsonc.vim
@@ -73,6 +79,7 @@ Files:
runtime/syntax/nix.vim
runtime/syntax/pandoc.vim
runtime/syntax/requirements.vim
+ runtime/syntax/typst.vim
runtime/syntax/wat.vim
Copyright:
2013 Jeroen Ruigrok van der Werven, Eli Parra
@@ -87,6 +94,8 @@ Copyright:
2017 Philip Jones
2022 Wuelner Martínez
2013-2019 vim-pandoc-syntax contributors
+ 2023 Kaj Munhoz Arfvidsson
+ 2013-2022 Sergii Tykhomyrov
License: Expat
Files: runtime/syntax/tmux.vim
@@ -190,6 +199,16 @@ Copyright:
2024 Wu, Zhenyu <wuzhenyu@ustc.edu>
License: GPL-3+
+Files:
+ runtime/ftplugin/chicken.vim
+ runtime/ftplugin/scheme.vim
+ runtime/indent/scheme.vim
+ runtime/syntax/chicken.vim
+ runtime/syntax/scheme.vim
+Copyright:
+ Evan Hanson <evhan@foldling.org>
+License: Unlicense
+
License: Vim
I) There are no restrictions on distributing unmodified copies of Vim except
that they must include this license text. You can also distribute
@@ -636,3 +655,29 @@ License: EDL-1
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+License: Unlicense
+ This is free and unencumbered software released into the public domain.
+ .
+ Anyone is free to copy, modify, publish, use, compile, sell, or
+ distribute this software, either in source code form or as a compiled
+ binary, for any purpose, commercial or non-commercial, and by any
+ means.
+ .
+ In jurisdictions that recognize copyright laws, the author or authors
+ of this software dedicate any and all copyright interest in the
+ software to the public domain. We make this dedication for the benefit
+ of the public at large and to the detriment of our heirs and
+ successors. We intend this dedication to be an overt act of
+ relinquishment in perpetuity of all present and future rights to this
+ software under copyright law.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+ OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ OTHER DEALINGS IN THE SOFTWARE.
+ .
+ For more information, please refer to <http://unlicense.org/>
diff --git a/debian/patches/debian/Add-recognition-of-more-LaTeX-commands-for-tex-filetype-d.patch b/debian/patches/debian/Add-recognition-of-more-LaTeX-commands-for-tex-filetype-d.patch
index a13aeac..7903dde 100644
--- a/debian/patches/debian/Add-recognition-of-more-LaTeX-commands-for-tex-filetype-d.patch
+++ b/debian/patches/debian/Add-recognition-of-more-LaTeX-commands-for-tex-filetype-d.patch
@@ -13,10 +13,10 @@ Signed-off-by: James McCoy <jamessan@debian.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/runtime/autoload/dist/ft.vim b/runtime/autoload/dist/ft.vim
-index bf9e32e..2f11f7a 100644
+index c8942eb..2faabe2 100644
--- a/runtime/autoload/dist/ft.vim
+++ b/runtime/autoload/dist/ft.vim
-@@ -1071,7 +1071,7 @@ export def FTtex()
+@@ -1112,7 +1112,7 @@ export def FTtex()
var firstNC = search('^\s*[^[:space:]%]', 'c', 1000)
if firstNC > 0
# Check the next thousand lines for a LaTeX or ConTeXt keyword.
diff --git a/debian/patches/debian/Document-Debian-s-decision-to-disable-modelines-by-defaul.patch b/debian/patches/debian/Document-Debian-s-decision-to-disable-modelines-by-defaul.patch
index 926b47e..a11b9ee 100644
--- a/debian/patches/debian/Document-Debian-s-decision-to-disable-modelines-by-defaul.patch
+++ b/debian/patches/debian/Document-Debian-s-decision-to-disable-modelines-by-defaul.patch
@@ -15,10 +15,10 @@ Signed-off-by: James McCoy <jamessan@debian.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/runtime/doc/options.txt b/runtime/doc/options.txt
-index 6ec4031..1687b8e 100644
+index 3ec8a3a..145f2f6 100644
--- a/runtime/doc/options.txt
+++ b/runtime/doc/options.txt
-@@ -5611,7 +5611,7 @@ A jump table for the options with a short description can be found at |Q_op|.
+@@ -5616,7 +5616,7 @@ A jump table for the options with a short description can be found at |Q_op|.
*'modeline'* *'ml'* *'nomodeline'* *'noml'*
'modeline' 'ml' boolean (Vim default: on (off for root),
diff --git a/debian/patches/debian/Support-sourcing-a-vimrc.tiny-when-Vim-is-invoked-as-vi.patch b/debian/patches/debian/Support-sourcing-a-vimrc.tiny-when-Vim-is-invoked-as-vi.patch
index 25d23e4..e437e8f 100644
--- a/debian/patches/debian/Support-sourcing-a-vimrc.tiny-when-Vim-is-invoked-as-vi.patch
+++ b/debian/patches/debian/Support-sourcing-a-vimrc.tiny-when-Vim-is-invoked-as-vi.patch
@@ -86,10 +86,10 @@ index 99184ab..6db866e 100644
# define SYS_VIMRC_FILE "$VIM/vimrc"
#endif
diff --git a/src/structs.h b/src/structs.h
-index 7e21f0f..8ed1481 100644
+index 79f415d..d749091 100644
--- a/src/structs.h
+++ b/src/structs.h
-@@ -4603,6 +4603,9 @@ typedef struct
+@@ -4607,6 +4607,9 @@ typedef struct
#ifdef FEAT_DIFF
int diff_mode; // start with 'diff' set
#endif
diff --git a/debian/rules b/debian/rules
index bf1fc99..1041331 100755
--- a/debian/rules
+++ b/debian/rules
@@ -180,7 +180,7 @@ override_dh_auto_build-indep:
$(MAKE) -f debian/rules build-vim-basic
$(MAKE) -C runtime/doc html
$(MAKE) -C debian/policy text html
- $(MAKE) -C src/po vim.pot VIM=$(CURDIR)/src/vim-basic/vim
+ $(MAKE) -C src/po vim.pot VIMPROG=$(CURDIR)/src/vim-basic/vim
override_dh_auto_build-arch: autoconf-stamp
$(call foreach-variant, $(MAKE) -f debian/rules build-"$${v}")
@@ -218,7 +218,7 @@ build-vim-%: VARIANT=vim-$*
build-vim-%: configure-$(VARIANT)
build-vim-%:
$(MAKE) -C src/$(VARIANT)
- $(MAKE) -C runtime/doc tags VIMEXE=$(CURDIR)/src/$(VARIANT)/vim
+ $(MAKE) -C runtime/doc tags VIMPROG=$(CURDIR)/src/$(VARIANT)/vim
test-vim-%: VARIANT=vim-$*
test-vim-%:
diff --git a/debian/runtime/vimrc b/debian/runtime/vimrc
index 3cb8b8a..1887a97 100644
--- a/debian/runtime/vimrc
+++ b/debian/runtime/vimrc
@@ -10,8 +10,10 @@
" let g:skip_defaults_vim = 1
"
" If you would rather _use_ default.vim's settings, but have the system or
-" user vimrc override its settings, then uncomment the line below.
+" user vimrc override its settings, then uncomment both lines below (to load
+" the settings now but prevent it from being loaded by the user's vimrc).
" source $VIMRUNTIME/defaults.vim
+" let g:skip_defaults_vim = 1
" All Debian-specific settings are defined in $VIMRUNTIME/debian.vim and
" sourced by the call to :runtime you can find below. If you wish to change