summaryrefslogtreecommitdiffstats
path: root/runtime/ftplugin/meson.vim
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/ftplugin/meson.vim')
-rw-r--r--runtime/ftplugin/meson.vim39
1 files changed, 39 insertions, 0 deletions
diff --git a/runtime/ftplugin/meson.vim b/runtime/ftplugin/meson.vim
new file mode 100644
index 0000000..1ce9a03
--- /dev/null
+++ b/runtime/ftplugin/meson.vim
@@ -0,0 +1,39 @@
+" Vim filetype plugin file
+" Language: meson
+" License: VIM License
+" Maintainer: Liam Beguin <liambeguin@gmail.com>
+" Original Author: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
+" Last Change: 2018 Nov 27
+
+if exists("b:did_ftplugin") | finish | endif
+let b:did_ftplugin = 1
+let s:keepcpo= &cpo
+set cpo&vim
+
+setlocal commentstring=#\ %s
+setlocal comments=:#
+setlocal formatoptions+=croql formatoptions-=t
+
+let b:undo_ftplugin = "setl com< cms< fo<"
+
+if get(g:, "meson_recommended_style", 1)
+ setlocal expandtab
+ setlocal shiftwidth=2
+ setlocal softtabstop=2
+ let b:undo_ftplugin .= " | setl et< sts< sw<"
+endif
+
+if exists("loaded_matchit") && !exists("b:match_words")
+ let b:match_words = '\<if\>:\<elif\>:\<else\>:\<endif\>,' .
+ \ '\<foreach\>:\<break\>:\<continue\>:\<endforeach\>'
+ let b:undo_ftplugin .= " | unlet! b:match_words"
+endif
+
+if (has("gui_win32") || has("gui_gtk")) && !exists("b:browsefilter")
+ let b:browsefilter = "Meson Build Files (meson.build)\tmeson.build\n" .
+ \ "All Files (*.*)\t*.*\n"
+ let b:undo_ftplugin .= " | unlet! b:browsefilter"
+endif
+
+let &cpo = s:keepcpo
+unlet s:keepcpo