summaryrefslogtreecommitdiffstats
path: root/runtime/lang/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--runtime/lang/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/runtime/lang/Makefile b/runtime/lang/Makefile
index 9ce56b4..d5f2ed6 100644
--- a/runtime/lang/Makefile
+++ b/runtime/lang/Makefile
@@ -5,6 +5,8 @@ include Make_all.mak
SED = LANG=C sed
+.PHONY: all clean
+
all: $(CONVERTED)
@@ -30,7 +32,7 @@ menu_cs_cz.iso_8859-2.vim: menu_cs_cz.utf-8.vim
iconv -f UTF-8 -t ISO-8859-2 $< | \
$(SED) -e 's/scriptencoding utf-8/scriptencoding iso-8859-2/' \
-e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
- -e 's/\(" Menu Translations:.*\)(.*)/\1(ISO8859-2)/' \
+ -e 's/\(" Menu Translations:.*\)(.*)/\1(ISO-8859-2)/' \
> $@
# Convert menu_cs_cz.utf-8.vim to create menu_czech_czech_republic.1250.vim.
@@ -226,3 +228,7 @@ menu_sk_sk.iso_8859-2.vim: menu_slovak_slovak_republic.1250.vim
$(SED) -e 's/scriptencoding cp1250/scriptencoding iso-8859-2/' \
-e 's/" Original translations/" Generated from $<, DO NOT EDIT/' \
> $@
+
+clean:
+ for G in $(CONVERTED); do if [ -f $$G ]; then rm -f $$G; fi; done
+# -rm -f $(CONVERTED)