summaryrefslogtreecommitdiffstats
path: root/src/configure
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/configure.ac19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 946fe52..233e907 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1539,11 +1539,18 @@ if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic";
AC_MSG_RESULT(yep)
dnl -- get the stable ABI version if passed in
+ python3_stable_abi_default=3.8
AC_MSG_CHECKING(--with-python3-stable-abi argument)
AC_SUBST(vi_cv_var_python3_stable_abi)
- AC_ARG_WITH(python3-stable-abi, [ --with-python3-stable-abi=VERSION stable ABI version to target (e.g. 3.8)],
- vi_cv_var_python3_stable_abi="$withval"; AC_MSG_RESULT($vi_cv_var_python3_stable_abi),
- AC_MSG_RESULT(no))
+ AC_ARG_WITH(python3-stable-abi, [ --with-python3-stable-abi=VERSION stable ABI version to target (default: 3.8)],
+ [
+ if test "X$withval" = "Xyes"; then
+ vi_cv_var_python3_stable_abi=$python3_stable_abi_default
+ else
+ vi_cv_var_python3_stable_abi="$withval"
+ fi
+ AC_MSG_RESULT($vi_cv_var_python3_stable_abi)],
+ AC_MSG_RESULT(no))
if test "X$vi_cv_var_python3_stable_abi" != "X"; then
AC_CACHE_VAL(vi_cv_var_python3_stable_abi_hex,
[
@@ -4497,6 +4504,12 @@ if test "$enable_nls" = "yes"; then
AC_SUBST(MAKEMO)
dnl this was added in GNU gettext 0.10.36
AC_CHECK_FUNCS(bind_textdomain_codeset)
+ AC_MSG_CHECKING([for dgettext])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
+ [#include <libintl.h>],
+ [dgettext("Test", "Test");])],
+ AC_MSG_RESULT([yes]); AC_DEFINE(HAVE_DGETTEXT),
+ AC_MSG_RESULT([no]))
dnl _nl_msg_cat_cntr is required for GNU gettext
AC_MSG_CHECKING([for _nl_msg_cat_cntr])
AC_LINK_IFELSE([AC_LANG_PROGRAM(