summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:52 +0000
commita515bba5570eaaa264b1fb590f91b7b772b83d3f (patch)
tree48e51447595bd944be56da6f464132d219f63c6d
parentMerging upstream version 7.0.16-dfsg. (diff)
downloadvirtualbox-a515bba5570eaaa264b1fb590f91b7b772b83d3f.tar.xz
virtualbox-a515bba5570eaaa264b1fb590f91b7b772b83d3f.zip
Adding debian version 7.0.16-dfsg-1.debian/7.0.16-dfsg-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog18
-rwxr-xr-xdebian/get-orig-source.sh2
-rw-r--r--debian/patches/102989.patch34
-rw-r--r--debian/patches/102990.patch107
-rw-r--r--debian/patches/102992.patch25
-rw-r--r--debian/patches/102993.patch13
-rw-r--r--debian/patches/102994.patch23
-rw-r--r--debian/patches/102999.patch22
-rw-r--r--debian/patches/103024.patch101
-rw-r--r--debian/patches/103066.patch80
-rw-r--r--debian/patches/103067.patch66
-rw-r--r--debian/patches/fix-kernel-build.patch39
-rw-r--r--debian/patches/gcc-13.patch12
-rw-r--r--debian/patches/series11
14 files changed, 19 insertions, 534 deletions
diff --git a/debian/changelog b/debian/changelog
index ccd8f139..48e76ea9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,21 @@
+virtualbox (7.0.16-dfsg-1) unstable; urgency=medium
+
+ * New upstream version 7.0.16-dfsg
+ * Update get-orig-source script
+ * Drop patches part of upstream codebase:
+ - 102989
+ - 102990
+ - 102992
+ - 102993
+ - 102994
+ - 102999
+ - 103024
+ - 103066
+ - 103067
+ - fix-kernel-build gcc-13
+
+ -- Gianfranco Costamagna <locutusofborg@debian.org> Tue, 16 Apr 2024 23:14:45 +0200
+
virtualbox (7.0.14-dfsg-4) unstable; urgency=medium
* Add patch from Xu Zhen (xuzhen666) to fix kernel module build LP: #2053024)
diff --git a/debian/get-orig-source.sh b/debian/get-orig-source.sh
index d4e8b70a..836a1834 100755
--- a/debian/get-orig-source.sh
+++ b/debian/get-orig-source.sh
@@ -70,4 +70,4 @@ tar --exclude .svn --exclude '.git*' --exclude debian --directory ${WORKING_DIR}
rm -rf ${ORIG_TARBALL_DIR}
echo "Done, now you can run:"
-echo "gbp import-orig ../${PACKAGE_NAME}_${UPSTREAM_VERSION}.orig.tar.xz"
+echo "gbp import-orig ../${DEST_TARBALL_NAME}"
diff --git a/debian/patches/102989.patch b/debian/patches/102989.patch
deleted file mode 100644
index f228c0d2..00000000
--- a/debian/patches/102989.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: include/iprt/string.h
-===================================================================
---- a/include/iprt/string.h (revision 102988)
-+++ b/include/iprt/string.h (revision 102989)
-@@ -245,7 +245,29 @@
- # define RT_BCOPY_UNFORTIFIED(a_pDst, a_pSrc, a_cbToCopy) memcpy((a_pDst), (a_pSrc), (a_cbToCopy))
- #endif /* !RT_OS_LINUX && !__KERNEL__ */
-
-+/** @def RT_STRSCPY
-+ * Copy string and NULL-terminate output buffer.
-+ *
-+ * This macro should mostly be used in Linux kernel code. This is
-+ * the replacement for deprecated strlcpy. It was deprecated since 3.16.60
-+ * when strscpy was introduced as an alternative. Finally, strlcpy was
-+ * completely removed from kernel code in 6.8.0.
-+ *
-+ * @param a_pDst Pointer to the destination string buffer.
-+ * @param a_pSrc Pointer to the source NULL-terminated string buffer.
-+ * @param a_cbToCopy Size of destination buffer..
-+ */
-+#if defined(RT_OS_LINUX) && defined(__KERNEL__)
-+# if (RTLNX_VER_MIN(3,16,60))
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbToCopy) strscpy((a_pDst), (a_pSrc), (a_cbToCopy))
-+# else /* < 3.16.60 */
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbToCopy) strlcpy((a_pDst), (a_pSrc), (a_cbToCopy))
-+# endif
-+#else /* !RT_OS_LINUX && !__KERNEL__ */
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbToCopy) strscpy((a_pDst), (a_pSrc), (a_cbToCopy))
-+#endif /* !RT_OS_LINUX && !__KERNEL__ */
-
-+
- #ifdef IN_RING3
-
- /**
diff --git a/debian/patches/102990.patch b/debian/patches/102990.patch
deleted file mode 100644
index 3cd42586..00000000
--- a/debian/patches/102990.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-Index: src/VBox/Additions/common/VBoxGuest/VBoxGuest-linux.c
-===================================================================
---- a/src/VBox/Additions/common/VBoxGuest/VBoxGuest-linux.c (revision 102989)
-+++ b/src/VBox/Additions/common/VBoxGuest/VBoxGuest-linux.c (revision 102990)
-@@ -1410,7 +1410,7 @@
- RTLogGroupSettings(pLogger, pszValue);
- }
- else if (pParam->name[0] != 'd')
-- strlcpy(&g_szLogGrp[0], pszValue, sizeof(g_szLogGrp));
-+ RT_STRSCPY(&g_szLogGrp[0], pszValue, sizeof(g_szLogGrp));
-
- return 0;
- }
-@@ -1436,7 +1436,7 @@
- RTLogFlags(pLogger, pszValue);
- }
- else if (pParam->name[0] != 'd')
-- strlcpy(&g_szLogFlags[0], pszValue, sizeof(g_szLogFlags));
-+ RT_STRSCPY(&g_szLogFlags[0], pszValue, sizeof(g_szLogFlags));
- return 0;
- }
-
-@@ -1461,7 +1461,7 @@
- RTLogDestinations(pLogger, pszValue);
- }
- else if (pParam->name[0] != 'd')
-- strlcpy(&g_szLogDst[0], pszValue, sizeof(g_szLogDst));
-+ RT_STRSCPY(&g_szLogDst[0], pszValue, sizeof(g_szLogDst));
- return 0;
- }
-
-Index: src/VBox/Additions/linux/drm/vbox_drv.h
-===================================================================
---- a/src/VBox/Additions/linux/drm/vbox_drv.h (revision 102989)
-+++ b/src/VBox/Additions/linux/drm/vbox_drv.h (revision 102990)
-@@ -538,9 +538,7 @@
- int vbox_irq_init(struct vbox_private *vbox);
- void vbox_irq_fini(struct vbox_private *vbox);
- void vbox_report_hotplug(struct vbox_private *vbox);
--#if RTLNX_VER_MAX(5,15,0) && !RTLNX_RHEL_MAJ_PREREQ(9,1) && !RTLNX_SUSE_MAJ_PREREQ(15,5)
- irqreturn_t vbox_irq_handler(int irq, void *arg);
--#endif
-
- /* vbox_hgsmi.c */
- void *hgsmi_buffer_alloc(struct gen_pool *guest_pool, size_t size,
-Index: src/VBox/Additions/linux/sharedfolders/vfsmod.c
-===================================================================
---- a/src/VBox/Additions/linux/sharedfolders/vfsmod.c (revision 102989)
-+++ b/src/VBox/Additions/linux/sharedfolders/vfsmod.c (revision 102990)
-@@ -1408,7 +1408,7 @@
- switch (opt) {
- case Opt_iocharset:
- case Opt_nls:
-- strlcpy(info->nls_name, param->string, sizeof(info->nls_name));
-+ RT_STRSCPY(info->nls_name, param->string, sizeof(info->nls_name));
- break;
- case Opt_uid:
- info->uid = result.uint_32;
-@@ -1469,7 +1469,7 @@
- printk(KERN_WARNING "vboxsf: cache mode (%u) is out of range, using default instead.\n", result.uint_32);
- break;
- case Opt_tag:
-- strlcpy(info->szTag, param->string, sizeof(info->szTag));
-+ RT_STRSCPY(info->szTag, param->string, sizeof(info->szTag));
- break;
- default:
- return invalf(fc, "Invalid mount option: '%s'", param->key);
-@@ -1528,7 +1528,7 @@
- }
-
- /* fc->source (the shared folder name) is set after vbsf_init_fs_ctx() */
-- strlcpy(info->name, fc->source, sizeof(info->name));
-+ RT_STRSCPY(info->name, fc->source, sizeof(info->name));
-
- # if RTLNX_VER_MAX(5,3,0)
- return vfs_get_super(fc, vfs_get_independent_super, vbsf_read_super_aux);
-Index: src/VBox/Additions/linux/sharedfolders/regops.c
-===================================================================
---- a/src/VBox/Additions/linux/sharedfolders/regops.c (revision 102989)
-+++ b/src/VBox/Additions/linux/sharedfolders/regops.c (revision 102990)
-@@ -3505,7 +3505,7 @@
- };
-
- /** file_operations::mmap wrapper for logging purposes. */
--extern int vbsf_reg_mmap(struct file *file, struct vm_area_struct *vma)
-+static int vbsf_reg_mmap(struct file *file, struct vm_area_struct *vma)
- {
- int rc;
- SFLOGFLOW(("vbsf_reg_mmap: file=%p vma=%p\n", file, vma));
-@@ -3786,7 +3786,7 @@
- }
-
- # if RTLNX_VER_MIN(5,19,0) || RTLNX_RHEL_RANGE(9,3, 9,99)
--int vbsf_write_begin(struct file *file, struct address_space *mapping, loff_t pos,
-+static int vbsf_write_begin(struct file *file, struct address_space *mapping, loff_t pos,
- unsigned len, struct page **pagep, void **fsdata)
- {
- vbsf_write_begin_warn(pos, len, 0);
-@@ -3793,7 +3793,7 @@
- return simple_write_begin(file, mapping, pos, len, pagep, fsdata);
- }
- # else
--int vbsf_write_begin(struct file *file, struct address_space *mapping, loff_t pos,
-+static int vbsf_write_begin(struct file *file, struct address_space *mapping, loff_t pos,
- unsigned len, unsigned flags, struct page **pagep, void **fsdata)
- {
- vbsf_write_begin_warn(pos, len, flags);
diff --git a/debian/patches/102992.patch b/debian/patches/102992.patch
deleted file mode 100644
index 58319078..00000000
--- a/debian/patches/102992.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: include/iprt/string.h
-===================================================================
---- a/include/iprt/string.h (revision 102991)
-+++ b/include/iprt/string.h (revision 102992)
-@@ -255,16 +255,16 @@
- *
- * @param a_pDst Pointer to the destination string buffer.
- * @param a_pSrc Pointer to the source NULL-terminated string buffer.
-- * @param a_cbToCopy Size of destination buffer..
-+ * @param a_cbDst Size of destination buffer.
- */
- #if defined(RT_OS_LINUX) && defined(__KERNEL__)
- # if (RTLNX_VER_MIN(3,16,60))
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbToCopy) strscpy((a_pDst), (a_pSrc), (a_cbToCopy))
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) (void)strscpy((a_pDst), (a_pSrc), (a_cbDst))
- # else /* < 3.16.60 */
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbToCopy) strlcpy((a_pDst), (a_pSrc), (a_cbToCopy))
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) strlcpy((a_pDst), (a_pSrc), (a_cbDst))
- # endif
- #else /* !RT_OS_LINUX && !__KERNEL__ */
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbToCopy) strscpy((a_pDst), (a_pSrc), (a_cbToCopy))
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) (void)strscpy((a_pDst), (a_pSrc), (a_cbDst))
- #endif /* !RT_OS_LINUX && !__KERNEL__ */
-
-
diff --git a/debian/patches/102993.patch b/debian/patches/102993.patch
deleted file mode 100644
index 6b0c0e9b..00000000
--- a/debian/patches/102993.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: include/iprt/string.h
-===================================================================
---- a/include/iprt/string.h (revision 102992)
-+++ b/include/iprt/string.h (revision 102993)
-@@ -258,7 +258,7 @@
- * @param a_cbDst Size of destination buffer.
- */
- #if defined(RT_OS_LINUX) && defined(__KERNEL__)
--# if (RTLNX_VER_MIN(3,16,60))
-+# if (RTLNX_VER_MIN(4,3,0))
- # define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) (void)strscpy((a_pDst), (a_pSrc), (a_cbDst))
- # else /* < 3.16.60 */
- # define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) strlcpy((a_pDst), (a_pSrc), (a_cbDst))
diff --git a/debian/patches/102994.patch b/debian/patches/102994.patch
deleted file mode 100644
index 93a51709..00000000
--- a/debian/patches/102994.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Index: include/iprt/string.h
-===================================================================
---- a/include/iprt/string.h (revision 102993)
-+++ b/include/iprt/string.h (revision 102994)
-@@ -259,12 +259,16 @@
- */
- #if defined(RT_OS_LINUX) && defined(__KERNEL__)
- # if (RTLNX_VER_MIN(4,3,0))
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) (void)strscpy((a_pDst), (a_pSrc), (a_cbDst))
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) \
-+ { \
-+ ssize_t _ret; \
-+ _ret = strscpy((a_pDst), (a_pSrc), (a_cbDst)); \
-+ }
- # else /* < 3.16.60 */
- # define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) strlcpy((a_pDst), (a_pSrc), (a_cbDst))
- # endif
- #else /* !RT_OS_LINUX && !__KERNEL__ */
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) (void)strscpy((a_pDst), (a_pSrc), (a_cbDst))
-+# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) strlcpy((a_pDst), (a_pSrc), (a_cbDst))
- #endif /* !RT_OS_LINUX && !__KERNEL__ */
-
-
diff --git a/debian/patches/102999.patch b/debian/patches/102999.patch
deleted file mode 100644
index 2c0e3ef3..00000000
--- a/debian/patches/102999.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: include/iprt/string.h
-===================================================================
---- a/include/iprt/string.h (revision 102998)
-+++ b/include/iprt/string.h (revision 102999)
-@@ -249,7 +249,7 @@
- * Copy string and NULL-terminate output buffer.
- *
- * This macro should mostly be used in Linux kernel code. This is
-- * the replacement for deprecated strlcpy. It was deprecated since 3.16.60
-+ * the replacement for deprecated strlcpy. It was deprecated since 4.3.0
- * when strscpy was introduced as an alternative. Finally, strlcpy was
- * completely removed from kernel code in 6.8.0.
- *
-@@ -264,7 +264,7 @@
- ssize_t _ret; \
- _ret = strscpy((a_pDst), (a_pSrc), (a_cbDst)); \
- }
--# else /* < 3.16.60 */
-+# else /* < 4.3.0 */
- # define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) strlcpy((a_pDst), (a_pSrc), (a_cbDst))
- # endif
- #else /* !RT_OS_LINUX && !__KERNEL__ */
diff --git a/debian/patches/103024.patch b/debian/patches/103024.patch
deleted file mode 100644
index 5bd2ba30..00000000
--- a/debian/patches/103024.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-Index: include/iprt/string.h
-===================================================================
---- a/include/iprt/string.h (revision 103023)
-+++ b/include/iprt/string.h (revision 103024)
-@@ -245,33 +245,7 @@
- # define RT_BCOPY_UNFORTIFIED(a_pDst, a_pSrc, a_cbToCopy) memcpy((a_pDst), (a_pSrc), (a_cbToCopy))
- #endif /* !RT_OS_LINUX && !__KERNEL__ */
-
--/** @def RT_STRSCPY
-- * Copy string and NULL-terminate output buffer.
-- *
-- * This macro should mostly be used in Linux kernel code. This is
-- * the replacement for deprecated strlcpy. It was deprecated since 4.3.0
-- * when strscpy was introduced as an alternative. Finally, strlcpy was
-- * completely removed from kernel code in 6.8.0.
-- *
-- * @param a_pDst Pointer to the destination string buffer.
-- * @param a_pSrc Pointer to the source NULL-terminated string buffer.
-- * @param a_cbDst Size of destination buffer.
-- */
--#if defined(RT_OS_LINUX) && defined(__KERNEL__)
--# if (RTLNX_VER_MIN(4,3,0))
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) \
-- { \
-- ssize_t _ret; \
-- _ret = strscpy((a_pDst), (a_pSrc), (a_cbDst)); \
-- }
--# else /* < 4.3.0 */
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) strlcpy((a_pDst), (a_pSrc), (a_cbDst))
--# endif
--#else /* !RT_OS_LINUX && !__KERNEL__ */
--# define RT_STRSCPY(a_pDst, a_pSrc, a_cbDst) strlcpy((a_pDst), (a_pSrc), (a_cbDst))
--#endif /* !RT_OS_LINUX && !__KERNEL__ */
-
--
- #ifdef IN_RING3
-
- /**
-Index: src/VBox/Additions/common/VBoxGuest/VBoxGuest-linux.c
-===================================================================
---- a/src/VBox/Additions/common/VBoxGuest/VBoxGuest-linux.c (revision 103023)
-+++ b/src/VBox/Additions/common/VBoxGuest/VBoxGuest-linux.c (revision 103024)
-@@ -1410,8 +1410,7 @@
- RTLogGroupSettings(pLogger, pszValue);
- }
- else if (pParam->name[0] != 'd')
-- RT_STRSCPY(&g_szLogGrp[0], pszValue, sizeof(g_szLogGrp));
--
-+ RTStrCopy(&g_szLogGrp[0], sizeof(g_szLogGrp), pszValue);
- return 0;
- }
-
-@@ -1436,7 +1435,7 @@
- RTLogFlags(pLogger, pszValue);
- }
- else if (pParam->name[0] != 'd')
-- RT_STRSCPY(&g_szLogFlags[0], pszValue, sizeof(g_szLogFlags));
-+ RTStrCopy(&g_szLogFlags[0], sizeof(g_szLogFlags), pszValue);
- return 0;
- }
-
-@@ -1461,7 +1460,7 @@
- RTLogDestinations(pLogger, pszValue);
- }
- else if (pParam->name[0] != 'd')
-- RT_STRSCPY(&g_szLogDst[0], pszValue, sizeof(g_szLogDst));
-+ RTStrCopy(&g_szLogDst[0], sizeof(g_szLogDst), pszValue);
- return 0;
- }
-
-Index: src/VBox/Additions/linux/sharedfolders/vfsmod.c
-===================================================================
---- a/src/VBox/Additions/linux/sharedfolders/vfsmod.c (revision 103023)
-+++ b/src/VBox/Additions/linux/sharedfolders/vfsmod.c (revision 103024)
-@@ -1408,7 +1408,7 @@
- switch (opt) {
- case Opt_iocharset:
- case Opt_nls:
-- RT_STRSCPY(info->nls_name, param->string, sizeof(info->nls_name));
-+ RTStrCopy(info->nls_name, sizeof(info->nls_name), param->string);
- break;
- case Opt_uid:
- info->uid = result.uint_32;
-@@ -1469,7 +1469,7 @@
- printk(KERN_WARNING "vboxsf: cache mode (%u) is out of range, using default instead.\n", result.uint_32);
- break;
- case Opt_tag:
-- RT_STRSCPY(info->szTag, param->string, sizeof(info->szTag));
-+ RTStrCopy(info->szTag, sizeof(info->szTag), param->string);
- break;
- default:
- return invalf(fc, "Invalid mount option: '%s'", param->key);
-@@ -1528,7 +1528,7 @@
- }
-
- /* fc->source (the shared folder name) is set after vbsf_init_fs_ctx() */
-- RT_STRSCPY(info->name, fc->source, sizeof(info->name));
-+ RTStrCopy(info->name, sizeof(info->name), fc->source);
-
- # if RTLNX_VER_MAX(5,3,0)
- return vfs_get_super(fc, vfs_get_independent_super, vbsf_read_super_aux);
diff --git a/debian/patches/103066.patch b/debian/patches/103066.patch
deleted file mode 100644
index 7346d559..00000000
--- a/debian/patches/103066.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-Index: src/VBox/Runtime/common/log/log.cpp
-===================================================================
---- a/src/VBox/Runtime/common/log/log.cpp (revision 103065)
-+++ b/src/VBox/Runtime/common/log/log.cpp (revision 103066)
-@@ -548,7 +548,7 @@
- uint32_t const fFlags = RT_LO_U16(fFlagsAndGroup);
- uint16_t const iGroup = RT_HI_U16(fFlagsAndGroup);
- if ( iGroup != UINT16_MAX
-- && ( (pLoggerInt->afGroups[iGroup < pLoggerInt->cGroups ? iGroup : 0] & (fFlags | RTLOGGRPFLAGS_ENABLED))
-+ && ( (*(pLoggerInt->afGroups + (iGroup < pLoggerInt->cGroups ? iGroup : 0)) & (fFlags | RTLOGGRPFLAGS_ENABLED))
- != (fFlags | RTLOGGRPFLAGS_ENABLED)))
- pLoggerInt = NULL;
- }
-@@ -1555,7 +1555,7 @@
- pLoggerInt->fFlags |= RTLOGFLAGS_DISABLED;
- iGroup = pLoggerInt->cGroups;
- while (iGroup-- > 0)
-- pLoggerInt->afGroups[iGroup] = 0;
-+ *(pLoggerInt->afGroups + iGroup) = 0;
-
- /*
- * Flush it.
-@@ -1788,9 +1788,9 @@
- for (i = 0; i < pLoggerInt->cGroups; i++)
- {
- if (fEnabled)
-- pLoggerInt->afGroups[i] |= fFlags;
-+ *(pLoggerInt->afGroups + i) |= fFlags;
- else
-- pLoggerInt->afGroups[i] &= ~fFlags;
-+ *(pLoggerInt->afGroups + i) &= ~fFlags;
- }
- }
- else
-@@ -4158,7 +4158,7 @@
- || !pszFormat || !*pszFormat)
- return VINF_LOG_DISABLED;
- if ( iGroup != ~0U
-- && (pLoggerInt->afGroups[iGroup] & (fFlags | RTLOGGRPFLAGS_ENABLED)) != (fFlags | RTLOGGRPFLAGS_ENABLED))
-+ && (*(pLoggerInt->afGroups + iGroup) & (fFlags | RTLOGGRPFLAGS_ENABLED)) != (fFlags | RTLOGGRPFLAGS_ENABLED))
- return VINF_LOG_DISABLED;
-
- /*
-Index: src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c
-===================================================================
---- a/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c (revision 103065)
-+++ b/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c (revision 103066)
-@@ -425,7 +425,7 @@
- {
- fContiguous = true;
- for (iPage = 0; iPage < cPages; iPage++)
-- pMemLnx->apPages[iPage] = &paPages[iPage];
-+ *(pMemLnx->apPages + iPage) = &paPages[iPage];
- }
- else if (fContiguous)
- {
-@@ -441,11 +441,11 @@
- * IPRT_USE_APPLY_TO_PAGE_RANGE_FOR_EXEC. */
- for (iPage = 0; iPage < cPages; iPage++)
- {
-- pMemLnx->apPages[iPage] = alloc_page(fFlagsLnx | __GFP_NOWARN);
-- if (RT_UNLIKELY(!pMemLnx->apPages[iPage]))
-+ *(pMemLnx->apPages + iPage) = alloc_page(fFlagsLnx | __GFP_NOWARN);
-+ if (RT_UNLIKELY(!*(pMemLnx->apPages + iPage)))
- {
- while (iPage-- > 0)
-- __free_page(pMemLnx->apPages[iPage]);
-+ __free_page(*(pMemLnx->apPages + iPage));
- rtR0MemObjDelete(&pMemLnx->Core);
- return rcNoMem;
- }
-@@ -622,7 +622,7 @@
- {
- size_t iPage = pMemLnx->cPages;
- while (iPage-- > 0)
-- if (PageHighMem(pMemLnx->apPages[iPage]))
-+ if (PageHighMem(*(pMemLnx->apPages + iPage)))
- {
- fMustMap = true;
- break;
diff --git a/debian/patches/103067.patch b/debian/patches/103067.patch
deleted file mode 100644
index 702f82d2..00000000
--- a/debian/patches/103067.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-Index: src/VBox/Additions/linux/sharedfolders/vfsmod.c
-===================================================================
---- a/src/VBox/Additions/linux/sharedfolders/vfsmod.c (revision 103066)
-+++ b/src/VBox/Additions/linux/sharedfolders/vfsmod.c (revision 103067)
-@@ -473,8 +473,7 @@
-
- path->u16Length = 1;
- path->u16Size = 2;
-- path->String.utf8[0] = '/';
-- path->String.utf8[1] = 0;
-+ RTStrCopy(path->String.utf8, path->u16Size, "/");
-
- /*
- * Stat the root directory (for inode info).
-Index: src/VBox/Additions/linux/sharedfolders/dirops.c
-===================================================================
---- a/src/VBox/Additions/linux/sharedfolders/dirops.c (revision 103066)
-+++ b/src/VBox/Additions/linux/sharedfolders/dirops.c (revision 103067)
-@@ -492,7 +492,7 @@
- cchSrcName = pEntry->name.u16Length;
- AssertLogRelBreak(offEntryInBuf + RT_UOFFSETOF(SHFLDIRINFO, name.String) + cbSrcName <= cbValid);
- AssertLogRelBreak(cchSrcName < cbSrcName);
-- AssertLogRelBreak(pEntry->name.String.ach[cchSrcName] == '\0');
-+ AssertLogRelBreak(*(pEntry->name.String.ach + cchSrcName) == '\0');
-
- /*
- * Filter out '.' and '..' entires.
-@@ -500,7 +500,7 @@
- if ( cchSrcName > 2
- || pEntry->name.String.ach[0] != '.'
- || ( cchSrcName == 2
-- && pEntry->name.String.ach[1] != '.')) {
-+ && *(pEntry->name.String.ach + 1) != '.')) {
- int const d_type = vbsf_get_d_type(pEntry->Info.Attr.fMode);
- ino_t const d_ino = (ino_t)offPos + 0xbeef; /* very fake */
- bool fContinue;
-Index: src/VBox/Additions/linux/sharedfolders/utils.c
-===================================================================
---- a/src/VBox/Additions/linux/sharedfolders/utils.c (revision 103066)
-+++ b/src/VBox/Additions/linux/sharedfolders/utils.c (revision 103067)
-@@ -1047,9 +1047,9 @@
- RT_BCOPY_UNFORTIFIED(&tmp->String.utf8[0], d_name, d_len + 1);
- else {
- RT_BCOPY_UNFORTIFIED(&tmp->String.utf8[0], p_name, p_len);
-- tmp->String.utf8[p_len] = '/';
-- RT_BCOPY_UNFORTIFIED(&tmp->String.utf8[p_len + 1], d_name, d_len);
-- tmp->String.utf8[p_len + 1 + d_len] = '\0';
-+ *(tmp->String.utf8 + p_len) = '/';
-+ RT_BCOPY_UNFORTIFIED(tmp->String.utf8 + p_len + 1, d_name, d_len);
-+ *(tmp->String.utf8 + p_len + 1 + d_len) = '\0';
- }
-
- *result = tmp;
-Index: include/VBox/VBoxGuestLibSharedFoldersInline.h
-===================================================================
---- a/include/VBox/VBoxGuestLibSharedFoldersInline.h (revision 103066)
-+++ b/include/VBox/VBoxGuestLibSharedFoldersInline.h (revision 103067)
-@@ -1505,7 +1505,7 @@
- pReq->StrPath.u16Length = (uint16_t)cchPath;
- pReq->StrPath.u16Size = (uint16_t)cchPath + 1;
- RT_BCOPY_UNFORTIFIED(pReq->StrPath.String.ach, pszPath, cchPath);
-- pReq->StrPath.String.ach[cchPath] = '\0';
-+ *(pReq->StrPath.String.ach + cchPath) = '\0';
-
- {
- int vrc = VbglR0SfHostReqReadLinkContig(idRoot, pvBuf, PhysBuffer, cbBuffer, pReq);
diff --git a/debian/patches/fix-kernel-build.patch b/debian/patches/fix-kernel-build.patch
deleted file mode 100644
index 5645d89a..00000000
--- a/debian/patches/fix-kernel-build.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Origin: https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/2053024
-Author: Xu Zhen (xuzhen666)
-Forwarded: irc
-diff --git a/src/VBox/HostDrivers/Support/SUPDrvTracer.cpp b/src/VBox/HostDrivers/Support/SUPDrvTracer.cpp
-index 7b25b5cec..5cc50bf15 100644
---- a/src/VBox/HostDrivers/Support/SUPDrvTracer.cpp
-+++ b/src/VBox/HostDrivers/Support/SUPDrvTracer.cpp
-@@ -1476,6 +1476,8 @@ SUPR0DECL(int) SUPR0TracerDeregisterImpl(void *hMod, PSUPDRVSESSION pSession)
- SUPR0_EXPORT_SYMBOL(SUPR0TracerDeregisterImpl);
-
-
-+#include <asm/nospec-branch.h>
-+#include <asm/linkage.h>
- /*
- * The probe function is a bit more fun since we need tail jump optimizating.
- *
-@@ -1495,11 +1497,13 @@ SUPR0TracerFireProbe: \n\
- # if defined(RT_ARCH_AMD64)
- __asm__("\
- movq g_pfnSupdrvProbeFireKernel(%rip), %rax \n\
-+ " ANNOTATE_RETPOLINE_SAFE " \n\
- jmp *%rax \n\
- ");
- # elif defined(RT_ARCH_X86)
- __asm__("\
- movl g_pfnSupdrvProbeFireKernel, %eax \n\
-+ " ANNOTATE_RETPOLINE_SAFE " \n\
- jmp *%eax \n\
- ");
- # else
-@@ -1511,7 +1515,7 @@ __asm__("\
- .type supdrvTracerProbeFireStub,@function \n\
- .global supdrvTracerProbeFireStub \n\
- supdrvTracerProbeFireStub: \n\
-- ret \n\
-+ " ASM_RET " \n\
- .size supdrvTracerProbeFireStub, . - supdrvTracerProbeFireStub \n\
- \n\
- .previous \n\
diff --git a/debian/patches/gcc-13.patch b/debian/patches/gcc-13.patch
deleted file mode 100644
index e1234cce..00000000
--- a/debian/patches/gcc-13.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/libs/dxvk-native-1.9.2a/src/util/util_bit.h b/src/libs/dxvk-native-1.9.2a/src/util/util_bit.h
-index 3c65c70df..d283792f2 100644
---- a/src/libs/dxvk-native-1.9.2a/src/util/util_bit.h
-+++ b/src/libs/dxvk-native-1.9.2a/src/util/util_bit.h
-@@ -16,6 +16,7 @@
- #include "util_likely.h"
- #include "util_math.h"
-
-+#include <cstdint>
- #include <cstring>
- #include <iterator>
- #include <type_traits>
diff --git a/debian/patches/series b/debian/patches/series
index b13e272b..07cab078 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -14,14 +14,3 @@
35-libvdeplug-soname.patch
36-fix-vnc-version-string.patch
37-do-not-run-if-not-in-vm.patch
-gcc-13.patch
-102989.patch
-102990.patch
-102992.patch
-102993.patch
-102994.patch
-102999.patch
-103024.patch
-103066.patch
-103067.patch
-fix-kernel-build.patch