summaryrefslogtreecommitdiffstats
path: root/src/VBox/Disassembler/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
commitf215e02bf85f68d3a6106c2a1f4f7f063f819064 (patch)
tree6bb5b92c046312c4e95ac2620b10ddf482d3fa8b /src/VBox/Disassembler/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-upstream/7.0.14-dfsg.tar.xz
virtualbox-upstream/7.0.14-dfsg.zip
Adding upstream version 7.0.14-dfsg.upstream/7.0.14-dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Disassembler/Makefile.kmk')
-rw-r--r--src/VBox/Disassembler/Makefile.kmk91
1 files changed, 91 insertions, 0 deletions
diff --git a/src/VBox/Disassembler/Makefile.kmk b/src/VBox/Disassembler/Makefile.kmk
new file mode 100644
index 00000000..cdc72106
--- /dev/null
+++ b/src/VBox/Disassembler/Makefile.kmk
@@ -0,0 +1,91 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the VBox Disassembler.
+#
+
+#
+# Copyright (C) 2006-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+SUB_DEPTH = ../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+# include the sub-makefile first.
+if defined(VBOX_WITH_TESTCASES) && !defined(VBOX_ONLY_VALIDATIONKIT)
+ include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk
+endif
+
+
+LIBRARIES += DisasmR3
+DisasmR3_TEMPLATE = VBoxR3Dll
+DisasmR3_DEFS = IN_DIS
+DisasmR3_SOURCES = \
+ Disasm.cpp \
+ DisasmCore.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp \
+ DisasmMisc.cpp \
+ DisasmFormatBytes.cpp \
+ DisasmFormatYasm.cpp
+
+LIBRARIES += DisasmR3Static
+DisasmR3Static_TEMPLATE = VBoxR3Static
+DisasmR3Static_EXTENDS = DisasmR3
+
+ifndef VBOX_ONLY_VALIDATIONKIT
+
+ LIBRARIES += DisasmBldProg
+ DisasmBldProg_TEMPLATE = VBoxAdvBldProg
+ DisasmBldProg_EXTENDS = DisasmR3
+
+ LIBRARIES += DisasmCoreR3
+ DisasmCoreR3_TEMPLATE = VBoxR3Dll
+ DisasmCoreR3_DEFS = IN_DIS DIS_CORE_ONLY
+ DisasmCoreR3_SOURCES = \
+ DisasmCore.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp \
+ DisasmMisc.cpp
+
+ ifdef VBOX_WITH_RAW_MODE
+ LIBRARIES += DisasmRC
+ DisasmRC_TEMPLATE = VBoxRc
+ DisasmRC_DEFS = IN_DIS IN_RT_RC DIS_CORE_ONLY
+ DisasmRC_SOURCES = \
+ DisasmCore.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp \
+ DisasmMisc.cpp
+ endif # VBOX_WITH_RAW_MODE
+
+ LIBRARIES += DisasmR0
+ DisasmR0_TEMPLATE = VBoxR0
+ DisasmR0_DEFS = IN_DIS IN_RT_R0 DIS_CORE_ONLY
+ DisasmR0_SOURCES = \
+ DisasmCore.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp \
+ DisasmMisc.cpp
+
+endif # !VBOX_ONLY_VALIDATIONKIT
+
+include $(FILE_KBUILD_SUB_FOOTER)
+