summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/darwin/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:45 +0000
commit04aecf1372d30eb709d8de65152535ab66dcb74a (patch)
treed1e4d8c453a76465e8b63119314a28d39b474479 /src/VBox/Installer/darwin/Makefile.kmk
parentAdding upstream version 7.0.14-dfsg. (diff)
downloadvirtualbox-5f720d3b2235aa93d71b3ff117e90531ab4c4410.tar.xz
virtualbox-5f720d3b2235aa93d71b3ff117e90531ab4c4410.zip
Adding upstream version 7.0.16-dfsg.upstream/7.0.16-dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Installer/darwin/Makefile.kmk')
-rw-r--r--src/VBox/Installer/darwin/Makefile.kmk6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/VBox/Installer/darwin/Makefile.kmk b/src/VBox/Installer/darwin/Makefile.kmk
index 494fd990..1b7a16f8 100644
--- a/src/VBox/Installer/darwin/Makefile.kmk
+++ b/src/VBox/Installer/darwin/Makefile.kmk
@@ -483,6 +483,12 @@ if defined(VBOX_WITH_PYTHON) && !defined(VBOX_WITHOUT_VBOXPYTHON_FOR_OSX_10_7)
VBOX_DI_VBAPP_DYLIBS += \
MacOS/VBoxPython2_7.so
endif
+if defined(VBOX_WITH_PYTHON) \
+ && !defined(VBOX_WITHOUT_PYTHON_LIMITED_API) \
+ && exists "$(VBOX_PATH_DIST)/VirtualBox.app/Contents/MacOS/VBoxPython3.so"
+ VBOX_DI_VBAPP_DYLIBS += \
+ MacOS/VBoxPython3.so
+endif
ifdef VBOX_WITH_VMSVGA3D
VBOX_DI_VBAPP_DYLIBS += \
MacOS/VBoxSVGA3D.dylib \