summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/win/InstallHelper/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:52 +0000
commitcd47c2446f1a9dee96610f298989848f8986a8be (patch)
tree02c30d62a9164987d0aaba2f72c58a50053205d6 /src/VBox/Installer/win/InstallHelper/Makefile.kmk
parentReleasing progress-linux version 7.0.14-dfsg-4~progress7.99u1. (diff)
downloadvirtualbox-cd47c2446f1a9dee96610f298989848f8986a8be.tar.xz
virtualbox-cd47c2446f1a9dee96610f298989848f8986a8be.zip
Merging upstream version 7.0.16-dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Installer/win/InstallHelper/Makefile.kmk')
-rw-r--r--src/VBox/Installer/win/InstallHelper/Makefile.kmk20
1 files changed, 10 insertions, 10 deletions
diff --git a/src/VBox/Installer/win/InstallHelper/Makefile.kmk b/src/VBox/Installer/win/InstallHelper/Makefile.kmk
index cad3c4c3..38525a7d 100644
--- a/src/VBox/Installer/win/InstallHelper/Makefile.kmk
+++ b/src/VBox/Installer/win/InstallHelper/Makefile.kmk
@@ -33,9 +33,16 @@ DLLS += VBoxInstallHelper
VBoxInstallHelper_TEMPLATE = VBoxR3StaticDllNoAsan
VBoxInstallHelper_SDKS = ReorderCompilerIncs $(VBOX_WINPSDK) $(VBOX_WINDDK)
VBoxInstallHelper_DEFS = _WIN32_WINNT=0x0501 _UNICODE UNICODE VBOX_SVN_REV=$(VBOX_SVN_REV)
-ifdef VBOX_WITH_NETFLT
+if defined(VBOX_WITH_NETFLT) || defined(VBOX_WITH_NETADP)
VBoxInstallHelper_SDKS += VBoxWinNewDevLib
- VBoxInstallHelper_DEFS += VBOX_WITH_NETFLT=1
+ VBoxInstallHelper_DEFS += \
+ $(if $(VBOX_WITH_NETFLT),VBOX_WITH_NETFLT,) \
+ $(if $(VBOX_WITH_NETADP),VBOX_WITH_NETADP,)
+ VBoxInstallHelper_LIBS += \
+ $(PATH_STAGE_LIB)/WinNetConfigSharedStatic.lib \
+ $(PATH_STAGE_LIB)/VBoxDrvCfgSharedStatic.lib \
+ $(PATH_TOOL_$(VBOX_VCC_TOOL)_LIB)/comsupp.lib \
+ $(PATH_SDK_$(VBOX_WINPSDK)_LIB)/WbemUuid.Lib
endif
VBoxInstallHelper_DEPS = $(VBOX_SVN_REV_KMK)
VBoxInstallHelper_SOURCES = \
@@ -47,15 +54,8 @@ ifndef VBOX_OSE
VBoxInstallHelper_SOURCES += \
internal/VBoxSerial.cpp
endif
-VBoxInstallHelper_LIBS = \
+VBoxInstallHelper_LIBS += \
$(PATH_SDK_$(VBOX_WINPSDK)_LIB)/Msi.lib
-ifdef VBOX_WITH_NETFLT
- VBoxInstallHelper_LIBS += \
- $(PATH_STAGE_LIB)/WinNetConfigSharedStatic.lib \
- $(PATH_STAGE_LIB)/VBoxDrvCfgSharedStatic.lib \
- $(PATH_TOOL_$(VBOX_VCC_TOOL)_LIB)/comsupp.lib \
- $(PATH_SDK_$(VBOX_WINPSDK)_LIB)/WbemUuid.Lib
-endif
if "$(KBUILD_TARGET)" == "win" && defined(VBOX_WITH_TESTCASES) && !defined(VBOX_OSE)
include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk