summaryrefslogtreecommitdiffstats
path: root/src/VBox/Storage/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
commitf215e02bf85f68d3a6106c2a1f4f7f063f819064 (patch)
tree6bb5b92c046312c4e95ac2620b10ddf482d3fa8b /src/VBox/Storage/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-f215e02bf85f68d3a6106c2a1f4f7f063f819064.tar.xz
virtualbox-f215e02bf85f68d3a6106c2a1f4f7f063f819064.zip
Adding upstream version 7.0.14-dfsg.upstream/7.0.14-dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Storage/Makefile.kmk')
-rw-r--r--src/VBox/Storage/Makefile.kmk90
1 files changed, 90 insertions, 0 deletions
diff --git a/src/VBox/Storage/Makefile.kmk b/src/VBox/Storage/Makefile.kmk
new file mode 100644
index 00000000..48d5bb0a
--- /dev/null
+++ b/src/VBox/Storage/Makefile.kmk
@@ -0,0 +1,90 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the Storage library.
+#
+
+#
+# Copyright (C) 2006-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+SUB_DEPTH = ../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+VBOX_PATH_STORAGE_SRC := $(PATH_SUB_CURRENT)
+
+if !defined(VBOX_ONLY_EXTPACKS)
+ include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk
+
+ #
+ # StorageLib - The storage Library.
+ #
+ LIBRARIES += StorageLib #StorageLibNoDB
+
+ StorageLib_TEMPLATE = VBoxR3Dll
+ StorageLib_DEFS = IN_VBOXDDU
+ ifeq ($(USER),bird)
+ StorageLib_DEFS.debug += RTMEM_WRAP_TO_EF_APIS
+ endif
+
+ StorageLib_SOURCES = \
+ VD.cpp \
+ VDPlugin.cpp \
+ VDVfs.cpp \
+ VDIfVfs.cpp \
+ VDIfVfs2.cpp \
+ VDIfTcpNet.cpp \
+ VDI.cpp \
+ VMDK.cpp \
+ VHD.cpp \
+ DMG.cpp \
+ Parallels.cpp \
+ ISCSI.cpp \
+ RAW.cpp \
+ QED.cpp \
+ QCOW.cpp \
+ VHDX.cpp \
+ CUE.cpp \
+ VISO.cpp \
+ VCICache.cpp
+endif # !VBOX_ONLY_EXTPACKS
+
+if defined(VBOX_WITH_EXTPACK_PUEL) && defined(VBOX_WITH_EXTPACK_PUEL_BUILD)
+ if defined(VBOX_WITH_PLUGIN_CRYPT)
+ DLLS += VDPluginCrypt
+ VDPluginCrypt_TEMPLATE = VBoxR3ExtPackPuelWithOpenSsl
+ VDPluginCrypt_LDFLAGS.linux = $(VBOX_GCC_NO_UNDEFINED)
+ VDPluginCrypt_DEFS = $(if $(VD_WITH_IPRT_CRYPTO),VD_WITH_IPRT_CRYPTO,)
+ VDPluginCrypt_SOURCES = \
+ VDFilterCrypt.cpp \
+ VDKeyStore.cpp
+ VDPluginCrypt_SOURCES.win = \
+ VDPluginCrypt.rc
+ endif
+endif # VBOX_WITH_EXTPACK_PUEL
+
+#StorageLibNoDB_TEMPLATE = VBoxR3Dll
+#StorageLibNoDB_DEFS = IN_VBOXDDU VBOX_HDD_NO_DYNAMIC_BACKENDS
+#StorageLibNoDB_SOURCES = \
+# $(StorageLib_SOURCES)
+
+# generate rules
+include $(FILE_KBUILD_SUB_FOOTER)
+