summaryrefslogtreecommitdiffstats
path: root/src/apps/svnsync-vbox/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
commitf215e02bf85f68d3a6106c2a1f4f7f063f819064 (patch)
tree6bb5b92c046312c4e95ac2620b10ddf482d3fa8b /src/apps/svnsync-vbox/Makefile
parentInitial commit. (diff)
downloadvirtualbox-f215e02bf85f68d3a6106c2a1f4f7f063f819064.tar.xz
virtualbox-f215e02bf85f68d3a6106c2a1f4f7f063f819064.zip
Adding upstream version 7.0.14-dfsg.upstream/7.0.14-dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/apps/svnsync-vbox/Makefile')
-rw-r--r--src/apps/svnsync-vbox/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/apps/svnsync-vbox/Makefile b/src/apps/svnsync-vbox/Makefile
new file mode 100644
index 00000000..2a4bfdd7
--- /dev/null
+++ b/src/apps/svnsync-vbox/Makefile
@@ -0,0 +1,46 @@
+# $Id: Makefile $
+## @file
+# Makefile
+#
+
+#
+# Copyright (C) 2006-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+CC = gcc
+CFLAGS = -O2 -g -Wall -pedantic -Wno-long-long -Wno-trigraphs \
+ -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+DEFS = -DVBOX -D_FILE_OFFSET_BITS=64
+INCS = -I. -I/usr/include/subversion-1 -I/usr/include/apr-1.0
+LIBS = -lsvn_ra-1 -lsvn_ra_local-1 \
+ -lsvn_repos-1 -lsvn_fs-1 -lsvn_delta-1 \
+ -lsvn_subr-1 -lapr-1 -laprutil-1 \
+ -ldb
+
+all: svnsync-vbox
+
+svnsync-vbox: main.c
+ $(CC) $(CFLAGS) $(DEFS) $(INCS) $(LIBS) -o $@ $<
+
+svnsync-vbox: svn_private_config.h
+
+svnsync-vbox: Makefile
+