summaryrefslogtreecommitdiffstats
path: root/src/VBox/Additions/3D/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Additions/3D/Makefile.kmk')
-rw-r--r--src/VBox/Additions/3D/Makefile.kmk46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/VBox/Additions/3D/Makefile.kmk b/src/VBox/Additions/3D/Makefile.kmk
new file mode 100644
index 00000000..eca2615f
--- /dev/null
+++ b/src/VBox/Additions/3D/Makefile.kmk
@@ -0,0 +1,46 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the Mesa3D code.
+#
+
+#
+# Copyright (C) 2016-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+#
+# Make sure our Config.kmk is included.
+#
+ifndef VBOX_MESA3D_CONFIG_KMK_INCLUDED
+ include $(PATH_SUB_CURRENT)/Config.kmk
+endif
+
+#
+# Include sub-makefile.
+#
+include $(PATH_SUB_CURRENT)/mesa/Makefile.kmk
+if1of ($(KBUILD_TARGET), win)
+ include $(PATH_SUB_CURRENT)/win/Makefile.kmk
+endif
+
+include $(FILE_KBUILD_SUB_FOOTER)