summaryrefslogtreecommitdiffstats
path: root/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/Common/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/Common/Makefile.kmk')
-rw-r--r--src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/Common/Makefile.kmk63
1 files changed, 63 insertions, 0 deletions
diff --git a/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/Common/Makefile.kmk b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/Common/Makefile.kmk
new file mode 100644
index 00000000..aab8f640
--- /dev/null
+++ b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/Common/Makefile.kmk
@@ -0,0 +1,63 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-makefile for the EFI build tool common library.
+#
+
+#
+# Copyright (C) 2013-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL), a copy of it is provided in the "COPYING.CDDL" file included
+# in the VirtualBox distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+# SPDX-License-Identifier: GPL-3.0-only OR CDDL-1.0
+#
+
+SUB_DEPTH = ../../../../../../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+LIBRARIES += EfiBldCommonLib
+EfiBldCommonLib_TEMPLATE = VBoxEfiBldLib
+EfiBldCommonLib_SOURCES = \
+ BasePeCoff.c \
+ BinderFuncs.c \
+ CommonLib.c \
+ Crc32.c \
+ Decompress.c \
+ EfiCompress.c \
+ EfiUtilityMsgs.c \
+ FirmwareVolumeBuffer.c \
+ FvLib.c \
+ MemoryFile.c \
+ MyAlloc.c \
+ OsPath.c \
+ ParseGuidedSectionTools.c \
+ ParseInf.c \
+ PeCoffLoaderEx.c \
+ SimpleFileParsing.c \
+ StringFuncs.c \
+ TianoCompress.c
+
+include $(FILE_KBUILD_SUB_FOOTER)
+