summaryrefslogtreecommitdiffstats
path: root/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/GNUmakefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/GNUmakefile')
-rw-r--r--src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/GNUmakefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/GNUmakefile b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/GNUmakefile
new file mode 100644
index 00000000..d8eb9cb4
--- /dev/null
+++ b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/GNUmakefile
@@ -0,0 +1,27 @@
+## @file
+# GNU/Linux makefile for 'LzmaCompress' module build.
+#
+# Copyright (c) 2009 - 2019, Intel Corporation. All rights reserved.<BR>
+# SPDX-License-Identifier: BSD-2-Clause-Patent
+#
+MAKEROOT ?= ..
+
+APPNAME = LzmaCompress
+
+LIBS = -lCommon
+
+SDK_C = Sdk/C
+
+OBJECTS = \
+ LzmaCompress.o \
+ $(SDK_C)/Alloc.o \
+ $(SDK_C)/LzFind.o \
+ $(SDK_C)/LzmaDec.o \
+ $(SDK_C)/LzmaEnc.o \
+ $(SDK_C)/7zFile.o \
+ $(SDK_C)/7zStream.o \
+ $(SDK_C)/Bra86.o
+
+include $(MAKEROOT)/Makefiles/app.makefile
+
+BUILD_CFLAGS += -D_7ZIP_ST