summaryrefslogtreecommitdiffstats
path: root/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile37
-rw-r--r--src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile.kmk58
2 files changed, 95 insertions, 0 deletions
diff --git a/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile
new file mode 100644
index 00000000..2f410a1e
--- /dev/null
+++ b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile
@@ -0,0 +1,37 @@
+## @file
+# Windows makefile for 'LzmaCompress' module build.
+#
+# Copyright (c) 2009 - 2019, Intel Corporation. All rights reserved.<BR>
+# SPDX-License-Identifier: BSD-2-Clause-Patent
+#
+!INCLUDE ..\Makefiles\ms.common
+
+APPNAME = LzmaCompress
+
+LIBS = $(LIB_PATH)\Common.lib
+
+SDK_C = Sdk\C
+
+OBJECTS = \
+ LzmaCompress.obj \
+ $(SDK_C)\Alloc.obj \
+ $(SDK_C)\LzFind.obj \
+ $(SDK_C)\LzmaDec.obj \
+ $(SDK_C)\LzmaEnc.obj \
+ $(SDK_C)\7zFile.obj \
+ $(SDK_C)\7zStream.obj \
+ $(SDK_C)\Bra86.obj \
+ $(SDK_C)\LzFindMt.obj \
+ $(SDK_C)\Threads.obj
+
+!INCLUDE ..\Makefiles\ms.app
+
+all: $(BIN_PATH)\LzmaF86Compress.bat
+
+$(BIN_PATH)\LzmaF86Compress.bat: LzmaF86Compress.bat
+ copy LzmaF86Compress.bat $(BIN_PATH)\LzmaF86Compress.bat /Y
+
+cleanall: localCleanall
+
+localCleanall:
+ del /f /q $(BIN_PATH)\LzmaF86Compress.bat > nul
diff --git a/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile.kmk b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile.kmk
new file mode 100644
index 00000000..846c9fab
--- /dev/null
+++ b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/LzmaCompress/Makefile.kmk
@@ -0,0 +1,58 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-makefile for the EFI LzmaCompress build tool.
+#
+
+#
+# Copyright (C) 2013-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL), a copy of it is provided in the "COPYING.CDDL" file included
+# in the VirtualBox distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+# SPDX-License-Identifier: GPL-3.0-only OR CDDL-1.0
+#
+
+SUB_DEPTH = ../../../../../../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+BLDPROGS += LzmaCompress
+LzmaCompress_TEMPLATE = VBoxEfiBldProg
+LzmaCompress_DEFS = _7ZIP_ST
+LzmaCompress_SOURCES = \
+ LzmaCompress.c \
+ Sdk/C/Alloc.c \
+ Sdk/C/LzFind.c \
+ Sdk/C/LzmaDec.c \
+ Sdk/C/LzmaEnc.c \
+ Sdk/C/7zFile.c \
+ Sdk/C/7zStream.c \
+ Sdk/C/Bra86.c
+
+BLDPROGS += LzmaF86Compress
+LzmaF86Compress_EXTENDS = LzmaCompress
+LzmaF86Compress_DEFS = VBOX_LZMA_F86_COMPRESS _7ZIP_ST
+
+include $(FILE_KBUILD_SUB_FOOTER)
+