summaryrefslogtreecommitdiffstats
path: root/src/VBox/Frontends/Common/VBoxKeyboard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Frontends/Common/VBoxKeyboard/Makefile')
-rw-r--r--src/VBox/Frontends/Common/VBoxKeyboard/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/VBox/Frontends/Common/VBoxKeyboard/Makefile b/src/VBox/Frontends/Common/VBoxKeyboard/Makefile
new file mode 100644
index 00000000..8acf1dc5
--- /dev/null
+++ b/src/VBox/Frontends/Common/VBoxKeyboard/Makefile
@@ -0,0 +1,34 @@
+# $Id: Makefile $
+## @file
+# Makefile for building the VirtualBox keyboard handler library.
+#
+
+# Note that for reasons of convenience, VirtualBox builds this library
+# from inside its own build system rather than using this file.
+
+#
+# Copyright (C) 2007-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+CFLAGS = -I. -fPIC
+
+VBoxKeyboard.so : keyboard.o
+ gcc -shared -o VBoxKeyboard.so keyboard.o -lX11