summaryrefslogtreecommitdiffstats
path: root/src/VBox/HostDrivers/win/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/HostDrivers/win/Makefile.kmk')
-rw-r--r--src/VBox/HostDrivers/win/Makefile.kmk66
1 files changed, 66 insertions, 0 deletions
diff --git a/src/VBox/HostDrivers/win/Makefile.kmk b/src/VBox/HostDrivers/win/Makefile.kmk
new file mode 100644
index 00000000..ed68e39a
--- /dev/null
+++ b/src/VBox/HostDrivers/win/Makefile.kmk
@@ -0,0 +1,66 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for Windows driver tooling lib.
+#
+
+#
+# Copyright (C) 2011-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL), a copy of it is provided in the "COPYING.CDDL" file included
+# in the VirtualBox distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+# SPDX-License-Identifier: GPL-3.0-only OR CDDL-1.0
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+# For the installer helper DLL.
+LIBRARIES += VBoxDrvCfgSharedStatic
+VBoxDrvCfgSharedStatic_TEMPLATE := VBoxR3StaticDllNoAsan
+VBoxDrvCfgSharedStatic_SDKS = ReorderCompilerIncs $(VBOX_WINPSDK) $(VBOX_WINDDK)
+VBoxDrvCfgSharedStatic_DEFS := _WIN32_WINNT=0x0501 _UNICODE UNICODE
+VBoxDrvCfgSharedStatic_SOURCES := cfg/VBoxDrvCfg.cpp
+
+# For the driver installer/uninstaller executables.
+LIBRARIES += VBoxDrvCfgExe
+VBoxDrvCfgExe_TEMPLATE := VBoxR3Exe
+VBoxDrvCfgExe_EXTENDS := VBoxDrvCfgSharedStatic
+
+# For the regular VBox DLLs.
+LIBRARIES += VBoxDrvCfgDll
+VBoxDrvCfgDll_TEMPLATE := VBoxR3Dll
+VBoxDrvCfgDll_EXTENDS := VBoxDrvCfgSharedStatic
+
+
+INSTALLS += HostDrivers-scripts
+HostDrivers-scripts_INST = $(INST_DIST)
+HostDrivers-scripts_EXEC_SOURCES = \
+ loadall.cmd \
+ load.cmd
+
+# generate rules
+include $(FILE_KBUILD_SUB_FOOTER)
+