summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/win
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Installer/win')
-rw-r--r--src/VBox/Installer/win/Makefile.kmk42
-rw-r--r--src/VBox/Installer/win/NLS/de_DE.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/el_GR.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/en_US.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/fa_IR.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/fr_FR.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/it_IT.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/ru_RU.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/tr_TR.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/zh_CN.wxl4
-rw-r--r--src/VBox/Installer/win/NLS/zh_TW.wxl4
-rw-r--r--src/VBox/Installer/win/Stub/Makefile.kmk2
-rw-r--r--src/VBox/Installer/win/UserInterface.wxi9
-rw-r--r--src/VBox/Installer/win/VirtualBox.wxs2
14 files changed, 49 insertions, 46 deletions
diff --git a/src/VBox/Installer/win/Makefile.kmk b/src/VBox/Installer/win/Makefile.kmk
index 4b91b460..962f3966 100644
--- a/src/VBox/Installer/win/Makefile.kmk
+++ b/src/VBox/Installer/win/Makefile.kmk
@@ -595,7 +595,7 @@ endef
ifdef VBOX_WITH_MSM_INSTALL
$(foreach module,$(VBOX_INSTALLER_MERGE_MODULES), \
$(foreach lang,$(VBOX_INSTALLER_MERGE_LANGUAGES), \
- $(eval $(def_vbox_link_msm)))),)
+ $(eval $(def_vbox_link_msm))))
endif
@@ -1215,12 +1215,12 @@ else
$(QUIET)$(RM) -f -- $(wildcard $(subst r$(VBOX_SVN_REV),r*, \
$@ \
$(VBOX_WIN_INST_REPACK_DIR)/4-multiarch-$(PACKAGE_NAME_MULTIARCH_FINAL).cmd ) )
- $(REDIRECT) -C $(@D) -- \
+ $(REDIRECT) -C "$(@D)" -- \
$(VBoxStubBld_1_TARGET) -out $@ \
-target-$(KBUILD_TARGET_ARCH) $(PACKAGE_NAME_FINAL) \
-stub $(PATH_STAGE_BIN)/VBoxStub.exe
$(VBOX_VCC_EDITBIN) /IntegrityCheck:NO $@
- $(call VBOX_SIGN_FILE_FN,$@)
+ $(call VBOX_SIGN_FILE_FN,$@,,,,,,timed)
# Create repack script for this step.
$(APPEND) -nt "$(VBOX_WIN_INST_REPACK_DIR)/4-multiarch-$(@F).cmd" \
'if ".%KBUILD_DEVTOOLS%" == "." (echo KBUILD_DEVTOOLS is not set & exit /b1)' \
@@ -1238,27 +1238,31 @@ else
echo "Repacking HERE"
$(RM) -f $(VBOX_WIN_INST_REPACK_DIR)/*.ddf
cd $(PATH_OUT)/repack && $(RM) -f *.ddf
- $(RM) -f $(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab
- $(RM) -f $(VBOX_WIN_INST_REPACK_DIR)/PackDriversForSubmission_internal.cmd
+ $(RM) -f -- \
+ "$(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab" \
+ "$(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab.ddf" \
+ "$(VBOX_WIN_INST_REPACK_DIR)/PackDriversForSubmission_internal.cmd"
+ cd $(VBOX_WIN_INST_REPACK_DIR) && ls -la
$(APPEND) -nt "$(VBOX_WIN_INST_REPACK_DIR)/PackDriversForSubmission_internal.cmd" \
- "SET KBUILD_BIN_PATH=$(KBUILD_BIN_PATH)" \
- "call PackDriversForSubmission.cmd -b $(PATH_STAGE_BIN) -a $(KBUILD_TARGET_ARCH) \
+ "SET KBUILD_BIN_PATH=$(KBUILD_BIN_PATH)" \
+ "call PackDriversForSubmission.cmd -b $(PATH_STAGE_BIN) -a $(KBUILD_TARGET_ARCH) \
-x -n --no-extpack -o $(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab"
- cd $(VBOX_WIN_INST_REPACK_DIR) && $(EXEC_X86_WIN32) cmd.exe /c PackDriversForSubmission_internal.cmd
- cd $(VBOX_WIN_INST_REPACK_DIR) && $(VBOX_RETRY) $(VBOX_WIN_ATTESTATION_SIGNING_EXE) "Oracle VM VirtualBox Base drivers $(KBUILD_TARGET_ARCH) $(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)r$(VBOX_SVN_REV)" "$(KBUILD_TARGET_ARCH)" "r$(VBOX_SVN_REV)" "$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab"
+ $(TIME_EXT) $(REDIRECT_EXT) -C "$(VBOX_WIN_INST_REPACK_DIR)" -- $(EXEC_X86_WIN32) cmd.exe /c PackDriversForSubmission_internal.cmd
+ $(TIME_EXT) $(REDIRECT_EXT) -C "$(VBOX_WIN_INST_REPACK_DIR)" -- $(VBOX_RETRY) $(VBOX_WIN_ATTESTATION_SIGNING_EXE) "Oracle VM VirtualBox Base drivers $(KBUILD_TARGET_ARCH) $(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)r$(VBOX_SVN_REV)" "$(KBUILD_TARGET_ARCH)" "r$(VBOX_SVN_REV)" "$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab"
- $(RM) -f $(VBOX_WIN_INST_REPACK_DIR)/Single-3-Repack_internal.cmd
+ $(RM) -f -- "$(VBOX_WIN_INST_REPACK_DIR)/Single-3-Repack_internal.cmd"
$(APPEND) -nt "$(VBOX_WIN_INST_REPACK_DIR)/Single-3-Repack_internal.cmd" \
- "SET KBUILD_BIN_PATH=$(KBUILD_BIN_PATH)" \
- "SET KBUILD_DEVTOOLS=$(KBUILD_DEVTOOLS)" \
- "call Single-3-Repack.cmd --no-extpack --signed "$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab.Signed.zip"
- cd $(VBOX_WIN_INST_REPACK_DIR) && $(EXEC_X86_WIN32) cmd.exe /c Single-3-Repack_internal.cmd
-
- $(RM) -f $(PATH_STAGE_BIN)/$(PACKAGE_NAME_MULTIARCH_FINAL)
- $(RM) -f $(PATH_STAGE_BIN)/$(PACKAGE_NAME_LANG).msi
- $(CP) $(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_MULTIARCH_FINAL) $(PATH_STAGE_BIN)/
- $(CP) $(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_LANG).msi $(PATH_STAGE_BIN)/
+ "SET KBUILD_BIN_PATH=$(KBUILD_BIN_PATH)" \
+ "SET KBUILD_DEVTOOLS=$(KBUILD_DEVTOOLS)" \
+ "call Single-3-Repack.cmd --no-extpack --signed "$(PACKAGE_NAME_LANG)-$(KBUILD_TARGET_ARCH).cab.Signed.zip"
+ $(TIME_EXT) $(REDIRECT_EXT) -C "$(VBOX_WIN_INST_REPACK_DIR)" -- $(EXEC_X86_WIN32) cmd.exe /c Single-3-Repack_internal.cmd
+
+ $(RM) -f -- \
+ "$(PATH_STAGE_BIN)/$(PACKAGE_NAME_MULTIARCH_FINAL)" \
+ "$(PATH_STAGE_BIN)/$(PACKAGE_NAME_LANG).msi"
+ $(CP) -- "$(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_MULTIARCH_FINAL)" "$(PATH_STAGE_BIN)/"
+ $(CP) -- "$(VBOX_WIN_INST_REPACK_DIR)/$(PACKAGE_NAME_LANG).msi" "$(PATH_STAGE_BIN)/"
endif
endif
diff --git a/src/VBox/Installer/win/NLS/de_DE.wxl b/src/VBox/Installer/win/NLS/de_DE.wxl
index d4b004f1..e177e190 100644
--- a/src/VBox/Installer/win/NLS/de_DE.wxl
+++ b/src/VBox/Installer/win/NLS/de_DE.wxl
@@ -74,7 +74,7 @@
<String Id="Only64Bit">Diese Applikation läuft nur auf 64-bit Windows-Systemen. Bitte installieren Sie die 32-bit Version von [ProductName]!</String>
<String Id="SunFound">Eine alte Sun Version von VirtualBox wurde auf diesem Computer gefunden. Bitte deinstallieren Sie diese Version zuerst. Danach können Sie [ProductName] installieren!</String>
<String Id="InnotekFound">Eine alte innotek Version von VirtualBox wurde auf diesem Computer gefunden. Bitte deinstallieren Sie diese Version zuerst. Danach können Sie [ProductName] installieren!</String>
- <String Id="InvalidTargetDir">Ungültiges Installationsverzeichnis angegeben. Bitte ein anderes Installationsverzeichnis wählen, um [ProductName] zu installieren.</String>
+ <String Id="InvalidTargetDir">Ungültiges Installationsverzeichnis angegeben. Bitte ein anderes Installationsverzeichnis wählen, um [ProductName] zu installieren. Für mehr Informationen bitte im [ProductName] Handbuch nachschlagen.</String>
<!---->
@@ -94,7 +94,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Ungültiges Installationsverzeichnis</String>
- <String Id="InvalidTargetDirDlg_Desc1">Das gewählte Installationsverzeichnis is ungültig, da dieses nicht den Sicherheitsrichtlinien entspricht.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">Das gewählte Installationsverzeichnis is ungültig, da dieses nicht den Sicherheitsrichtlinien entspricht. Für mehr Informationen bitte im [ProductName] Handbuch nachschlagen.</String>
<String Id="InvalidTargetDirDlg_Desc2">Bitte ein anderes Installationsverzeichnis wählen um [ProductName] zu installieren.</String>
<!---->
diff --git a/src/VBox/Installer/win/NLS/el_GR.wxl b/src/VBox/Installer/win/NLS/el_GR.wxl
index 071a61e0..fb40cf55 100644
--- a/src/VBox/Installer/win/NLS/el_GR.wxl
+++ b/src/VBox/Installer/win/NLS/el_GR.wxl
@@ -74,7 +74,7 @@
<String Id="Only64Bit">Αυτή η εφαρμογή τρέχει μόνο σε συστήματα Windows 64 bit. Εγκαταστήστε την έκδοση 32-bit του [ProductName]!</String>
<String Id="SunFound">Βρέθηκε μία παλιότερη εγκατάσταση του Sun VirtualBox στον υπολογιστή. Καταργήστε πρώτα την εγκατάσταση αυτού του πακέτου και μετά εγκαταστήστε το [ProductName]!</String>
<String Id="InnotekFound">Βρέθηκε μία παλιότερη εγκατάσταση του innotek VirtualBox στον υπολογιστή. Καταργήστε πρώτα την εγκατάσταση αυτού του πακέτου και μετά εγκαταστήστε το [ProductName]!</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
@@ -95,7 +95,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
diff --git a/src/VBox/Installer/win/NLS/en_US.wxl b/src/VBox/Installer/win/NLS/en_US.wxl
index 3eac3530..532e6067 100644
--- a/src/VBox/Installer/win/NLS/en_US.wxl
+++ b/src/VBox/Installer/win/NLS/en_US.wxl
@@ -74,7 +74,7 @@
<String Id="Only64Bit">This application only runs on 64-bit Windows systems. Please install the 32-bit version of [ProductName]!</String>
<String Id="SunFound">An old Sun VirtualBox installation has been found on this machine. Please uninstall this package first and then install [ProductName]!</String>
<String Id="InnotekFound">An old innotek VirtualBox installation has been found on this machine. Please uninstall this package first and then install [ProductName]!</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
@@ -95,7 +95,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
diff --git a/src/VBox/Installer/win/NLS/fa_IR.wxl b/src/VBox/Installer/win/NLS/fa_IR.wxl
index 1eeedf8a..21e65775 100644
--- a/src/VBox/Installer/win/NLS/fa_IR.wxl
+++ b/src/VBox/Installer/win/NLS/fa_IR.wxl
@@ -67,7 +67,7 @@
<String Id="Only64Bit">این برنامه فقط روی ویندوز 64 بیتی اِجرا میشود. لطفا نسخه 32 بیتی [ProductName] را نصب کنید!</String>
<String Id="SunFound">یک نصب قدیمی ویرچوال باکس روی این رایانه یافت شد. لطفا اول این بسته را حذف سپس [ProductName] را نصب کنید!</String>
<String Id="InnotekFound">یک نسخه قدیمی نصب ویرچوال باکس در این ماشین یافت شد. لطفا اول این بسته را حذف و سپس [ProductName] را نصب کنید!</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
<String Id="CancelDlg_Question">آیا میخواهید نصب [ProductName] را لغو کنید؟</String>
<!---->
@@ -80,7 +80,7 @@
<String Id="LicenseAgreementDlg_Decline">&amp;من ضوابط را در توافقنامه مجوز نمی پذیرم</String>
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
<String Id="CheckSerialDlg_Header">شماره سریال</String>
diff --git a/src/VBox/Installer/win/NLS/fr_FR.wxl b/src/VBox/Installer/win/NLS/fr_FR.wxl
index 2624925b..efdeb242 100644
--- a/src/VBox/Installer/win/NLS/fr_FR.wxl
+++ b/src/VBox/Installer/win/NLS/fr_FR.wxl
@@ -73,7 +73,7 @@
<String Id="Only32Bit">Cette application ne marche que sur des systèmes Windows 32-bit. Veuillez installer la version 64-bit de [ProductName]!</String>
<String Id="Only64Bit">Cette application ne marche que sur des systèmes Windows 64-bit. Veuillez installer la version 32-bit de [ProductName]!</String>
<String Id="InnotekFound">Vous avez une ancienne installation de innotek VirtualBox sur cette machine. Il vous faudra la désinstaller avant de pouvoir installer [ProductName].</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
@@ -94,7 +94,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
diff --git a/src/VBox/Installer/win/NLS/it_IT.wxl b/src/VBox/Installer/win/NLS/it_IT.wxl
index ef0b25d5..47754d9a 100644
--- a/src/VBox/Installer/win/NLS/it_IT.wxl
+++ b/src/VBox/Installer/win/NLS/it_IT.wxl
@@ -67,7 +67,7 @@
<String Id="Only64Bit">Questa applicazione può essere eseguita solo su sistemi Windows a 64 bit. Installa la versione a 32 bit di [ProductName]!</String>
<String Id="SunFound">Una vecchia installazione di Sun VirtualBox è stata trovata su questa macchina. Disinstalla prima questo pacchetto e poi installa [ProductName]!</String>
<String Id="InnotekFound">Una vecchia installazione di innotek VirtualBox è stata trovata su questa macchina. Disinstalla prima questo pacchetto e poi installa [ProductName]!</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
<String Id="CancelDlg_Question">Sei sicuro di voler annullare l'installazione di [ProductName]?</String>
<!---->
@@ -80,7 +80,7 @@
<String Id="LicenseAgreementDlg_Decline">&amp;Non accetto i termini dell'accordo di licenza</String>
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
<String Id="CheckSerialDlg_Header">Numero di serie</String>
diff --git a/src/VBox/Installer/win/NLS/ru_RU.wxl b/src/VBox/Installer/win/NLS/ru_RU.wxl
index 3eac3530..532e6067 100644
--- a/src/VBox/Installer/win/NLS/ru_RU.wxl
+++ b/src/VBox/Installer/win/NLS/ru_RU.wxl
@@ -74,7 +74,7 @@
<String Id="Only64Bit">This application only runs on 64-bit Windows systems. Please install the 32-bit version of [ProductName]!</String>
<String Id="SunFound">An old Sun VirtualBox installation has been found on this machine. Please uninstall this package first and then install [ProductName]!</String>
<String Id="InnotekFound">An old innotek VirtualBox installation has been found on this machine. Please uninstall this package first and then install [ProductName]!</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
@@ -95,7 +95,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
diff --git a/src/VBox/Installer/win/NLS/tr_TR.wxl b/src/VBox/Installer/win/NLS/tr_TR.wxl
index ff7a3b89..185199f3 100644
--- a/src/VBox/Installer/win/NLS/tr_TR.wxl
+++ b/src/VBox/Installer/win/NLS/tr_TR.wxl
@@ -74,7 +74,7 @@
<String Id="Only64Bit">Bu uygulama yalnızca 64-bit Windows sistemlerinde çalışır. Lütfen [ProductName] 32-bit sürümünü yükleyin!</String>
<String Id="SunFound">Bu makinede eski bir Sun VirtualBox kurulumu bulundu. Lütfen önce bu paketi kaldırın ve sonra [ProductName] yükleyin!</String>
<String Id="InnotekFound">Bu makinede eski bir innotek VirtualBox kurulumu bulundu. Lütfen önce bu paketi kaldırın ve sonra [ProductName] yükleyin!</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
@@ -95,7 +95,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
diff --git a/src/VBox/Installer/win/NLS/zh_CN.wxl b/src/VBox/Installer/win/NLS/zh_CN.wxl
index 2d57834a..c4b157d2 100644
--- a/src/VBox/Installer/win/NLS/zh_CN.wxl
+++ b/src/VBox/Installer/win/NLS/zh_CN.wxl
@@ -74,7 +74,7 @@
<String Id="Only64Bit">此应用程序只能运行在 64 位 Windows 系统。 请安装 [ProductName] 的 32 位版本!</String>
<String Id="SunFound">在此计算机发现旧的 Sun VirtualBox 安装。 请先卸载此组件然后安装 [ProductName]!</String>
<String Id="InnotekFound">在此计算机发现旧的 innotek VirtualBox 安装。 请先卸载此组件然后安装 [ProductName]!</String>
-<String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+<String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
@@ -95,7 +95,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
-<String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+<String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
diff --git a/src/VBox/Installer/win/NLS/zh_TW.wxl b/src/VBox/Installer/win/NLS/zh_TW.wxl
index c30e8113..952e1ebe 100644
--- a/src/VBox/Installer/win/NLS/zh_TW.wxl
+++ b/src/VBox/Installer/win/NLS/zh_TW.wxl
@@ -74,7 +74,7 @@
<String Id="Only64Bit">此應用程式只能執行在 64 位元的 Windows 系統。 請安裝 [ProductName] 的 32 位元版本!</String>
<String Id="SunFound">在此電腦發現舊的 Sun VirtualBox 安裝。 請先解除安裝此套件然後安裝 [ProductName]!</String>
<String Id="InnotekFound">在此電腦發現舊的 innotek VirtualBox 安裝。 請先解除安裝此套件然後安裝 [ProductName]!</String>
- <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName].</String>
+ <String Id="InvalidTargetDir">Invalid installation directory specified! Please use another installation directory to install [ProductName]. Refer to the [ProductName] manual for more information.</String>
<!---->
@@ -95,7 +95,7 @@
<!---->
<String Id="InvalidTargetDirDlg_Header">Invalid installation directory</String>
- <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements.</String>
+ <String Id="InvalidTargetDirDlg_Desc1">The chosen installation directory is invalid, as it does not meet the security requirements. Refer to the [ProductName] manual for more information.</String>
<String Id="InvalidTargetDirDlg_Desc2">Please choose another directory for installing [ProductName].</String>
<!---->
diff --git a/src/VBox/Installer/win/Stub/Makefile.kmk b/src/VBox/Installer/win/Stub/Makefile.kmk
index 1bf99706..13c21c67 100644
--- a/src/VBox/Installer/win/Stub/Makefile.kmk
+++ b/src/VBox/Installer/win/Stub/Makefile.kmk
@@ -88,7 +88,7 @@ ifdef VBOX_SIGNING_MODE
$(VBOX_BIN2C) -ascii --append VBoxStubTrustedCert1 "$@.cer1" $@
$(APPEND) "$@.array" " { g_abVBoxStubTrustedCert1, sizeof(g_abVBoxStubTrustedCert1) }, "
endif
- if $(intersects win_planb,$(VBOX_WITH_CORP_CODE_SIGNING))
+ if !$(intersects win,$(VBOX_WITH_CORP_CODE_SIGNING)) && $(intersects win_planb,$(VBOX_WITH_CORP_CODE_SIGNING))
$(VBOX_RTSIGNTOOL) extract-exe-signer-cert --signature-index 1 --exe "$(VBOX_RTSIGNTOOL)" --output "$@.cer2" --der
$(VBOX_BIN2C) -ascii --append VBoxStubTrustedCert2 "$@.cer2" $@
$(APPEND) "$@.array" " { g_abVBoxStubTrustedCert2, sizeof(g_abVBoxStubTrustedCert2) }, "
diff --git a/src/VBox/Installer/win/UserInterface.wxi b/src/VBox/Installer/win/UserInterface.wxi
index c3bbab13..b8fff529 100644
--- a/src/VBox/Installer/win/UserInterface.wxi
+++ b/src/VBox/Installer/win/UserInterface.wxi
@@ -222,7 +222,7 @@
<Text>!(loc.InvalidTargetDirDlg_Desc1)</Text>
</Control>
- <Control Id="Description2" Type="Text" X="135" Y="95" Width="220" Height="130" Transparent="yes" NoPrefix="yes">
+ <Control Id="Description2" Type="Text" X="135" Y="105" Width="220" Height="130" Transparent="yes" NoPrefix="yes">
<Text>!(loc.InvalidTargetDirDlg_Desc2)</Text>
</Control>
@@ -364,7 +364,6 @@
<Control Id="Text" Type="Text" X="25" Y="70" Width="320" Height="20">
<Text>!(loc.Customize2Dlg_Desc)</Text>
</Control>
-<?if $(env.VBOX_WITH_QTGUI) = "yes" ?>
<!-- Note the gray background behind the checkboxes. Unfortunately there's no easy way to
fix this, without fixing it in the WiX source code. Because the control's background
uses the default dialog background color, changing the background image for the dialog to
@@ -388,7 +387,7 @@
Property="VBOX_REGISTERFILEEXTENSIONS" CheckBoxValue="1" Default="no">
<Text>!(loc.Customize2Dlg_RegisterFileExtensions)</Text>
</Control>
-<?endif?> <!-- VBOX_WITH_QTGUI -->
+
<Control Id="Next" Type="PushButton" X="236" Y="243" Width="56" Height="17" Default="yes" Text="!(loc.ButtonText_Next)" />
<Control Id="Back" Type="PushButton" X="180" Y="243" Width="56" Height="17" Text="!(loc.ButtonText_Back)" />
@@ -1169,11 +1168,11 @@
<!-- Property which defines whether the installer checks the serial number or not. -->
<Property Id="VBOX_SHOW_SERIAL_CHECK_DLG">1</Property>
<?endif?>
-<?if $(env.VBOX_WITH_QTGUI) = "no" ?>
+<?if $(env.VBOX_WITH_QTGUI) = "yes" ?>
<!-- Property which defines whether to show the second customization dialog. This second customization
dialog only is needed for GUI-based options, so skip if we either don't ship FE/Qt or don't show
the (first) customization dialog. -->
- <Property Id="VBOX_SHOW_CUSTOMIZE2_DLG"><![CDATA[VBOX_SHOW_CUSTOMIZE_DLG]]></Property>
+ <Property Id="VBOX_SHOW_CUSTOMIZE2_DLG">1</Property>
<?endif?>
diff --git a/src/VBox/Installer/win/VirtualBox.wxs b/src/VBox/Installer/win/VirtualBox.wxs
index beccd815..f9d2f95d 100644
--- a/src/VBox/Installer/win/VirtualBox.wxs
+++ b/src/VBox/Installer/win/VirtualBox.wxs
@@ -277,8 +277,8 @@
<CustomAction Id="ca_UninstallBranding" BinaryKey="VBoxInstallHelper" DllEntry="UninstallBranding" Execute="deferred" Return="check" Impersonate="no"/>
<CustomAction Id="ca_UninstallBrandingArgs" Property="ca_UninstallBranding" Value="[INSTALLDIR]" Execute="immediate"/>
-<?if $(env.VBOX_WITH_MSM_INSTALL) = "no" ?>
<?include VBoxMergeAppCA.wxi ?>
+<?if $(env.VBOX_WITH_MSM_INSTALL) = "no" ?>
<?if $(env.VBOX_WITH_32_ON_64_MAIN_API) = "yes" ?>
<?include VBoxMergeCOM32On64CA.wxi ?>
<?endif ?>