summaryrefslogtreecommitdiffstats
path: root/src/VBox/RDP
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/RDP')
-rw-r--r--src/VBox/RDP/.scm-settings48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/VBox/RDP/.scm-settings b/src/VBox/RDP/.scm-settings
new file mode 100644
index 00000000..27d197d9
--- /dev/null
+++ b/src/VBox/RDP/.scm-settings
@@ -0,0 +1,48 @@
+# $Id: .scm-settings $
+## @file
+# Source code massager settings for RDP.
+#
+
+#
+# Copyright (C) 2010-2023 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+--filter-out-dirs /client-*/keymaps/.
+--filter-out-dirs /client-*/doc/.
+
+--filter-out-files /client-*/bootstrap
+--filter-out-files /client-*/config.*
+--filter-out-files /client-*/configure.ac
+--filter-out-files /client-*/install-sh
+--filter-out-files /client-*/Makefile.in
+--filter-out-files /client-*/proto.head
+--filter-out-files /client-*/proto.tail
+--filter-out-files /client-*/rdesktop.spec
+--filter-out-files /client-*/README
+
+/client-*/*.c: --external-copyright --lgpl-disclaimer --no-convert-tabs --no-fix-todos --no-strip-trailing-blanks
+/client-*/*.h: --external-copyright --lgpl-disclaimer --no-convert-tabs --no-fix-todos --no-strip-trailing-blanks --no-fix-header-guards
+/client-*/configure: --external-copyright --lgpl-disclaimer --no-convert-tabs --no-fix-todos --no-strip-trailing-blanks
+/client-*/vrdp/*: --no-external-copyright --no-lgpl-disclaimer --fix-todos --strip-trailing-blanks
+
+/server/mixeng/*_template.h: --no-fix-header-guards
+/server/*.h: --guard-relative-to-dir server --guard-prefix VRDP_INCLUDED_SRC_
+