summaryrefslogtreecommitdiffstats
path: root/src/libs/dxvk-native-1.9.2a/src/wsi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/dxvk-native-1.9.2a/src/wsi/meson.build')
-rw-r--r--src/libs/dxvk-native-1.9.2a/src/wsi/meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/libs/dxvk-native-1.9.2a/src/wsi/meson.build b/src/libs/dxvk-native-1.9.2a/src/wsi/meson.build
new file mode 100644
index 00000000..6ab147be
--- /dev/null
+++ b/src/libs/dxvk-native-1.9.2a/src/wsi/meson.build
@@ -0,0 +1,32 @@
+wsi_win32_src = [
+ 'win32/wsi_mode_win32.cpp',
+ 'win32/wsi_monitor_win32.cpp',
+ 'win32/wsi_presenter_win32.cpp',
+ 'win32/wsi_window_win32.cpp',
+]
+
+wsi_sdl2_src = [
+ 'sdl2/wsi_mode_sdl2.cpp',
+ 'sdl2/wsi_monitor_sdl2.cpp',
+ 'sdl2/wsi_presenter_sdl2.cpp',
+ 'sdl2/wsi_window_sdl2.cpp',
+]
+
+if dxvk_wsi == 'win32'
+ wsi_src = wsi_win32_src
+ wsi_deps = []
+elif dxvk_wsi == 'sdl2'
+ wsi_src = wsi_sdl2_src
+ wsi_deps = [ lib_sdl2 ]
+else
+ error('Unknown wsi')
+endif
+
+wsi_lib = static_library('wsi', wsi_src,
+ dependencies : wsi_deps,
+ override_options : ['cpp_std='+dxvk_cpp_std],
+ include_directories : [ dxvk_include_path ])
+
+wsi_dep = declare_dependency(
+ link_with : [ wsi_lib ],
+ include_directories : [ dxvk_include_path ])