summaryrefslogtreecommitdiffstats
path: root/src/libs/dxvk-native-1.9.2a/tests/dxbc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/dxvk-native-1.9.2a/tests/dxbc/meson.build')
-rw-r--r--src/libs/dxvk-native-1.9.2a/tests/dxbc/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/libs/dxvk-native-1.9.2a/tests/dxbc/meson.build b/src/libs/dxvk-native-1.9.2a/tests/dxbc/meson.build
new file mode 100644
index 00000000..3bd0912a
--- /dev/null
+++ b/src/libs/dxvk-native-1.9.2a/tests/dxbc/meson.build
@@ -0,0 +1,6 @@
+test_dxbc_deps = [ dxbc_dep, dxvk_dep ]
+
+executable('dxbc-compiler'+exe_ext, files('test_dxbc_compiler.cpp'), dependencies : test_dxbc_deps, install : true, gui_app : true, override_options: ['cpp_std='+dxvk_cpp_std])
+executable('dxbc-disasm'+exe_ext, files('test_dxbc_disasm.cpp'), dependencies : [ test_dxbc_deps, lib_d3dcompiler_47 ], install : true, gui_app : true, override_options: ['cpp_std='+dxvk_cpp_std])
+executable('hlsl-compiler'+exe_ext, files('test_hlsl_compiler.cpp'), dependencies : [ test_dxbc_deps, lib_d3dcompiler_47 ], install : true, gui_app : true, override_options: ['cpp_std='+dxvk_cpp_std])
+