summaryrefslogtreecommitdiffstats
path: root/src/libs/xpcom18a4/xpcom/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/libs/xpcom18a4/xpcom/Makefile.in84
1 files changed, 84 insertions, 0 deletions
diff --git a/src/libs/xpcom18a4/xpcom/Makefile.in b/src/libs/xpcom18a4/xpcom/Makefile.in
new file mode 100644
index 00000000..8bfe9abe
--- /dev/null
+++ b/src/libs/xpcom18a4/xpcom/Makefile.in
@@ -0,0 +1,84 @@
+#
+# ***** BEGIN LICENSE BLOCK *****
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
+#
+# The contents of this file are subject to the Mozilla Public License Version
+# 1.1 (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+# http://www.mozilla.org/MPL/
+#
+# Software distributed under the License is distributed on an "AS IS" basis,
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
+# for the specific language governing rights and limitations under the
+# License.
+#
+# The Original Code is mozilla.org code.
+#
+# The Initial Developer of the Original Code is
+# Netscape Communications Corporation.
+# Portions created by the Initial Developer are Copyright (C) 1998
+# the Initial Developer. All Rights Reserved.
+#
+# Contributor(s):
+#
+# Alternatively, the contents of this file may be used under the terms of
+# either of the GNU General Public License Version 2 or later (the "GPL"),
+# or the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
+# in which case the provisions of the GPL or the LGPL are applicable instead
+# of those above. If you wish to allow use of your version of this file only
+# under the terms of either the GPL or the LGPL, and not to allow others to
+# use your version of this file under the terms of the MPL, indicate your
+# decision by deleting the provisions above and replace them with the notice
+# and other provisions required by the GPL or the LGPL. If you do not delete
+# the provisions above, a recipient may use your version of this file under
+# the terms of any one of the MPL, the GPL or the LGPL.
+#
+# ***** END LICENSE BLOCK *****
+
+DEPTH = ..
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+include $(DEPTH)/config/autoconf.mk
+
+MODULE = xpcom
+GRE_MODULE = 1
+
+DIRS = \
+ MoreFiles \
+ typelib \
+ string \
+ glue \
+ base \
+ ds \
+ io \
+ components \
+ threads \
+ reflect \
+ proxy \
+ build \
+ tools \
+ $(NULL)
+
+ifeq ($(OS_ARCH),WINNT)
+ifdef MOZ_DEBUG
+DIRS += windbgdlg
+endif
+endif
+
+ifdef ENABLE_TESTS
+DIRS += \
+ tests \
+ sample \
+ typelib/xpt/tests \
+ reflect/xptinfo/tests \
+ reflect/xptcall/tests \
+ proxy/tests
+endif
+
+# xpcom-config.h is generated by configure
+SDK_HEADERS = xpcom-config.h
+
+include $(topsrcdir)/config/rules.mk
+