summaryrefslogtreecommitdiffstats
path: root/src/libs/xpcom18a4/xpcom/base/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/xpcom18a4/xpcom/base/Makefile.in')
-rw-r--r--src/libs/xpcom18a4/xpcom/base/Makefile.in133
1 files changed, 133 insertions, 0 deletions
diff --git a/src/libs/xpcom18a4/xpcom/base/Makefile.in b/src/libs/xpcom18a4/xpcom/base/Makefile.in
new file mode 100644
index 00000000..a897bca8
--- /dev/null
+++ b/src/libs/xpcom18a4/xpcom/base/Makefile.in
@@ -0,0 +1,133 @@
+#
+# ***** BEGIN LICENSE BLOCK *****
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
+#
+# The contents of this file are subject to the Mozilla Public License Version
+# 1.1 (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+# http://www.mozilla.org/MPL/
+#
+# Software distributed under the License is distributed on an "AS IS" basis,
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
+# for the specific language governing rights and limitations under the
+# License.
+#
+# The Original Code is mozilla.org code.
+#
+# The Initial Developer of the Original Code is
+# Netscape Communications Corporation.
+# Portions created by the Initial Developer are Copyright (C) 1998
+# the Initial Developer. All Rights Reserved.
+#
+# Contributor(s):
+#
+# Alternatively, the contents of this file may be used under the terms of
+# either of the GNU General Public License Version 2 or later (the "GPL"),
+# or the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
+# in which case the provisions of the GPL or the LGPL are applicable instead
+# of those above. If you wish to allow use of your version of this file only
+# under the terms of either the GPL or the LGPL, and not to allow others to
+# use your version of this file under the terms of the MPL, indicate your
+# decision by deleting the provisions above and replace them with the notice
+# and other provisions required by the GPL or the LGPL. If you do not delete
+# the provisions above, a recipient may use your version of this file under
+# the terms of any one of the MPL, the GPL or the LGPL.
+#
+# ***** END LICENSE BLOCK *****
+
+DEPTH = ../..
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+include $(DEPTH)/config/autoconf.mk
+
+MODULE = xpcom
+XPIDL_MODULE = xpcom_base
+LIBRARY_NAME = xpcombase_s
+GRE_MODULE = 1
+
+REQUIRES = string \
+ $(NULL)
+
+CPPSRCS = \
+ nsAllocator.cpp \
+ nsConsoleMessage.cpp \
+ nsConsoleService.cpp \
+ nsDebugImpl.cpp \
+ nsErrorService.cpp \
+ nsExceptionService.cpp \
+ nsID.cpp \
+ nsMemoryImpl.cpp \
+ nsTraceRefcntImpl.cpp \
+ $(NULL)
+
+ifdef GC_LEAK_DETECTOR
+CSRCS += nsGarbageCollector.c
+CPPSRCS += nsLeakDetector.cpp
+REQUIRES += boehm
+endif
+
+EXPORTS = \
+ nsAgg.h \
+ nsAutoPtr.h \
+ nsCom.h \
+ nsDebugImpl.h \
+ nsIAllocator.h \
+ nsIID.h \
+ nsISupportsObsolete.h \
+ nsTraceRefcntImpl.h \
+ nsWeakPtr.h \
+ $(NULL)
+
+ifeq ($(OS_ARCH),WINNT)
+ifdef MOZ_DEBUG
+CSRCS += pure_api.c
+EXPORTS += pure.h
+endif
+CPPSRCS += nsStackFrameWin.cpp
+endif
+
+ifneq ($(OS_ARCH),WINNT)
+CPPSRCS += nsStackFrameUnix.cpp
+endif
+
+SDK_XPIDLSRCS = \
+ nsIDebug.idl \
+ nsIInterfaceRequestor.idl \
+ nsIMemory.idl \
+ nsIProgrammingLanguage.idl \
+ nsISupports.idl \
+ nsITraceRefcnt.idl \
+ nsIWeakReference.idl \
+ nsrootidl.idl \
+
+SDK_HEADERS = \
+ nsError.h \
+ nsID.h \
+ nsISupportsBase.h \
+ nscore.h \
+
+XPIDLSRCS = \
+ nsIConsoleListener.idl \
+ nsIConsoleMessage.idl \
+ nsIConsoleService.idl \
+ nsIErrorService.idl \
+ nsIException.idl \
+ nsIExceptionService.idl \
+ $(NULL)
+
+ifdef GC_LEAK_DETECTOR
+XPIDLSRCS += nsILeakDetector.idl
+endif
+
+# we don't want the shared lib, but we want to force the creation of a static lib.
+FORCE_STATIC_LIB = 1
+
+# Force use of PIC
+FORCE_USE_PIC = 1
+
+include $(topsrcdir)/config/rules.mk
+
+DEFINES += -D_IMPL_NS_COM
+