summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:23:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:23:18 +0000
commit3adae17e76163052e87e71ebf469607602d530bd (patch)
tree386985cf81519f72f115837bd2cedfb99440e3be /debian/patches
parentMerging upstream version 0.0~git20230113.4362b18. (diff)
downloadwasi-libc-3adae17e76163052e87e71ebf469607602d530bd.tar.xz
wasi-libc-3adae17e76163052e87e71ebf469607602d530bd.zip
Adding debian version 0.0~git20230113.4362b18-1.debian/0.0_git20230113.4362b18-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian-flags.patch37
-rw-r--r--debian/patches/disable-warning.patch12
-rw-r--r--debian/patches/dont-rebuild-install.patch20
3 files changed, 53 insertions, 16 deletions
diff --git a/debian/patches/debian-flags.patch b/debian/patches/debian-flags.patch
index 3c8ef0b..d9ca6f8 100644
--- a/debian/patches/debian-flags.patch
+++ b/debian/patches/debian-flags.patch
@@ -1,5 +1,12 @@
---- a/expected/wasm32-wasi/posix/predefined-macros.txt
-+++ b/expected/wasm32-wasi/posix/predefined-macros.txt
+Author: Ximin Luo <infinity0@debian.org>
+Description: patch aligning expected definitions to Debian
+peculiarities/toolchain versions.
+Forwarded: not-needed
+
+Index: wasi-libc/expected/wasm32-wasi-threads/predefined-macros.txt
+===================================================================
+--- wasi-libc.orig/expected/wasm32-wasi-threads/predefined-macros.txt
++++ wasi-libc/expected/wasm32-wasi-threads/predefined-macros.txt
@@ -1119,7 +1119,6 @@
#define NAN (0.0f/0.0f)
#define NBBY 8
@@ -8,7 +15,15 @@
#define ND_NA_FLAG_OVERRIDE 0x00000020
#define ND_NA_FLAG_ROUTER 0x00000080
#define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -3113,7 +3112,7 @@
+@@ -2728,6 +2727,7 @@
+ #define __SIZE_MAX__ 4294967295UL
+ #define __SIZE_TYPE__ long unsigned int
+ #define __SIZE_WIDTH__ 32
++#define __SSP_STRONG__ 2
+ #define __STDARG_H
+ #define __STDC_HOSTED__ 1
+ #define __STDC_IEC_559__ 1
+@@ -3112,7 +3112,7 @@
#define and_eq &=
#define asin(x) __tg_real_complex(asin, (x))
#define asinh(x) __tg_real_complex(asinh, (x))
@@ -17,8 +32,10 @@
#define atan(x) __tg_real_complex(atan, (x))
#define atan2(x,y) __tg_real_2(atan2, (x), (y))
#define atanh(x) __tg_real_complex(atanh, (x))
---- a/expected/wasm32-wasi/single/predefined-macros.txt
-+++ b/expected/wasm32-wasi/single/predefined-macros.txt
+Index: wasi-libc/expected/wasm32-wasi/predefined-macros.txt
+===================================================================
+--- wasi-libc.orig/expected/wasm32-wasi/predefined-macros.txt
++++ wasi-libc/expected/wasm32-wasi/predefined-macros.txt
@@ -1119,7 +1119,6 @@
#define NAN (0.0f/0.0f)
#define NBBY 8
@@ -27,7 +44,15 @@
#define ND_NA_FLAG_OVERRIDE 0x00000020
#define ND_NA_FLAG_ROUTER 0x00000080
#define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -3073,7 +3072,7 @@
+@@ -2691,6 +2690,7 @@
+ #define __SIZE_MAX__ 4294967295UL
+ #define __SIZE_TYPE__ long unsigned int
+ #define __SIZE_WIDTH__ 32
++#define __SSP_STRONG__ 2
+ #define __STDARG_H
+ #define __STDC_HOSTED__ 1
+ #define __STDC_IEC_559__ 1
+@@ -3073,7 +3073,7 @@
#define and_eq &=
#define asin(x) __tg_real_complex(asin, (x))
#define asinh(x) __tg_real_complex(asinh, (x))
diff --git a/debian/patches/disable-warning.patch b/debian/patches/disable-warning.patch
index 46098d4..c6256b5 100644
--- a/debian/patches/disable-warning.patch
+++ b/debian/patches/disable-warning.patch
@@ -1,6 +1,12 @@
---- a/Makefile
-+++ b/Makefile
-@@ -294,6 +294,7 @@
+Author: Fabian Grünbichler <debian@fabian.gruenbichler.email>
+Description: disable on-by-default linker warning
+Forwarded: not-needed
+
+Index: wasi-libc/Makefile
+===================================================================
+--- wasi-libc.orig/Makefile
++++ wasi-libc/Makefile
+@@ -310,6 +310,7 @@ CFLAGS += -Wall -Wextra -Werror \
-Wno-missing-braces \
-Wno-ignored-pragmas \
-Wno-unused-but-set-variable \
diff --git a/debian/patches/dont-rebuild-install.patch b/debian/patches/dont-rebuild-install.patch
index a72b006..a9cf7f7 100644
--- a/debian/patches/dont-rebuild-install.patch
+++ b/debian/patches/dont-rebuild-install.patch
@@ -1,6 +1,12 @@
---- a/Makefile
-+++ b/Makefile
-@@ -556,6 +556,8 @@
+Author: Ximin Luo <infinity0@debian.org>
+Description: Prevent spurious rebuilds
+Forwarded: not-needed
+
+Index: wasi-libc/Makefile
+===================================================================
+--- wasi-libc.orig/Makefile
++++ wasi-libc/Makefile
+@@ -577,6 +577,8 @@ include_dirs:
# Remove selected header files.
$(RM) $(patsubst %,$(SYSROOT_INC)/%,$(MUSL_OMIT_HEADERS))
@@ -9,7 +15,7 @@
startup_files: include_dirs
#
# Build the startup files.
-@@ -566,6 +568,8 @@
+@@ -587,6 +589,8 @@ startup_files: include_dirs
mkdir -p "$(SYSROOT_LIB)" && \
mv *.o "$(SYSROOT_LIB)"
@@ -18,7 +24,7 @@
libc: include_dirs \
$(SYSROOT_LIB)/libc.a \
$(SYSROOT_LIB)/libc-printscan-long-double.a \
-@@ -575,6 +579,8 @@
+@@ -596,6 +600,8 @@ libc: include_dirs \
$(SYSROOT_LIB)/libwasi-emulated-getpid.a \
$(SYSROOT_LIB)/libwasi-emulated-signal.a
@@ -27,7 +33,7 @@
finish: startup_files libc
#
# Create empty placeholder libraries.
-@@ -586,6 +592,7 @@
+@@ -607,6 +613,7 @@ finish: startup_files libc
#
# The build succeeded! The generated sysroot is in $(SYSROOT).
#
@@ -35,7 +41,7 @@
# The check for defined and undefined symbols expects there to be a heap
# alloctor (providing malloc, calloc, free, etc). Skip this step if the build
-@@ -687,5 +694,6 @@
+@@ -712,5 +719,6 @@ install: finish
clean:
$(RM) -r "$(OBJDIR)"
$(RM) -r "$(SYSROOT)"