summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 13:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 13:54:39 +0000
commit7f4e44f9469d8dcf6f95e07d0f5bb340f8830bfb (patch)
tree07741545f80a7f29822eb571d02db8dd0349674f /debian/patches
parentAdding upstream version 0.0~git20221206.8b7148f. (diff)
downloadwasi-libc-7f4e44f9469d8dcf6f95e07d0f5bb340f8830bfb.tar.xz
wasi-libc-7f4e44f9469d8dcf6f95e07d0f5bb340f8830bfb.zip
Adding debian version 0.0~git20221206.8b7148f-1.debian/0.0_git20221206.8b7148f-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian-flags.patch38
-rw-r--r--debian/patches/disable-warning.patch10
-rw-r--r--debian/patches/dont-rebuild-install.patch44
-rw-r--r--debian/patches/series3
4 files changed, 95 insertions, 0 deletions
diff --git a/debian/patches/debian-flags.patch b/debian/patches/debian-flags.patch
new file mode 100644
index 0000000..3c8ef0b
--- /dev/null
+++ b/debian/patches/debian-flags.patch
@@ -0,0 +1,38 @@
+--- a/expected/wasm32-wasi/posix/predefined-macros.txt
++++ b/expected/wasm32-wasi/posix/predefined-macros.txt
+@@ -1119,7 +1119,6 @@
+ #define NAN (0.0f/0.0f)
+ #define NBBY 8
+ #define NCARGS 131072
+-#define NDEBUG 1
+ #define ND_NA_FLAG_OVERRIDE 0x00000020
+ #define ND_NA_FLAG_ROUTER 0x00000080
+ #define ND_NA_FLAG_SOLICITED 0x00000040
+@@ -3113,7 +3112,7 @@
+ #define and_eq &=
+ #define asin(x) __tg_real_complex(asin, (x))
+ #define asinh(x) __tg_real_complex(asinh, (x))
+-#define assert(x) (void)0
++#define assert(x) ((void)((x) || (__assert_fail(#x, __FILE__, __LINE__, __func__),0)))
+ #define atan(x) __tg_real_complex(atan, (x))
+ #define atan2(x,y) __tg_real_2(atan2, (x), (y))
+ #define atanh(x) __tg_real_complex(atanh, (x))
+--- a/expected/wasm32-wasi/single/predefined-macros.txt
++++ b/expected/wasm32-wasi/single/predefined-macros.txt
+@@ -1119,7 +1119,6 @@
+ #define NAN (0.0f/0.0f)
+ #define NBBY 8
+ #define NCARGS 131072
+-#define NDEBUG 1
+ #define ND_NA_FLAG_OVERRIDE 0x00000020
+ #define ND_NA_FLAG_ROUTER 0x00000080
+ #define ND_NA_FLAG_SOLICITED 0x00000040
+@@ -3073,7 +3072,7 @@
+ #define and_eq &=
+ #define asin(x) __tg_real_complex(asin, (x))
+ #define asinh(x) __tg_real_complex(asinh, (x))
+-#define assert(x) (void)0
++#define assert(x) ((void)((x) || (__assert_fail(#x, __FILE__, __LINE__, __func__),0)))
+ #define atan(x) __tg_real_complex(atan, (x))
+ #define atan2(x,y) __tg_real_2(atan2, (x), (y))
+ #define atanh(x) __tg_real_complex(atanh, (x))
diff --git a/debian/patches/disable-warning.patch b/debian/patches/disable-warning.patch
new file mode 100644
index 0000000..46098d4
--- /dev/null
+++ b/debian/patches/disable-warning.patch
@@ -0,0 +1,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -294,6 +294,7 @@
+ -Wno-missing-braces \
+ -Wno-ignored-pragmas \
+ -Wno-unused-but-set-variable \
++ -Wno-unused-command-line-argument \
+ -Wno-unknown-warning-option
+
+ # Configure support for threads.
diff --git a/debian/patches/dont-rebuild-install.patch b/debian/patches/dont-rebuild-install.patch
new file mode 100644
index 0000000..a72b006
--- /dev/null
+++ b/debian/patches/dont-rebuild-install.patch
@@ -0,0 +1,44 @@
+--- a/Makefile
++++ b/Makefile
+@@ -556,6 +556,8 @@
+ # Remove selected header files.
+ $(RM) $(patsubst %,$(SYSROOT_INC)/%,$(MUSL_OMIT_HEADERS))
+
++ touch $@
++
+ startup_files: include_dirs
+ #
+ # Build the startup files.
+@@ -566,6 +568,8 @@
+ mkdir -p "$(SYSROOT_LIB)" && \
+ mv *.o "$(SYSROOT_LIB)"
+
++ touch $@
++
+ libc: include_dirs \
+ $(SYSROOT_LIB)/libc.a \
+ $(SYSROOT_LIB)/libc-printscan-long-double.a \
+@@ -575,6 +579,8 @@
+ $(SYSROOT_LIB)/libwasi-emulated-getpid.a \
+ $(SYSROOT_LIB)/libwasi-emulated-signal.a
+
++ touch $@
++
+ finish: startup_files libc
+ #
+ # Create empty placeholder libraries.
+@@ -586,6 +592,7 @@
+ #
+ # The build succeeded! The generated sysroot is in $(SYSROOT).
+ #
++ touch $@
+
+ # The check for defined and undefined symbols expects there to be a heap
+ # alloctor (providing malloc, calloc, free, etc). Skip this step if the build
+@@ -687,5 +694,6 @@
+ clean:
+ $(RM) -r "$(OBJDIR)"
+ $(RM) -r "$(SYSROOT)"
++ $(RM) -f include_dirs startup_files libc finish
+
+ .PHONY: default startup_files libc finish install include_dirs clean
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..cf9c25b
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+dont-rebuild-install.patch
+debian-flags.patch
+disable-warning.patch