summaryrefslogtreecommitdiffstats
path: root/CMakeListsCustom.txt.example
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
commite4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc (patch)
tree68cb5ef9081156392f1dd62a00c6ccc1451b93df /CMakeListsCustom.txt.example
parentInitial commit. (diff)
downloadwireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.tar.xz
wireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.zip
Adding upstream version 4.2.2.upstream/4.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'CMakeListsCustom.txt.example')
-rw-r--r--CMakeListsCustom.txt.example49
1 files changed, 49 insertions, 0 deletions
diff --git a/CMakeListsCustom.txt.example b/CMakeListsCustom.txt.example
new file mode 100644
index 00000000..1501d8ec
--- /dev/null
+++ b/CMakeListsCustom.txt.example
@@ -0,0 +1,49 @@
+# CMakeListsCustom.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+# Add a list of your custom plugins SRC dir here including the path
+#
+
+# Fail CMake stage if any of these plugins are missing from source tree
+set(CUSTOM_PLUGIN_SRC_DIR
+# private_plugins/foo
+# or
+# plugins/epan/foo
+)
+
+# Do not fail CMake stage if any of the optional plugins are missing from source tree
+set(_OPTIONAL_CUSTOM_PLUGIN_SRC_DIR
+# plugins/epan/bar
+)
+
+# Add your custom TShark taps here
+set(CUSTOM_TSHARK_TAP_SRC
+# ui/cli/tap-baz.c
+)
+
+# This loop handles supporting optional plugins
+foreach( _plugin_dir ${_OPTIONAL_CUSTOM_PLUGIN_SRC_DIR} )
+ if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_plugin_dir}/CMakeLists.txt )
+ list( APPEND CUSTOM_PLUGIN_SRC_DIR ${_plugin_dir} )
+ else()
+ message( WARNING "Custom plugins: No ${_plugin_dir}/CMakeLists.txt file found - ignoring" )
+ endif()
+endforeach()
+
+#
+# Editor modelines - https://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#