summaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/wlancertextn
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
commite4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc (patch)
tree68cb5ef9081156392f1dd62a00c6ccc1451b93df /epan/dissectors/asn1/wlancertextn
parentInitial commit. (diff)
downloadwireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.tar.xz
wireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.zip
Adding upstream version 4.2.2.upstream/4.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'epan/dissectors/asn1/wlancertextn')
-rw-r--r--epan/dissectors/asn1/wlancertextn/CMakeLists.txt35
-rw-r--r--epan/dissectors/asn1/wlancertextn/WLANCERTEXTN.asn93
-rw-r--r--epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.c70
-rw-r--r--epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.h18
-rw-r--r--epan/dissectors/asn1/wlancertextn/wlancertextn.cnf21
5 files changed, 237 insertions, 0 deletions
diff --git a/epan/dissectors/asn1/wlancertextn/CMakeLists.txt b/epan/dissectors/asn1/wlancertextn/CMakeLists.txt
new file mode 100644
index 00000000..133762cf
--- /dev/null
+++ b/epan/dissectors/asn1/wlancertextn/CMakeLists.txt
@@ -0,0 +1,35 @@
+# CMakeLists.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+
+set( PROTOCOL_NAME wlancertextn )
+
+set( PROTO_OPT )
+
+set( EXT_ASN_FILE_LIST
+)
+
+set( ASN_FILE_LIST
+ WLANCERTEXTN.asn
+)
+
+set( EXTRA_DIST
+ ${ASN_FILE_LIST}
+ packet-${PROTOCOL_NAME}-template.c
+ packet-${PROTOCOL_NAME}-template.h
+ ${PROTOCOL_NAME}.cnf
+)
+
+set( SRC_FILES
+ ${EXTRA_DIST}
+ ${EXT_ASN_FILE_LIST}
+)
+
+set( A2W_FLAGS -b )
+
+ASN2WRS()
diff --git a/epan/dissectors/asn1/wlancertextn/WLANCERTEXTN.asn b/epan/dissectors/asn1/wlancertextn/WLANCERTEXTN.asn
new file mode 100644
index 00000000..52bda2c9
--- /dev/null
+++ b/epan/dissectors/asn1/wlancertextn/WLANCERTEXTN.asn
@@ -0,0 +1,93 @@
+-- ASN definitions taken from RFC3770
+-- Copyright notice from RFC3770 follows below
+--
+-- RFC 3770 PPP and WLAN May 2004
+--
+-- 10. Full Copyright Statement
+--
+-- Copyright (C) The Internet Society (2004). This document is subject
+-- to the rights, licenses and restrictions contained in BCP 78, and
+-- except as set forth therein, the authors retain all their rights.
+--
+-- This document and the information contained herein are provided on an
+-- "AS IS" basis and THE CONTRIBUTOR, THE ORGANIZATION HE/SHE REPRESENTS
+-- OR IS SPONSORED BY (IF ANY), THE INTERNET SOCIETY AND THE INTERNET
+-- ENGINEERING TASK FORCE DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED,
+-- INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE
+-- INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED
+-- WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
+--
+-- Intellectual Property
+--
+-- The IETF takes no position regarding the validity or scope of any
+-- Intellectual Property Rights or other rights that might be claimed to
+-- pertain to the implementation or use of the technology described in
+-- this document or the extent to which any license under such rights
+-- might or might not be available; nor does it represent that it has
+-- made any independent effort to identify any such rights. Information
+-- on the procedures with respect to rights in RFC documents can be
+-- found in BCP 78 and BCP 79.
+--
+-- Copies of IPR disclosures made to the IETF Secretariat and any
+-- assurances of licenses to be made available, or the result of an
+-- attempt made to obtain a general license or permission for the use of
+-- such proprietary rights by implementers or users of this
+-- specification can be obtained from the IETF on-line IPR repository at
+-- http://www.ietf.org/ipr.
+--
+-- The IETF invites any interested party to bring to its attention any
+-- copyrights, patents or patent applications, or other proprietary
+-- rights that may cover technology that may be required to implement
+-- this standard. Please address the information to the IETF at ietf-
+-- ipr@ietf.org.
+--
+-- Acknowledgement
+--
+-- Funding for the RFC Editor function is currently provided by the
+-- Internet Society.
+--
+
+
+ WLANCertExtn
+ { iso(1) identified-organization(3) dod(6) internet(1)
+ security(5) mechanisms(5) pkix(7) id-mod(0)
+ id-mod-wlan-extns(24) }
+
+ DEFINITIONS IMPLICIT TAGS ::=
+ BEGIN
+
+ -- OID Arcs
+
+ id-pe OBJECT IDENTIFIER ::=
+ { iso(1) identified-organization(3) dod(6) internet(1)
+ security(5) mechanisms(5) pkix(7) 1 }
+
+ id-kp OBJECT IDENTIFIER ::=
+ { iso(1) identified-organization(3) dod(6) internet(1)
+ security(5) mechanisms(5) pkix(7) 3 }
+
+ id-aca OBJECT IDENTIFIER ::=
+ { iso(1) identified-organization(3) dod(6) internet(1)
+ security(5) mechanisms(5) pkix(7) 10 }
+
+ -- Extended Key Usage Values
+
+ id-kp-eapOverPPP OBJECT IDENTIFIER ::= { id-kp 13 }
+
+ id-kp-eapOverLAN OBJECT IDENTIFIER ::= { id-kp 14 }
+
+
+ -- Wireless LAN SSID Extension
+
+ id-pe-wlanSSID OBJECT IDENTIFIER ::= { id-pe 13 }
+
+ SSIDList ::= SEQUENCE SIZE (1..MAX) OF SSID
+
+ SSID ::= OCTET STRING (SIZE (1..32))
+
+ -- Wireless LAN SSID Attribute Certificate Attribute
+ -- Uses same syntax as the certificate extension: SSIDList
+
+ id-aca-wlanSSID OBJECT IDENTIFIER ::= { id-aca 6 }
+
+ END
diff --git a/epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.c b/epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.c
new file mode 100644
index 00000000..39a0c220
--- /dev/null
+++ b/epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.c
@@ -0,0 +1,70 @@
+/* packet-wlancertextn.c
+ * Routines for Wireless Certificate Extension (RFC3770)
+ * Ronnie Sahlberg 2005
+ *
+ * Wireshark - Network traffic analyzer
+ * By Gerald Combs <gerald@wireshark.org>
+ * Copyright 1998 Gerald Combs
+ *
+ * SPDX-License-Identifier: GPL-2.0-or-later
+ */
+
+#include "config.h"
+
+#include <epan/packet.h>
+#include <epan/oids.h>
+#include <epan/asn1.h>
+
+#include "packet-ber.h"
+#include "packet-wlancertextn.h"
+#include "packet-x509af.h"
+#include "packet-x509ce.h"
+#include "packet-x509sat.h"
+
+#define PNAME "Wlan Certificate Extension"
+#define PSNAME "WLANCERTEXTN"
+#define PFNAME "wlancertextn"
+
+void proto_register_wlancertextn(void);
+void proto_reg_handoff_wlancertextn(void);
+
+/* Initialize the protocol and registered fields */
+static int proto_wlancertextn = -1;
+#include "packet-wlancertextn-hf.c"
+
+/* Initialize the subtree pointers */
+#include "packet-wlancertextn-ett.c"
+
+#include "packet-wlancertextn-fn.c"
+
+
+/*--- proto_register_wlancertextn ----------------------------------------------*/
+void proto_register_wlancertextn(void) {
+
+ /* List of fields */
+ static hf_register_info hf[] = {
+#include "packet-wlancertextn-hfarr.c"
+ };
+
+ /* List of subtrees */
+ static gint *ett[] = {
+#include "packet-wlancertextn-ettarr.c"
+ };
+
+ /* Register protocol */
+ proto_wlancertextn = proto_register_protocol(PNAME, PSNAME, PFNAME);
+
+ /* Register fields and subtrees */
+ proto_register_field_array(proto_wlancertextn, hf, array_length(hf));
+ proto_register_subtree_array(ett, array_length(ett));
+
+}
+
+
+/*--- proto_reg_handoff_wlancertextn -------------------------------------------*/
+void proto_reg_handoff_wlancertextn(void) {
+#include "packet-wlancertextn-dis-tab.c"
+ oid_add_from_string("id-kp-eapOverPPP","1.3.6.1.5.5.7.3.13");
+ oid_add_from_string("id-kp-eapOverLAN","1.3.6.1.5.5.7.3.14");
+}
+
diff --git a/epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.h b/epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.h
new file mode 100644
index 00000000..944a74d5
--- /dev/null
+++ b/epan/dissectors/asn1/wlancertextn/packet-wlancertextn-template.h
@@ -0,0 +1,18 @@
+/* packet-wlancertextn.h
+ * Routines for Wireless Certificate Extensions (RFC3770) packet dissection
+ * Ronnie Sahlberg 2005
+ *
+ * Wireshark - Network traffic analyzer
+ * By Gerald Combs <gerald@wireshark.org>
+ * Copyright 1998 Gerald Combs
+ *
+ * SPDX-License-Identifier: GPL-2.0-or-later
+ */
+
+#ifndef PACKET_WLANCERTEXTN_H
+#define PACKET_WLANCERTEXTN_H
+
+/*#include "packet-wlancertextn-exp.h"*/
+
+#endif /* PACKET_WLANCERTEXTN_H */
+
diff --git a/epan/dissectors/asn1/wlancertextn/wlancertextn.cnf b/epan/dissectors/asn1/wlancertextn/wlancertextn.cnf
new file mode 100644
index 00000000..2a867029
--- /dev/null
+++ b/epan/dissectors/asn1/wlancertextn/wlancertextn.cnf
@@ -0,0 +1,21 @@
+# WlanCertExtn.cnf
+# WlanCertExtn conformation file
+
+#.MODULE_IMPORT
+
+#.EXPORTS
+
+#.REGISTER
+
+SSIDList B "1.3.6.1.5.5.7.1.13" "id-pe-wlanSSID"
+SSIDList B "1.3.6.1.5.5.7.10.6" "id-aca-wlanSSID"
+
+#.NO_EMIT
+
+#.TYPE_RENAME
+
+#.FIELD_RENAME
+
+#.END
+
+