summaryrefslogtreecommitdiffstats
path: root/packaging/wix
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:14:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:14:33 +0000
commit9f153fbfec0fb9c9ce38e749a7c6f4a5e115d4e9 (patch)
tree2784370cda9bbf2da9114d70f05399c0b229d28c /packaging/wix
parentAdding debian version 4.2.6-1. (diff)
downloadwireshark-9f153fbfec0fb9c9ce38e749a7c6f4a5e115d4e9.tar.xz
wireshark-9f153fbfec0fb9c9ce38e749a7c6f4a5e115d4e9.zip
Merging upstream version 4.4.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'packaging/wix')
-rw-r--r--packaging/wix/CMakeLists.txt17
-rw-r--r--packaging/wix/ComponentGroups.wxi48
-rw-r--r--packaging/wix/DirectoryStructure.wxi4
-rw-r--r--packaging/wix/Features.wxi2
-rw-r--r--packaging/wix/InputPaths.wxi2
-rw-r--r--packaging/wix/WiresharkOptionsDlg.wxs2
6 files changed, 43 insertions, 32 deletions
diff --git a/packaging/wix/CMakeLists.txt b/packaging/wix/CMakeLists.txt
index eb9079e7..02dfbdd5 100644
--- a/packaging/wix/CMakeLists.txt
+++ b/packaging/wix/CMakeLists.txt
@@ -60,7 +60,7 @@ set(PROGRAM_NAME ${CMAKE_PROJECT_NAME})
file(TO_NATIVE_PATH "${CMAKE_SOURCE_DIR}" TOP_SRC_DIR)
# STAGING_DIR depends on the build configuration so we pass it
# on the command line below.
-file(TO_NATIVE_PATH "${CMAKE_BINARY_DIR}/docbook" DOCBOOK_DIR)
+file(TO_NATIVE_PATH "${CMAKE_BINARY_DIR}/doc" DOC_DIR)
# To do:
# - Sync the various version names between CMake and Wix.
@@ -126,11 +126,11 @@ foreach(_dll ${GLIB2_DLLS_RELEASE})
endforeach()
file(APPEND "${_all_manifest_wix}" " <?endif?>\n")
SET(unique_component "")
-set (_dll_list ${CARES_DLL} ${PCRE2_RELEASE_DLL} ${GCRYPT_DLLS}
+set (_dll_list ${AMRNB_DLL} ${CARES_DLL} ${PCRE2_RELEASE_DLL} ${GCRYPT_DLLS}
${GNUTLS_DLLS} ${KERBEROS_DLLS} ${LIBSSH_DLLS} ${LUA_DLL}
- ${LZ4_DLL} ${MINIZIP_DLL} ${NGHTTP2_DLL} ${NGHTTP3_DLL} ${SBC_DLL} ${SMI_DLL}
+ ${LZ4_DLL} ${MINIZIP_DLL} ${MINIZIPNG_DLLS} ${NGHTTP2_DLL} ${NGHTTP3_DLL} ${SBC_DLL} ${SMI_DLL}
${SNAPPY_DLL} ${SPANDSP_DLL} ${BCG729_DLL} ${LIBXML2_DLLS} ${WINSPARKLE_DLL}
- ${ZLIB_DLL} ${BROTLI_DLLS} ${ZSTD_DLL} ${ILBC_DLL} ${OPUS_DLL}
+ ${ZLIB_DLL} ${ZLIBNG_DLL} ${BROTLI_DLLS} ${ZSTD_DLL} ${ILBC_DLL} ${OPUS_DLL}
${SPEEXDSP_DLL}
# Required for mmdbresolve
${MAXMINDDB_DLL}
@@ -196,7 +196,7 @@ set(WIX_CANDLE_DEFINES
-dQtTranslationDir=${ARCHIVE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/translations
-dRadiusDictDir=${ARCHIVE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/radius
-dSnmpMibDir=${ARCHIVE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/snmp/mibs
- -dUsersGuideDir=${ARCHIVE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/docbook/wsug_html_chunked
+ -dUsersGuideDir=${ARCHIVE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/doc/wsug_html_chunked
-dVCRedistVersion=${MSVC_CRT_VERSION}
-dVCRedistDir=${MERGE_MODULE_DIR}
${d_smi_dir}
@@ -252,7 +252,7 @@ macro( ADD_WIX_PACKAGE_TARGET )
# UsersGuide.wxs. Collects the contents of wsug_html_chunked.
# Generated with heat.exe
add_custom_command(OUTPUT ${_wix_binary_dir}/UsersGuide.wxs
- COMMAND ${WIX_HEAT_EXECUTABLE} dir ${CMAKE_BINARY_DIR}/docbook/wsug_html_chunked
+ COMMAND ${WIX_HEAT_EXECUTABLE} dir ${CMAKE_BINARY_DIR}/doc/wsug_html_chunked
${WIX_HEAT_FLAGS} -cg CG.Documentation -dr dirUsersGuide -var var.UsersGuideDir
-out ${_wix_binary_dir}/UsersGuide.wxs
)
@@ -297,8 +297,9 @@ macro( ADD_WIX_PACKAGE_TARGET )
DEPENDS
${WIX_FILES}
copy_data_files
- user_guide_html
faq_html
+ user_guide_html
+ release_notes_html
)
set_target_properties(wireshark_wix_prep PROPERTIES
FOLDER "Packaging"
@@ -335,7 +336,5 @@ set(CLEAN_FILES
RadiusDict.wxs
Diameter.wxs
QtTranslation.wxs
- #NEWS.txt
- #user-guide.chm
wireshark-${VERSION}-${WIRESHARK_TARGET_PLATFORM}.msi
)
diff --git a/packaging/wix/ComponentGroups.wxi b/packaging/wix/ComponentGroups.wxi
index 8a649732..0c2156af 100644
--- a/packaging/wix/ComponentGroups.wxi
+++ b/packaging/wix/ComponentGroups.wxi
@@ -1,4 +1,4 @@
-<?xml version="1.0" encoding="utf-8"?>
+<?xml version="1.0" encoding="utf-8"?>
<Include>
<!-- Wireshark -->
@@ -30,15 +30,9 @@
<Component Id="cmpCOPYING_txt" Guid="*">
<File Id="filCOPYING_txt" KeyPath="yes" Source="$(var.Staging.Dir)\COPYING.txt" />
</Component>
- <Component Id="cmpNEWS_txt" Guid="*">
- <File Id="filNEWS_txt" KeyPath="yes" Source="$(var.Staging.Dir)\NEWS.txt" />
- </Component>
<Component Id="cmpREADME_txt" Guid="*">
<File Id="filREADME_txt" KeyPath="yes" Source="$(var.Staging.Dir)\README.txt" />
</Component>
- <Component Id="cmpREADME_windows_txt" Guid="*">
- <File Id="filREADME_windows_txt" KeyPath="yes" Source="$(var.Staging.Dir)\README.windows.txt" />
- </Component>
<Component Id="cmpWka" Guid="*">
<File Id="filWka" KeyPath="yes" Source="$(var.Staging.Dir)\wka" />
</Component>
@@ -67,7 +61,7 @@
<File Id="filIpmap_html" KeyPath="yes" Source="$(var.Staging.Dir)\ipmap.html" />
</Component>
<Component Id="cmpReleaseNotes_html" Guid="*">
- <File Id="filReleaseNotes_html" KeyPath="yes" Source="$(var.Staging.Dir)\release-notes.html" />
+ <File Id="filReleaseNotes_html" KeyPath="yes" Source="$(var.Staging.Dir)\release-notes.html" Name="Release Notes.html" />
</Component>
</DirectoryRef>
</Fragment>
@@ -77,9 +71,7 @@
<ComponentRef Id="cmpLibwireshark_dll" />
<ComponentRef Id="cmpLibwsutil_dll" />
<ComponentRef Id="cmpCOPYING_txt" />
- <ComponentRef Id="cmpNEWS_txt" />
<ComponentRef Id="cmpREADME_txt" />
- <ComponentRef Id="cmpREADME_windows_txt" />
<ComponentRef Id="cmpWka" />
<ComponentRef Id="cmpPdml2html_xsl" />
<ComponentRef Id="cmpWs_css" />
@@ -461,7 +453,7 @@
<!-- Androiddump -->
<Fragment>
- <DirectoryRef Id="dirExtcap">
+ <DirectoryRef Id="dirExtcapWireshark">
<Component Id="cmpAndroiddump_exe" Guid="*">
<File Id="filAndroiddump_exe" KeyPath="yes" Source="$(var.Extcap.Dir)\androiddump.exe" />
</Component>
@@ -481,7 +473,7 @@
<!-- Randpktdump -->
<Fragment>
- <DirectoryRef Id="dirExtcap">
+ <DirectoryRef Id="dirExtcapWireshark">
<Component Id="cmpRandpktdump_exe" Guid="*">
<File Id="filRandpktdump_exe" KeyPath="yes" Source="$(var.Extcap.Dir)\randpktdump.exe" />
</Component>
@@ -501,7 +493,7 @@
<!-- Etwdump -->
<Fragment>
- <DirectoryRef Id="dirExtcap">
+ <DirectoryRef Id="dirExtcapWireshark">
<Component Id="cmpEtwdump_exe" Guid="*">
<File Id="filEtwdump_exe" KeyPath="yes" Source="$(var.Extcap.Dir)\etwdump.exe" />
</Component>
@@ -521,7 +513,7 @@
<!-- Sshdump -->
<Fragment>
- <DirectoryRef Id="dirExtcap">
+ <DirectoryRef Id="dirExtcapWireshark">
<Component Id="cmpSshdump_exe" Guid="*">
<File Id="filSshdump_exe" KeyPath="yes" Source="$(var.Extcap.Dir)\sshdump.exe" />
</Component>
@@ -541,7 +533,7 @@
<!-- Ciscodump -->
<Fragment>
- <DirectoryRef Id="dirExtcap">
+ <DirectoryRef Id="dirExtcapWireshark">
<Component Id="cmpCiscodump_exe" Guid="*">
<File Id="filCiscodump_exe" KeyPath="yes" Source="$(var.Extcap.Dir)\Ciscodump.exe" />
</Component>
@@ -561,7 +553,7 @@
<!-- Wifidump -->
<Fragment>
- <DirectoryRef Id="dirExtcap">
+ <DirectoryRef Id="dirExtcapWireshark">
<Component Id="cmpWifidump_exe" Guid="*">
<File Id="filWifidump_exe" KeyPath="yes" Source="$(var.Extcap.Dir)\wifidump.exe" />
</Component>
@@ -581,7 +573,7 @@
<!-- Udpdump -->
<Fragment>
- <DirectoryRef Id="dirExtcap">
+ <DirectoryRef Id="dirExtcapWireshark">
<Component Id="cmpUdpdump_exe" Guid="*">
<File Id="filUdpdump_exe" KeyPath="yes" Source="$(var.Extcap.Dir)\Udpdump.exe" />
</Component>
@@ -599,13 +591,13 @@
</ComponentGroup>
</Fragment>
- <?ifdef DOCBOOK_DIR?>
+ <?ifdef DOC_DIR?>
<!-- User Guide is created by heat -->
<!-- FAQ -->
<Fragment>
<DirectoryRef Id="INSTALLFOLDER">
<Component Id="cmpFAQ_html" Guid="*">
- <File Id="filFAQ_html" KeyPath="yes" Source="$(var.DOCBOOK_DIR)\faq.html" />
+ <File Id="filFAQ_html" KeyPath="yes" Source="$(var.DOC_DIR)\faq.html" />
</Component>
</DirectoryRef>
</Fragment>
@@ -702,6 +694,15 @@
<RegistryValue Root="HKCU" Key="Software\$(var.WiresharkName)" Name="cap" Type="integer" Value="1" KeyPath="yes"/>
<Condition>WIRESHARK_FILE_EXTENSIONS = "1"</Condition>
</Component>
+ <Component Id="cmpFAems">
+ <ProgId Id="$(var.WiresharkFileAssociation)" Description="ems">
+ <Extension Id="ems">
+ <Verb Id="open" Command="open" TargetFile="filWireshark_exe" Argument="&quot;%1&quot;"/>
+ </Extension>
+ </ProgId>
+ <RegistryValue Root="HKCU" Key="Software\$(var.WiresharkName)" Name="ems" Type="integer" Value="1" KeyPath="yes"/>
+ <Condition>WIRESHARK_FILE_EXTENSIONS = "1"</Condition>
+ </Component>
<Component Id="cmpFAenc">
<ProgId Id="$(var.WiresharkFileAssociation)" Description="enc">
<Extension Id="enc">
@@ -819,6 +820,15 @@
<RegistryValue Root="HKCU" Key="Software\$(var.WiresharkName)" Name="rf5" Type="integer" Value="1" KeyPath="yes"/>
<Condition>WIRESHARK_FILE_EXTENSIONS = "1"</Condition>
</Component>
+ <Component Id="cmpFAscap">
+ <ProgId Id="$(var.WiresharkFileAssociation)" Description="scap">
+ <Extension Id="scap">
+ <Verb Id="open" Command="open" TargetFile="filWireshark_exe" Argument="&quot;%1&quot;"/>
+ </Extension>
+ </ProgId>
+ <RegistryValue Root="HKCU" Key="Software\$(var.WiresharkName)" Name="scap" Type="integer" Value="1" KeyPath="yes"/>
+ <Condition>WIRESHARK_FILE_EXTENSIONS = "1"</Condition>
+ </Component>
<Component Id="cmpFAsnoop">
<ProgId Id="$(var.WiresharkFileAssociation)" Description="snoop">
<Extension Id="snoop">
diff --git a/packaging/wix/DirectoryStructure.wxi b/packaging/wix/DirectoryStructure.wxi
index f06297ed..8452558d 100644
--- a/packaging/wix/DirectoryStructure.wxi
+++ b/packaging/wix/DirectoryStructure.wxi
@@ -13,7 +13,9 @@
<Directory Id="INSTALLFOLDER" Name="$(var.WiresharkName)">
<Directory Id="dirDtds" Name="dtds"/>
<Directory Id="dirDiameter" Name="diameter"/>
- <Directory Id="dirExtcap" Name="extcap"/>
+ <Directory Id="dirExtcap" Name="extcap">
+ <Directory Id="dirExtcapWireshark" Name="wireshark"/>
+ </Directory>
<Directory Id="dirHelp" Name="help"/>
<Directory Id="dirRadius" Name="radius"/>
<Directory Id="dirPlugins" Name="plugins">
diff --git a/packaging/wix/Features.wxi b/packaging/wix/Features.wxi
index ffaa4d60..8cf7ccc5 100644
--- a/packaging/wix/Features.wxi
+++ b/packaging/wix/Features.wxi
@@ -109,7 +109,7 @@
<ComponentGroupRef Id="CG.Tools.Wifidump" />
</Feature>
</Feature>
- <?ifdef DOCBOOK_DIR?>
+ <?ifdef DOC_DIR?>
<Feature Id="Fe.Documentation" Title="Documentation" Level="1" AllowAdvertise="yes" Display="expand" Description="Install an offline copy of the User's Guide and FAQ.">
<ComponentGroupRef Id="CG.Documentation" />
</Feature>
diff --git a/packaging/wix/InputPaths.wxi b/packaging/wix/InputPaths.wxi
index 5ff62355..782113d4 100644
--- a/packaging/wix/InputPaths.wxi
+++ b/packaging/wix/InputPaths.wxi
@@ -10,7 +10,7 @@
<?define Staging.Dir ="$(var.BuildOutputDir)" ?>
<?define Plugins.Dir ="$(var.Staging.Dir)\plugins" ?>
<?define Profiles.Dir ="$(var.Staging.Dir)\profiles" ?>
- <?define Extcap.Dir ="$(var.Staging.Dir)\extcap" ?>
+ <?define Extcap.Dir ="$(var.Staging.Dir)\extcap\wireshark" ?>
<?define WiresharkQt.Dir ="$(var.Staging.Dir)" ?>
<?define Dtds.Dir ="$(var.Staging.Dir)\dtds" ?>
<?define Tpncp.Dir ="$(var.Staging.Dir)\tpncp" ?>
diff --git a/packaging/wix/WiresharkOptionsDlg.wxs b/packaging/wix/WiresharkOptionsDlg.wxs
index 0790ccd2..c64c77f0 100644
--- a/packaging/wix/WiresharkOptionsDlg.wxs
+++ b/packaging/wix/WiresharkOptionsDlg.wxs
@@ -52,7 +52,7 @@
<Condition Action="disable"><![CDATA[&Fe.Wireshark <> 3]]></Condition>
</Control>
<Control Id="FileExtensionsText1" Type="Text" X="20" Y="206" Width="350" Height="11" Transparent="yes" NoPrefix="yes" Text="Extensions include 5vw, acp, apc, atc, bfr, cap, enc, erf, fdc, lcap, mplog, ntar, out,"/>
- <Control Id="FileExtensionsText2" Type="Text" X="20" Y="217" Width="350" Height="11" Transparent="yes" NoPrefix="yes" Text="pcap, pcapng, pkt, rf5, snoop, syc, tpc, tr1, trace, trc, vwr, wpc, and wpz."/>
+ <Control Id="FileExtensionsText2" Type="Text" X="20" Y="217" Width="350" Height="11" Transparent="yes" NoPrefix="yes" Text="pcap, pcapng, pkt, rf5, scap, snoop, syc, tpc, tr1, trace, trc, vwr, wpc, and wpz."/>
<Control Id="BottomLine" Type="Line" X="0" Y="234" Width="370" Height="0"/>
<Control Id="Back" Type="PushButton" X="180" Y="243" Width="56" Height="17" Text="!(loc.WixUIBack)"/>