summaryrefslogtreecommitdiffstats
path: root/tools/release-update-debian-soversions.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
commite4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc (patch)
tree68cb5ef9081156392f1dd62a00c6ccc1451b93df /tools/release-update-debian-soversions.sh
parentInitial commit. (diff)
downloadwireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.tar.xz
wireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.zip
Adding upstream version 4.2.2.upstream/4.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tools/release-update-debian-soversions.sh')
-rwxr-xr-xtools/release-update-debian-soversions.sh23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/release-update-debian-soversions.sh b/tools/release-update-debian-soversions.sh
new file mode 100755
index 0000000..e788d71
--- /dev/null
+++ b/tools/release-update-debian-soversions.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# Compare ABIs of two Wireshark working copies
+#
+# Copyright 2017 Balint Reczey <balint.reczey@canonical.com>
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+# Set shared library package names and library versions in Debian packaging
+# matching the new major release's so versions
+
+set -e
+
+for i in codecs wireshark wiretap wsutil; do
+ NEW_VERSION=$(grep SOVERSION "$(grep -l lib${i} ./*/CMakeLists.txt)" | sed 's/.*SOVERSION \([0-9]*\).*/\1/')
+ rename "s/0\\./${NEW_VERSION}./" packaging/debian/lib${i}0.*
+ grep -l -R "lib${i}0" packaging/debian/ | xargs sed -i "s/lib${i}0/lib${i}${NEW_VERSION}/"
+ grep -l -R "lib${i}\\.so\\.0" packaging/debian/ | xargs sed -i "s/lib${i}\\.so\\.0/lib${i}.so.${NEW_VERSION}/"
+done