summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control2
-rw-r--r--debian/control.in2
-rw-r--r--debian/control.t64.in2
-rwxr-xr-xdebian/rules6
5 files changed, 20 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 4238a5bf..20795e98 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+wireshark (4.2.6-1) unstable; urgency=medium
+
+ * Build depend on libssh-dev instead of libssh-gcrypt-dev on latest
+ distribution releases. This is made possible by OpenSSL switching
+ its license to Apache 2.0.
+ (Closes: #1074268)
+ * New upstream version:
+ - security fixes:
+ - The SPRT dissector could crash
+
+ -- Balint Reczey <balint@balintreczey.hu> Thu, 11 Jul 2024 23:26:26 +0200
+
wireshark (4.2.5-2) sid; urgency=medium
* debian/rules: Keep the t64 transition when targeting sid or oracular
diff --git a/debian/control b/debian/control
index dd4939cb..2c5362b0 100644
--- a/debian/control
+++ b/debian/control
@@ -43,7 +43,7 @@ Build-Depends: dpkg-dev (>= 1.22.5),
libsbc-dev,
libnghttp2-dev,
libnghttp3-dev,
- libssh-gcrypt-dev,
+ libssh-dev,
liblz4-dev,
libsnappy-dev,
libzstd-dev,
diff --git a/debian/control.in b/debian/control.in
index e8f06ae5..4de467c2 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -38,7 +38,7 @@ Build-Depends: @QT_BUILD_DEPS@,
libsbc-dev,
libnghttp2-dev,
libnghttp3-dev,
- libssh-gcrypt-dev,
+ @LIBSSH_DEV@,
liblz4-dev,
libsnappy-dev,
libzstd-dev,
diff --git a/debian/control.t64.in b/debian/control.t64.in
index 991c47b7..811f467b 100644
--- a/debian/control.t64.in
+++ b/debian/control.t64.in
@@ -39,7 +39,7 @@ Build-Depends: dpkg-dev (>= 1.22.5),
libsbc-dev,
libnghttp2-dev,
libnghttp3-dev,
- libssh-gcrypt-dev,
+ @LIBSSH_DEV@,
liblz4-dev,
libsnappy-dev,
libzstd-dev,
diff --git a/debian/rules b/debian/rules
index bec1a95a..58e50c04 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,7 +25,11 @@ endif
ifneq ($(filter focal,$(DEB_DISTRIBUTION)),)
CONTROL_IN_SED_CMD := $(CONTROL_IN_SED_CMD)s/^ *libbcg729-dev/\# libbcg729-dev/;s/^ *libnghttp3-dev/\# libnghttp3-dev/;
endif
-
+ifneq ($(filter noble oracular unstable sid testing trixie UNRELEASED,$(DEB_DISTRIBUTION)),)
+CONTROL_IN_SED_CMD := $(CONTROL_IN_SED_CMD)s/@LIBSSH_DEV@/libssh-dev/;
+else
+CONTROL_IN_SED_CMD := $(CONTROL_IN_SED_CMD)s/@LIBSSH_DEV@/libssh-gcrypt-dev/;
+endif
# This has to be exported to make some magic below work.
export DH_OPTIONS