summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xdebian/rules14
1 files changed, 4 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index 9000fb5b..b598434f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,7 +53,7 @@ override_dh_auto_build-indep:
dh_auto_build -i
$(MAKE) -C $(CURDIR)/obj-* user_guide_html developer_guide_html
# fix links in documentation
- sed -i "s|$(CURDIR)/docbook|..|" obj-*/docbook/ws*g_html_chunked/*.html
+ sed -i "s|$(CURDIR)/doc|..|" obj-*/doc/ws*g_html_chunked/*.html
override_dh_dwz:
# run dh_dwz only with debhelper (>= 12.6) to work around https://bugs.debian.org/939164
@@ -86,11 +86,11 @@ override_dh_fixperms-arch:
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
$(MAKE) -C obj-* test-programs
-ifneq (,$(filter armel armhf hppa mips mipsel s390x,$(DEB_HOST_ARCH)))
+ifneq (,$(filter hppa m68k powerpc ppc64 sparc64 s390x,$(DEB_HOST_ARCH)))
# reported as https://gitlab.com/wireshark/wireshark/-/issues/15945
- -dh_auto_test
+ -env LC_ALL=C.UTF-8 dh_auto_test
else
- dh_auto_test
+ env LC_ALL=C.UTF-8 dh_auto_test
endif
endif
@@ -98,11 +98,5 @@ override_dh_clean:
dh_clean -- debian/control
# regenerate debian/control
sed "$(CONTROL_IN_SED_CMD)" debian/control.in > debian/control
- # also revert t64-related changes in backports
- for f in debian/lib*t64*; do \
- [ -f $$f ] || continue; \
- sed -i 's/\([0-9]\)t64/\1/g' $$f; \
- echo $$f | sed 's/t64//' | xargs mv $$f; \
- done
# ignore #653916
@echo 'blhc: ignore-line-regexp: .*CMakeCXXCompilerABI.cpp .*'