summaryrefslogtreecommitdiffstats
path: root/tools/lemon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/lemon/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/tools/lemon/CMakeLists.txt b/tools/lemon/CMakeLists.txt
new file mode 100644
index 0000000..529eeae
--- /dev/null
+++ b/tools/lemon/CMakeLists.txt
@@ -0,0 +1,46 @@
+# CMakeLists.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+
+add_executable(lemon lemon.c)
+
+if(DEFINED LEMON_C_COMPILER)
+ set(CMAKE_C_COMPILER "${LEMON_C_COMPILER}")
+ set(CMAKE_C_FLAGS "")
+endif()
+
+# To keep lemon.c as close to upstream as possible disable all warnings
+if(CMAKE_C_COMPILER_ID MATCHES "MSVC")
+ target_compile_options(lemon PRIVATE /w)
+else()
+ target_compile_options(lemon PRIVATE -w)
+endif()
+if(CMAKE_C_COMPILER_ID MATCHES "Clang")
+ # Disable static analysis for lemon source code. These issues don't
+ # affect Wireshark at runtime.
+ target_compile_options(lemon PRIVATE -Xclang -analyzer-disable-all-checks)
+endif()
+if(DEFINED NO_SANITIZE_CFLAGS)
+ target_compile_options(lemon PRIVATE ${NO_SANITIZE_CFLAGS})
+endif()
+if(DEFINED NO_SANITIZE_LDFLAGS)
+ target_link_options(lemon PRIVATE ${NO_SANITIZE_LDFLAGS})
+endif()
+
+#
+# Editor modelines - https://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#