summaryrefslogtreecommitdiffstats
path: root/tools/macos-setup-patches
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/macos-setup-patches/falco-include-dirs.patch15
-rw-r--r--tools/macos-setup-patches/falco-uthash_h-install.patch9
-rw-r--r--tools/macos-setup-patches/glib-pkgconfig.patch (renamed from macosx-support-lib-patches/glib-pkgconfig.patch)0
-rw-r--r--tools/macos-setup-patches/gnutls-pkgconfig.patch (renamed from macosx-support-lib-patches/gnutls-pkgconfig.patch)0
-rwxr-xr-xtools/macos-setup-patches/qt-fix-pc-file (renamed from macosx-support-lib-patches/qt-fix-pc-file)0
-rwxr-xr-xtools/macos-setup-patches/qt-fix-pc-files (renamed from macosx-support-lib-patches/qt-fix-pc-files)2
-rw-r--r--tools/macos-setup-patches/snappy-signed.patch (renamed from macosx-support-lib-patches/snappy-signed.patch)0
-rw-r--r--tools/macos-setup-patches/spandsp-configure-patch (renamed from macosx-support-lib-patches/spandsp-configure-patch)0
8 files changed, 25 insertions, 1 deletions
diff --git a/tools/macos-setup-patches/falco-include-dirs.patch b/tools/macos-setup-patches/falco-include-dirs.patch
new file mode 100644
index 00000000..68f5f228
--- /dev/null
+++ b/tools/macos-setup-patches/falco-include-dirs.patch
@@ -0,0 +1,15 @@
+758865ee6 update(cmake): Don't add build directories to our pc files
+diff --git a/userspace/libsinsp/CMakeLists.txt b/userspace/libsinsp/CMakeLists.txt
+index 6104603e8..1989ea3fb 100644
+--- a/userspace/libsinsp/CMakeLists.txt
++++ b/userspace/libsinsp/CMakeLists.txt
+@@ -335,6 +335,9 @@ endforeach()
+ # Build our pkg-config "Cflags:" flags.
+ set(SINSP_PKG_CONFIG_INCLUDES "")
+ foreach(sinsp_include_directory ${LIBSINSP_INCLUDE_DIRS})
++ if (${sinsp_include_directory} MATCHES "^${CMAKE_SOURCE_DIR}" OR ${sinsp_include_directory} MATCHES "^${CMAKE_BINARY_DIR}")
++ continue()
++ endif()
+ list(APPEND SINSP_PKG_CONFIG_INCLUDES -I${sinsp_include_directory})
+ endforeach()
+
diff --git a/tools/macos-setup-patches/falco-uthash_h-install.patch b/tools/macos-setup-patches/falco-uthash_h-install.patch
new file mode 100644
index 00000000..7e1f7855
--- /dev/null
+++ b/tools/macos-setup-patches/falco-uthash_h-install.patch
@@ -0,0 +1,9 @@
+--- falco-libs-0.14.1/cmake/modules/libscap.cmake.orig 2024-03-25 22:46:40
++++ falco-libs-0.14.1/cmake/modules/libscap.cmake 2024-03-25 22:46:10
+@@ -139,5 +139,6 @@
+ FILES_MATCHING PATTERN "*.h")
+ install(FILES ${PROJECT_BINARY_DIR}/libscap/scap_config.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${LIBS_PACKAGE_NAME}/libscap)
+ install(FILES ${PROJECT_BINARY_DIR}/libscap/scap_strl_config.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${LIBS_PACKAGE_NAME}/libscap)
++install(FILES ${PROJECT_BINARY_DIR}/uthash-prefix/src/uthash/src/uthash.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${LIBS_PACKAGE_NAME}/libscap)
+ install(FILES ${PROJECT_BINARY_DIR}/libscap/libscap.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
diff --git a/macosx-support-lib-patches/glib-pkgconfig.patch b/tools/macos-setup-patches/glib-pkgconfig.patch
index 07761460..07761460 100644
--- a/macosx-support-lib-patches/glib-pkgconfig.patch
+++ b/tools/macos-setup-patches/glib-pkgconfig.patch
diff --git a/macosx-support-lib-patches/gnutls-pkgconfig.patch b/tools/macos-setup-patches/gnutls-pkgconfig.patch
index f0ad93ec..f0ad93ec 100644
--- a/macosx-support-lib-patches/gnutls-pkgconfig.patch
+++ b/tools/macos-setup-patches/gnutls-pkgconfig.patch
diff --git a/macosx-support-lib-patches/qt-fix-pc-file b/tools/macos-setup-patches/qt-fix-pc-file
index fa9ba54b..fa9ba54b 100755
--- a/macosx-support-lib-patches/qt-fix-pc-file
+++ b/tools/macos-setup-patches/qt-fix-pc-file
diff --git a/macosx-support-lib-patches/qt-fix-pc-files b/tools/macos-setup-patches/qt-fix-pc-files
index 87dc3966..d30edb07 100755
--- a/macosx-support-lib-patches/qt-fix-pc-files
+++ b/tools/macos-setup-patches/qt-fix-pc-files
@@ -18,4 +18,4 @@ then
echo "Usage: qt-fix-pc-files <top-level Qt directory>" 1>&1
exit 1
fi
-find "$1" -name "*.pc" -exec macosx-support-lib-patches/qt-fix-pc-file {} ";"
+find "$1" -name "*.pc" -exec tools/macos-setup-patches/qt-fix-pc-file {} ";"
diff --git a/macosx-support-lib-patches/snappy-signed.patch b/tools/macos-setup-patches/snappy-signed.patch
index 0018fcc4..0018fcc4 100644
--- a/macosx-support-lib-patches/snappy-signed.patch
+++ b/tools/macos-setup-patches/snappy-signed.patch
diff --git a/macosx-support-lib-patches/spandsp-configure-patch b/tools/macos-setup-patches/spandsp-configure-patch
index 5a898f99..5a898f99 100644
--- a/macosx-support-lib-patches/spandsp-configure-patch
+++ b/tools/macos-setup-patches/spandsp-configure-patch