summaryrefslogtreecommitdiffstats
path: root/tools/pidl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xtools/pidl/Makefile.PL17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/pidl/Makefile.PL b/tools/pidl/Makefile.PL
new file mode 100755
index 0000000..2a405fc
--- /dev/null
+++ b/tools/pidl/Makefile.PL
@@ -0,0 +1,17 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ 'NAME' => 'Parse::Pidl',
+ 'VERSION_FROM' => 'lib/Parse/Pidl.pm',
+ 'EXE_FILES' => [ 'pidl' ],
+ 'test' => { 'TESTS' => 'tests/*.pl' }
+);
+
+sub MY::postamble {
+<<'EOT';
+lib/Parse/Pidl/IDL.pm: idl.yp
+ yapp -m 'Parse::Pidl::IDL' -o lib/Parse/Pidl/IDL.pm idl.yp
+
+lib/Parse/Pidl/Expr.pm: expr.yp
+ yapp -m 'Parse::Pidl::Expr' -o lib/Parse/Pidl/Expr.pm expr.yp
+EOT
+}