summaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt26
1 files changed, 25 insertions, 1 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 6a1aab9a..3308d6f2 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -22,6 +22,7 @@ set(WIRESHARK_WIDGET_HEADERS
widgets/capture_filter_combo.h
widgets/capture_filter_edit.h
widgets/clickable_label.h
+ widgets/compression_group_box.h
widgets/copy_from_profile_button.h
widgets/detachable_tabwidget.h
widgets/display_filter_combo.h
@@ -45,7 +46,13 @@ set(WIRESHARK_WIDGET_HEADERS
widgets/path_selection_edit.h
widgets/pref_module_view.h
widgets/profile_tree_view.h
+ widgets/qcp_axis_ticker_elided.h
+ widgets/qcp_axis_ticker_si.h
+ widgets/qcp_string_legend_item.h
widgets/range_syntax_lineedit.h
+ widgets/resize_header_view.h
+ widgets/resolved_addresses_view.h
+ widgets/rowmove_tree_view.h
widgets/rtp_audio_graph.h
widgets/splash_overlay.h
widgets/stock_icon_tool_button.h
@@ -73,6 +80,7 @@ set(WIRESHARK_UTILS_HEADERS
utils/field_information.h
utils/frame_information.h
utils/idata_printable.h
+ utils/profile_switcher.h
utils/proto_node.h
utils/qt_ui_utils.h
utils/rtp_audio_file.h
@@ -140,6 +148,7 @@ set(WIRESHARK_QT_HEADERS
bluetooth_devices_dialog.h
bluetooth_hci_summary_dialog.h
byte_view_tab.h
+ capture_comment_dialog.h
capture_file_dialog.h
capture_file_properties_dialog.h
capture_file.h
@@ -171,7 +180,6 @@ set(WIRESHARK_QT_HEADERS
file_set_dialog.h
filter_action.h
filter_dialog.h
- filter_dialog.h
filter_expression_frame.h
firewall_rules_dialog.h
follow_stream_action.h
@@ -189,6 +197,7 @@ set(WIRESHARK_QT_HEADERS
interface_toolbar_reader.h
interface_toolbar.h
io_console_dialog.h
+ io_graph_action.h
io_graph_dialog.h
layout_preferences_frame.h
lbm_lbtrm_transport_dialog.h
@@ -282,6 +291,7 @@ set(WIRESHARK_WIDGET_SRCS
widgets/capture_filter_combo.cpp
widgets/capture_filter_edit.cpp
widgets/clickable_label.cpp
+ widgets/compression_group_box.cpp
widgets/copy_from_profile_button.cpp
widgets/detachable_tabwidget.cpp
widgets/display_filter_combo.cpp
@@ -305,7 +315,13 @@ set(WIRESHARK_WIDGET_SRCS
widgets/path_selection_edit.cpp
widgets/pref_module_view.cpp
widgets/profile_tree_view.cpp
+ widgets/qcp_axis_ticker_elided.cpp
+ widgets/qcp_axis_ticker_si.cpp
+ widgets/qcp_string_legend_item.cpp
widgets/range_syntax_lineedit.cpp
+ widgets/resize_header_view.cpp
+ widgets/resolved_addresses_view.cpp
+ widgets/rowmove_tree_view.cpp
widgets/rtp_audio_graph.cpp
widgets/splash_overlay.cpp
widgets/stock_icon_tool_button.cpp
@@ -332,6 +348,7 @@ set(WIRESHARK_UTILS_SRCS
utils/data_printer.cpp
utils/field_information.cpp
utils/frame_information.cpp
+ utils/profile_switcher.cpp
utils/proto_node.cpp
utils/qt_ui_utils.cpp
utils/rtp_audio_file.cpp
@@ -394,6 +411,7 @@ set(WIRESHARK_QT_SRC
bluetooth_devices_dialog.cpp
bluetooth_hci_summary_dialog.cpp
byte_view_tab.cpp
+ capture_comment_dialog.cpp
capture_file_dialog.cpp
capture_file_properties_dialog.cpp
capture_file.cpp
@@ -439,6 +457,7 @@ set(WIRESHARK_QT_SRC
interface_toolbar_reader.cpp
interface_toolbar.cpp
io_console_dialog.cpp
+ io_graph_action.cpp
layout_preferences_frame.cpp
lbm_lbtrm_transport_dialog.cpp
lbm_lbtru_transport_dialog.cpp
@@ -558,6 +577,7 @@ set(WIRESHARK_QT_UI
bluetooth_device_dialog.ui
bluetooth_devices_dialog.ui
bluetooth_hci_summary_dialog.ui
+ capture_comment_dialog.ui
capture_file_properties_dialog.ui
capture_info_dialog.ui
capture_options_dialog.ui
@@ -799,6 +819,9 @@ if(USE_qt6)
if(Qt6Multimedia_FOUND)
target_link_libraries(qtui PUBLIC Qt6::Multimedia)
endif()
+ if(Qt6DBus_FOUND)
+ target_link_libraries(qtui PUBLIC Qt6::DBus)
+ endif()
endif()
target_include_directories(qtui
@@ -810,6 +833,7 @@ target_include_directories(qtui
${QT5_INCLUDE_DIRS}
${GCRYPT_INCLUDE_DIRS}
${MINIZIP_INCLUDE_DIRS}
+ ${MINIZIPNG_INCLUDE_DIRS}
${PCAP_INCLUDE_DIRS}
${SPEEXDSP_INCLUDE_DIRS}
${WINSPARKLE_INCLUDE_DIRS}