summaryrefslogtreecommitdiffstats
path: root/writecap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'writecap/CMakeLists.txt')
-rw-r--r--writecap/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/writecap/CMakeLists.txt b/writecap/CMakeLists.txt
new file mode 100644
index 00000000..9200a274
--- /dev/null
+++ b/writecap/CMakeLists.txt
@@ -0,0 +1,41 @@
+# CMakeLists.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+
+set(WRITECAP_SRC
+ pcapio.c
+)
+
+set_source_files_properties(
+ ${WRITECAP_SRC}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
+
+
+add_library(writecap STATIC
+ ${WRITECAP_SRC}
+)
+
+set_target_properties(writecap PROPERTIES
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ FOLDER "Libs"
+)
+
+#
+# Editor modelines - https://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#