summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-15 09:41:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-15 09:41:34 +0000
commit25e43e389c26d56f90f2f20e3cee19c808b2a18c (patch)
treefdadca249ffd70901103b3f06a98aeab695c6193 /tests/Makefile.am
parentAdding debian version 5.6.1+really5.4.5-1. (diff)
downloadxz-utils-25e43e389c26d56f90f2f20e3cee19c808b2a18c.tar.xz
xz-utils-25e43e389c26d56f90f2f20e3cee19c808b2a18c.zip
Merging upstream version 5.6.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ebc33a7..d85328d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,26 +1,19 @@
-##
+## SPDX-License-Identifier: 0BSD
## Author: Lasse Collin
-##
-## This file has been put into the public domain.
-## You can do whatever you want with this file.
-##
EXTRA_DIST = \
files \
ossfuzz \
+ tests.cmake \
tuktest.h \
tests.h \
test_files.sh \
test_compress.sh \
- test_compress_prepared_bcj_sparc \
- test_compress_prepared_bcj_x86 \
test_compress_generated_abc \
test_compress_generated_random \
test_compress_generated_text \
test_scripts.sh \
- bcj_test.c \
- compress_prepared_bcj_sparc \
- compress_prepared_bcj_x86 \
+ test_suffix.sh \
xzgrep_expected_output
AM_CPPFLAGS = \
@@ -61,12 +54,16 @@ TESTS = \
test_lzip_decoder \
test_vli \
test_files.sh \
- test_compress_prepared_bcj_sparc \
- test_compress_prepared_bcj_x86 \
+ test_suffix.sh \
test_compress_generated_abc \
test_compress_generated_random \
test_compress_generated_text
+if COND_MICROLZMA
+check_PROGRAMS += test_microlzma
+TESTS += test_microlzma
+endif
+
if COND_SCRIPTS
TESTS += test_scripts.sh
endif