summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am85
1 files changed, 35 insertions, 50 deletions
diff --git a/Makefile.am b/Makefile.am
index f562f90..f6e7363 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,5 @@
-##
+## SPDX-License-Identifier: 0BSD
## Author: Lasse Collin
-##
-## This file has been put into the public domain.
-## You can do whatever you want with this file.
-##
# Use -n to prevent gzip from adding a timestamp to the .gz headers.
GZIP_ENV = -9n
@@ -21,11 +17,11 @@ if COND_DOC
dist_doc_DATA = \
AUTHORS \
COPYING \
+ COPYING.0BSD \
COPYING.GPLv2 \
NEWS \
README \
THANKS \
- TODO \
doc/faq.txt \
doc/history.txt \
doc/xz-file-format.txt \
@@ -38,47 +34,33 @@ dist_examples_DATA = \
doc/examples/02_decompress.c \
doc/examples/03_compress_custom.c \
doc/examples/04_compress_easy_mt.c \
+ doc/examples/11_file_info.c \
doc/examples/Makefile
-
-examplesolddir = $(docdir)/examples_old
-dist_examplesold_DATA = \
- doc/examples_old/xz_pipe_comp.c \
- doc/examples_old/xz_pipe_decomp.c
-
-# Install the Doxygen generated documentation if they were built.
-install-data-local:
- if test -d "$(srcdir)/doc/api" ; then \
- $(MKDIR_P) "$(DESTDIR)$(docdir)/api" && \
- $(INSTALL_DATA) "$(srcdir)"/doc/api/* \
- "$(DESTDIR)$(docdir)/api"; \
- fi
-
-# Remove the Doxygen generated documentation when uninstalling.
-uninstall-local:
- rm -rf "$(DESTDIR)$(docdir)/api"
endif
EXTRA_DIST = \
- po4a \
- extra \
+ cmake \
dos \
doxygen \
+ extra \
+ po4a \
windows \
- macosx \
- cmake \
CMakeLists.txt \
- autogen.sh \
COPYING.GPLv2 \
COPYING.GPLv3 \
COPYING.LGPLv2.1 \
INSTALL.generic \
PACKAGERS \
+ TODO \
+ autogen.sh \
build-aux/manconv.sh \
- build-aux/version.sh
+ build-aux/version.sh \
+ po/xz.pot-header
ACLOCAL_AMFLAGS = -I m4
-# List of man pages to convert to PDF and plain text in the dist-hook target.
+# List of man pages to convert to plain text in the dist-hook target
+# or to PDF in the pdf-local target.
manfiles = \
src/xz/xz.1 \
src/xzdec/xzdec.1 \
@@ -89,42 +71,31 @@ manfiles = \
src/scripts/xzmore.1
# Create ChangeLog from output of "git log --date=iso --stat".
-# Convert the man pages to PDF and plain text (ASCII only) formats.
+# Convert the man pages to plain text (ASCII only) format.
dist-hook:
if test -d "$(srcdir)/.git" && type git > /dev/null 2>&1; then \
( cd "$(srcdir)" && git log --date=iso --stat \
- 6060f7dc76fd6c2a8a1f8e85d0e4d86bb78273e6^..HEAD ) \
+ b69da6d4bb6bb11fc0cf066920791990d2b22a06^..HEAD ) \
> "$(distdir)/ChangeLog"; \
fi
- if type groff > /dev/null 2>&1 && type ps2pdf > /dev/null 2>&1; then \
+ if type groff > /dev/null 2>&1; then \
dest="$(distdir)/doc/man" && \
- $(MKDIR_P) "$$dest/pdf-a4" "$$dest/pdf-letter" "$$dest/txt" && \
+ $(MKDIR_P) "$$dest/txt" && \
for FILE in $(manfiles); do \
BASE=`basename $$FILE .1` && \
- sh "$(srcdir)/build-aux/manconv.sh" pdf a4 \
- < "$(srcdir)/$$FILE" \
- > "$$dest/pdf-a4/$$BASE-a4.pdf" && \
- sh "$(srcdir)/build-aux/manconv.sh" pdf letter \
- < "$(srcdir)/$$FILE" \
- > "$$dest/pdf-letter/$$BASE-letter.pdf" && \
- sh "$(srcdir)/build-aux/manconv.sh" ascii \
+ $(SHELL) "$(srcdir)/build-aux/manconv.sh" ascii \
< "$(srcdir)/$$FILE" \
> "$$dest/txt/$$BASE.txt"; \
done; \
fi
- if test -d "$(srcdir)/doc/api" ; then \
- $(MKDIR_P) "$(distdir)/doc/api" && \
- $(INSTALL_DATA) "$(srcdir)"/doc/api/* \
- "$(distdir)/doc/api"; \
- fi
# This works with GNU tar and gives cleaner package than normal 'make dist'.
-# This also ensures that the man page translations are up to date (dist-hook
+# This also ensures that the translations are up to date (dist-hook
# would be too late for that).
mydist:
- sh "$(srcdir)/src/liblzma/validate_map.sh"
- cd "$(srcdir)/po4a" && sh update-po
- cd "$(srcdir)/doxygen" && sh update-doxygen
+ $(SHELL) "$(srcdir)/src/liblzma/validate_map.sh"
+ cd po && $(MAKE) xz.pot-update
+ cd "$(srcdir)/po4a" && $(SHELL) update-po
VERSION=$(VERSION); \
if test -d "$(srcdir)/.git" && type git > /dev/null 2>&1; then \
SNAPSHOT=`cd "$(srcdir)" && git describe --abbrev=4 | cut -b2-`; \
@@ -132,3 +103,17 @@ mydist:
fi; \
TAR_OPTIONS='--owner=0 --group=0 --numeric-owner --mode=u+rw,go+r-w' \
$(MAKE) VERSION="$$VERSION" dist-gzip
+
+# NOTE: This only creates the PDFs. The install rules are missing.
+pdf-local:
+ dest="doc/man" && \
+ $(MKDIR_P) "$$dest/pdf-a4" "$$dest/pdf-letter" && \
+ for FILE in $(manfiles); do \
+ BASE=`basename $$FILE .1` && \
+ $(SHELL) "$(srcdir)/build-aux/manconv.sh" pdf a4 \
+ < "$(srcdir)/$$FILE" \
+ > "$$dest/pdf-a4/$$BASE-a4.pdf" && \
+ $(SHELL) "$(srcdir)/build-aux/manconv.sh" pdf letter \
+ < "$(srcdir)/$$FILE" \
+ > "$$dest/pdf-letter/$$BASE-letter.pdf"; \
+ done