summaryrefslogtreecommitdiffstats
path: root/src/liblzma/check/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/liblzma/check/Makefile.inc15
1 files changed, 7 insertions, 8 deletions
diff --git a/src/liblzma/check/Makefile.inc b/src/liblzma/check/Makefile.inc
index dc011a3..04cf1ff 100644
--- a/src/liblzma/check/Makefile.inc
+++ b/src/liblzma/check/Makefile.inc
@@ -1,9 +1,8 @@
-##
+## SPDX-License-Identifier: 0BSD
## Author: Lasse Collin
-##
-## This file has been put into the public domain.
-## You can do whatever you want with this file.
-##
+
+## Note: There is no check for COND_CHECK_CRC32 because
+## currently crc32 is always enabled.
EXTRA_DIST += \
check/crc32_tablegen.c \
@@ -12,9 +11,10 @@ EXTRA_DIST += \
liblzma_la_SOURCES += \
check/check.c \
check/check.h \
- check/crc_macros.h
+ check/crc_common.h \
+ check/crc_x86_clmul.h \
+ check/crc32_arm64.h
-if COND_CHECK_CRC32
if COND_SMALL
liblzma_la_SOURCES += check/crc32_small.c
else
@@ -28,7 +28,6 @@ else
liblzma_la_SOURCES += check/crc32_fast.c
endif
endif
-endif
if COND_CHECK_CRC64
if COND_SMALL