summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:49:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:49:24 +0000
commit2415e66f889f38503b73e8ebc5f43ca342390e5c (patch)
treeac48ab69d1d96bae3d83756134921e0d90593aa5 /setup.py
parentInitial commit. (diff)
downloadyt-dlp-2415e66f889f38503b73e8ebc5f43ca342390e5c.tar.xz
yt-dlp-2415e66f889f38503b73e8ebc5f43ca342390e5c.zip
Adding upstream version 2024.03.10.upstream/2024.03.10
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..8d1e6d1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/env python3
+
+# Allow execution from anywhere
+import os
+import sys
+
+sys.path.insert(0, os.path.dirname(os.path.abspath(__file__)))
+
+import warnings
+
+
+if sys.argv[1:2] == ['py2exe']:
+ warnings.warn(DeprecationWarning('`setup.py py2exe` is deprecated and will be removed in a future version. '
+ 'Use `bundle.py2exe` instead'))
+
+ import bundle.py2exe
+
+ bundle.py2exe.main()
+
+elif 'build_lazy_extractors' in sys.argv:
+ warnings.warn(DeprecationWarning('`setup.py build_lazy_extractors` is deprecated and will be removed in a future version. '
+ 'Use `devscripts.make_lazy_extractors` instead'))
+
+ import subprocess
+
+ os.chdir(sys.path[0])
+ print('running build_lazy_extractors')
+ subprocess.run([sys.executable, 'devscripts/make_lazy_extractors.py'])
+
+else:
+
+ print(
+ 'ERROR: Building by calling `setup.py` is deprecated. '
+ 'Use a build frontend like `build` instead. ',
+ 'Refer to https://build.pypa.io for more info', file=sys.stderr)
+ sys.exit(1)